I need bluetooth help

I done File transferred mode

and picture transferred mode.

On windows OS it works fine it just take time to load files, what is to be expected with many pictures.

Which Android version on what phone are you using?

Samsung, android 7 version.

Tomorrow i have access to such a device, will try it out to find a solution.


Just connected a Samsung Galaxy Tab S2, running Android 7 and transfered about 10 GiB over USB using the regular File manager in default MTP mode. No issues. Please check the following things:

  • Reboot your Mobile Phone
  • Verify that your USB cable is in good condition (some cables are meant for charging only and haven’t connected all needed pins)

it says no defualt controller available

it says no default controller available

and I followed everything on the post you made but the thing that stopped the command from working was that "no default controller available "message thing

Can you please run the following commands:

systemctl status bluetooth.service 2>&1 | tee bluetooth.log
journalctl -u bluetooth.service 2>&1 | tee -a bluetooth.log

Then upload the generated file “bluetooth.log” from your home directory here for further analysis.

bluetooth.log (1.5 KB)

OK, it seems that for some reason your Bluetooth Adapter is recognized, but blocked:

  name: hci0
  type: bluetooth
  hard: 0
  soft: 1
  persistent: 0
  state: 0
  driver: btusb

(soft: 1, should be soft: 0)
So, let’s try if we can force to unblock it:

sudo systemctl stop bluetooth
sudo rfkill unblock bluetooth
sudo systemctl start bluetooth

Let me know if that worked. If that worked, we need to make it permanent. Run:

sudo nano /etc/rc.local

Then append the following line:

rfkill unblock bluetooth

Save with Ctrl-O, then Ctrl-X to leave.

i got this when i used the commands

the only result i got from this was from te second line and it said

sudo: rfkill: command not found

idk if the others did any thing

OK …

Save the following script into a file called unblock.sh into your homedirectory:

ls -d /sys/class/rfkill/* | while read device
    NAME=$(cat ${device}/name)
    echo Soft-Unblocking device: ${NAME} ...
    echo 0 > ${device}/soft

Now open a Terminal and execute:

chmod +x ~/unblock.sh
sudo systemctl stop bluetooth.service
sudo ~/unblock.sh
sudo systemctl start bluetooth.service

This will perform the same as the first one i posted but uses another approach to enable the device.

Hey egrath I don’t think we have rfkill command, but I find a way to change the soft lock(to enable bluetooth):

$ echo 0 |sudo tee /sys/class/rfkill/rfkill1/soft

Also from Jesus_cortes’s log hci0 is rfkill1

Yes, was a little bit too fast with my posting about rfkill - had to write the answer on a system which wasn’t EOS :frowning: . Your Script is essentially the same as mine, but in a more compact form.

the commands that egrath said permision denied and what endlessyung posted just said no such file off directory

At which of the commands to you get a permission denied? The unblock script?

yes the on you told me to save into a file

yes the on you told me to save into a file

So you have saved my file, then executed:

chmod +x ~/unblock.sh
sudo ~/unblock.sh

… and this results in a Permission denied error? OK, please run:

sudo bash -x ~/unblock.sh

And post the result here (this is just for determining from where the permission denied error comes)

the result was

/sysroot/home/user/unblock.sh: /sysroot/home/user/unblock.sh: Is a directory

That sounds like you have saved the file under some name in a directory called unblock.sh. You need to save it as a file, then run the chmod command from above on that file, and lastly execute that file.