Internet setup issue


#1

Hi,
I just installed endless os on my pc, and i’m having trouble setting up my network connection. I have a fibre-optic cable, with user and password assigned by the provider.
I’m new to linux, and am pretty much stuck. Need help… Thanks in advance.


#2

@Alin_Lacatus
Anyway, something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command: eos-diagnostics
  3. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#3

https://drive.google.com/file/d/0B_IYEajtM0XQMkZXTDV2aV9NbEU/view?usp=docslist_api


#4

@Alin_Lacatus
Send us this file so we can analyze and see a possible solution


#5

Only have my phone for internet, so i used google drive, i hope it’s ok.


#6

How does your fiber-optic cable connect to your computer? Via a standard network cable straight into the computer, or do you have some extra hardware?

Have you tried going to the Network section of the Settings app, clicking your network device, and configuring it there?


#7

Cable going straight in, no additional hardware. Tried configuring from the network i have a connection “Wired”, it’s on and says connected -100 mb/s, but it doesnt actually work


#8

What’s the name of your ISP? Perhaps someone’s written a blog post about how to set it up on Linux? Endless OS is based on GNOME so instructions for most other Linux distros should still apply.


#9

I already searched, but apparently the solutions don’t apply to endless. There was mention of sudo pppoeconf, but it gives me unknown command.


#10

I’m not very familiar with PPPoE (it’s quite uncommon where I live), but: it looks like Network Manager needs an extra package, rp-pppoe, which we don’t currently have in Endless OS, so we can’t currently support your network configuration. I’ll open a feature request internally – hopefully we can address this in a future release of Endless OS. In the meantime, maybe you can use a wireless network or some other connection method under Endless OS.


#11

Ok, thanks for your time and help. I’ll see what i can do.


#12

is part of the new version?


#13

It’s not; this feature request is still in the backlog. Sorry.


closed #14