Is it possible to configure EndlessOS for Hibernate?

I would like to be able to hibernate EndlessOS. I successfully used @egrath’s instructions (thanks to @egrath) to enable my swap partition permanently, but I still have no idea how to configure EndlessOS for hibernating, any suggestions?

As far as i know, it’s hard to create a hibernate / resume with a Swapfile instead of a swap partition, so it may be even harder on a OSTree based system. See https://wiki.debian.org/Hibernation/Hibernate_Without_Swap_Partition for further details on why.

Thanks Egon, I have a swap partition, not a swap file, and I followed your instructions succesfully and so I was able to activate the swap partition (semi) permantly, but I have no idea, how to enable hibernate now.

First of all, make sure that Fast Boot and Secure Boot are disabled in your BIOS - those interfere with Hibernate. Then, run the following command:

systemctl hibernate

which should put your system into hibernation mode if all prerequisites are met.

results in Failed to hibernate system via logind: Sleep verb "hibernate" not supported (with and without sudo).

PS: Interestingly, my usb-stick with Debian based siduction has no problems to hibernate on the swap partition of the usb-stick.

can you please also try:

pkexec /lib/systemd/systemd-sleep hibernate

results in

Suspending system…
Failed to suspend system. System resumed again: Device or resource busy

/dev/sda:
setting Advanced Power Management level to 0xfe (254)
APM_level = 254

last messages are: dmesg -H | tail -56 (2.8 KB)