Issues after update Endless 3.9.0

Hello,

Please help. After installing version 3.9.0 Endless there are issues with the actualization of “Freedesktop Platform 20.08.1.2. Also, sometimes the system “freezes”. Nitro 5, 7.6 GIB, core i5 9th Geforce GTX 1650, 1.1 TB

No error message.

Thank you!

Can you try updating from the Terminal:

flatpak update --appstream -y; flatpak update -y

Does it update without issues? If not, can you please provide a diagnostic by running

eos-diagnostics

and then upload the generated file.

eos-diagnostic-201112_144630_UTC-0300.txt (1,8,MB)

  1. Open the application called ‘Terminal’
  2. In this application run the command:

sudo eos-rollback

Thanks, I tried again to update from the terminal and it did work!

Thanks for the reply!

Hi my Asus notebook has login issues, i.e., keypad and mouse pad freezed after it got updated yesterday with the recent endless os updates. I am able to login to other accounts but still keypad and mouse pad not working. Unable to type even with On screen keyboard

Have you already tried:


As for the Onscreen Keyboard: Theres currently a Bug which prevents its usability after an Upgrade

This problem is affecting several users - most of which are Asus laptops. @egrath has posted details of a workaround, but we don’t yet understand why this problem exists or how to address it in a more comprehensive fashion. We even tested 13 Asus laptops but none of them exhibited the problem.

Would anyone who is facing this issue (keyboard not working after update to latest Endless version) be interested in helping us understand the problem via a remote access debugging session? (This can be done even if you have put @egrath’s workaround in place)

  • This would involve coordinating over WhatsApp. We would agree on a time slot somewhere between 8am and 8pm Taiwan time (GMT+8).
  • You’d need an internet connection and an external keyboard.
  • On my instruction, you would run a command that grants me remote access.
  • I would have full admin access to your computer, documents, etc. (I will not be looking at those, but I want to make you aware of the level of access you are granting.)
  • At some points during the session I will ask you to press keys on the internal keyboard.

Hi Daniel,
I would allow you to remote access my computer to help fix this problem. Be aware that I am not an I.T. expert, English is not my native language and I am a Linux system newbie. After app updating today at some point the mouse started to work by itself, as if it in remote access, many apps were opened at the same time, I couldn’t control the mouse, touchpad, or Keyboard.

eos-diagnostic annexed.
Nitro 5, 7.6 GIB, core i5 9th Geforce GTX 1650, 1.1 TB, Endless.

eos-diagnostic-201126_215546_UTC-0300.txt (2.77 MB)