Memory Space Problem

Hello,

I have been using your Endless OS for several years and I am very happy with it. The OS is installed on an Asus notebook R207N and runs stable.

But since version 3.9.0 (201109-141440) I have a problem now. On startup I get the error message that the disk space is only 835 MB. But I have only 5 programs with a total of 990 MB installed and no further data is stored. But the flash memory has a size of about 30 GB. The memory analysis shows 26 GB for sysrot. Is the Endless OS really that big? Under UEFI I also see that apparently two versions of Endless OS are installed: 3.9.0 (ostree:0) and 3.8.7 (ostree:1).

Now what can I do as a layman to free up space on the flash memory? I would appreciate your technical advice on this.

Many thanks and greetings from Berlin in Germany

Ulrich Hilker

Can you please install the application “Disk Usage Analyzer” and check with it which folders are eating up your space.

Hello Egrath,

and thanks for your answer. Unfortunately I do not know what is behind the names. Maybe the photo here will help.

Further greetings from Ulrich

eos-diagnostic-201209_143703_UTC 0100.txt (604,0 KB)

And maybe this analysis file will also help to identify the problem. I created it with Terminal and the command “eos-diagnostics” …

23 GiB for OSTree Deployments is a little bit too much IMHO, i have two deployments which took a total of 9 GiB. Can you please run the following command:

sudo ostree admin cleanup 

This will delete unused and orphaned files from the repository. Check with the Disk Usage Analyzer again when finished.

If you problem still persist, please run the following command:

sudo du -hcS /sysroot/ostree 2>&1 | tee /dev/stderr | gzip -9 >/sysroot/home/${SUDO_USER}/ostree.txt.gz

Then upload the file ostree.txt.gz from your Home directory to this thread for further analysis.

Too bad, both suggestions unfortunately do not work. Here are the picture. Hopefully you have another tip for me.

Use this command instead, it uses a hardcoded path instead of environment:

sudo du -hcS /sysroot/ostree 2>&1 | tee /dev/stderr | gzip -9 >/sysroot/home/ulrich/ostree.txt.gz

I don’t give up hope, but that doesn’t work either.

Holy, sorry my fault. Your usename is admin, not ulrich. Just replace this part from the above command.

Exciting and - it works. So here is the report about my operating system.ostree.txt.gz (134,0 KB)

I think, due to a strange way that we have repositories set up, that Flatpak stuff may be included in this “ostree” size count.
Might be worth seeing if there are big apps, or unused runtimes, that can be removed.

Can you please check the output of:

ostree prune --no-prune --refs-only

How much space would be freed?

Hard to say, obviously something important is missing:

admin@ulrich:~$ ostree prune --no-prune --refs-only
error: No such metadata object 4b4ceff85160c7e3ae61d8a35406c2b550c1caa8209b18cab52ad0cf6d29dcb2.dirtree

Can you please run:

wget https://raw.githubusercontent.com/endlessm/eos-meta/master/eos-tech-support/eos-fix-ostree-repo
chmod +x eos-fix-ostree-repo
sudo ./eos-fix-ostree-repo

This will scan the OSTree repository for issues and (hopefully) fix them. After this, reboot your computer and run the command i mentioned earlier again.

I find this very exciting and I also learn something. So here is the new result:
admin@ulrich:~$ ostree prune --no-prune --refs-only
Total objects: 380996
Would delete: 77186 objects, freeing 5,6 GB

OK, now you can run:

sudo ostree prune --refs-only

This will delete all Objects in the repository which are no longer used (“unreferenced”).

Thank you very much for your active help. As you can see, there is nothing left to delete now. I am very happy about the result.

Best regards from Berlin
Ulrich Hilker

admin@ulrich:~$ sudo ostree prune --refs-only
[sudo] Passwort für admin:
Total objects: 303810
No unreachable objects
admin@ulrich:~$ sudo ostree admin cleanup
Freed objects: 184,6 MB
admin@ulrich:~$

Good afternoon!
An interesting situation happened to my ENDLESS a couple of days ago. The thing is, I never use automatic updates - I like to have everything under control. But this time something went wrong. I noticed the laptop running in the background. Of course, I didn’t realize exactly what was working right away. (1-2 minutes, maybe). I open the App Center - and there is an auto update of the system and applications. I stopped the update through cancellation, and still 1 GB less free disk space.
Can you advise - how to find unfinished deployment in OSTree and free up disk space.
I don’t want to sound ridiculous, but about 10 years ago I tried to do everything myself. No, no I’m 100% new to Linux. I have worked with Windows all my life, specifically AutoCAD and UNIGRAPHICS. I used to write applied scripts for those applications, and I was pleased with myself. Now it’s all in the past. I am a human of 60+ category and the laptop is just an entertainment. :slightly_smiling_face:

You can use the same commands from above to find unused OSTree objects and delete them. I always did updates by myself, because i liked the control over it. This changed with EOS, as it normally just works as expected :slight_smile:

I used the above commands as soon as I found this branch. It didn’t help.

(sudo ostree admin cleanup) - freed up 46MB
(sudo ostree prune --refs-only) - also not much, less than 100MB

One thing I know is that all the garbage (1GB) I want to get rid of is in ( ./sysroot/ostree/repo/object/).
The question is how to determine what is trash.