Mounting NFS shares

Hello all,

I could be off here, but I think I’ve got everything configured on my NFS server properly (dietpi install), I’m able to mount the nfs share from my mxlinux box. However I cannot access from Endless.

If I go to ‘Files’ on endless, then ‘+ Other locations’, then in the bottom connect to server box, it shows the syntax for connecting to the nfs server. I do that… but then I get the error:
“Unable to access location”
“Permission denied: Perhaps this host is disallowed or a privileged port is needed”

I’ve tried both
nfs://192.168.1.101:/srv/nfs
and
nfs://192.168.1.101/srv/nfs

I get the same error for both. I’ve also tried with the hostname instead of ip address for both cases.
I notice that there is no mount.nfs --> Is this the reason for it not working? Or is this support baked into Gnome files?

I also tried nfs://192.168.1.101
But I get “Unable to access location”; “Mount point does not exist.”

This is my uname -a for endless box:
Linux myhostname 5.11.0-35-generic #37+dev51.6f2d25bbeos4.0.2 SMP Fri Dec 10 14:25:43 UTC 2021 x86_64 GNU/Linux

I’m able to sftp:// to my dietpi server no problem.

73,
Timothy

Are you using the same procedure on your mxlinux setup?

GNOME uses gvfs for accessing NFS (it does not actually mount the filesystem in the traditional sense) and it looks like there are some limitations including lack of NFSv4 support: https://gitlab.gnome.org/GNOME/gvfs/-/issues/18