Não consigo baixar o Visual Studio Code

A Central de Aplicativos não funciona. Aparece que esá instalando mas não sai do 0%. Tive problemas para instalar o Chrome e o Firefox. Rodei no Terminal o comando “flatpak update” no final depois de muitas tentativas consegui instalar apenas o Firefox. Agora não consigo baixar o Visual Code. Por que o Endless se propõe a ser de fácil acesso e uso para qualquer pessoa mas no final das contas só te atrasa? eos-diagnostic-211011_015655_UTC-0300.txt (1,2,MB)

  1. Abra o aplicativo chamado ‘Terminal
  2. Neste aplicativo execute o comando:
flatpak update --appstream && flatpak update -y
sudo ostree admin upgrade
eos-updater-ctl update
  1. Reinicie o compudador

Obrigado por tirar um pouco do seu tempo para me responder. Infelizmente não deu certo. Apareceu esse erro: “erro: ID inválido sudo: Nome deve conter pelo menos 2 pontos”. eos-diagnostic-211012_001607_UTC-0300.txt (863,6,KB) Por que o Endless é tão complicado de mexer?

Please type the commands exactly as shown above, you probably have a typo in it.

I’ve tried more than ten times. It’s frustrating.

Can you please provide a Screenshot after entering those commands showing the exact error message. Eventually we can see something that’s not obvious.

You’ve read my mind. There you go.

You’ve put everything together in one command line. Do each one individually:

flatpak update --appstream && flatpak update -y

When this command has finished:

sudo ostree admin upgrade

and lastly:

eos-updater-ctl update

I’ve tried before. It doesn’t allow me to type anything after this:

Enter your password there. It’s not shown when typing for security reasons. The sudo command let you run applications with administrative privileges, which is needed in this case.

it did not work.

We’re getting closer, the commands worked, but complained about expired keys (which is due to the old version of EOS). Please follow the instructions in the following support entry to fix this:

Then you will be able to upgrade to the latest version and install Visual Studio Code from within AppCenter

I’ve done the procedures but still the same thing. There is no upgrade to be done in my AppCenter. Also I still cannot install google chrome.

OK, strange. Please try the following commands:

wget -nv --no-check-certificate https://ostree.endlessm.com/keys/eos-ostree-keyring.gpg
wget -nv --no-check-certificate https://ostree.endlessm.com/keys/eos-flatpak-keyring.gpg
sudo ostree remote gpg-import -k eos-ostree-keyring.gpg eos
sudo ostree remote gpg-import -k eos-ostree-keyring.gpg eos-runtimes
sudo ostree remote gpg-import -k eos-flatpak-keyring.gpg eos-apps
sudo ostree remote gpg-import -k eos-flatpak-keyring.gpg eos-sdk

These commands are similar to the ones you already issued, but the retrieval of the new keys does not check if the ones already there have been expired.

It’s done. What now?


eos-updater-ctl update

If, after a reboot your System ist still at 3.7.7 (verify in About Dialog), then run:

sudo ostree admin upgrade

After you are running 3.9.5, you can install VS Code from the App Center.

Maybe I’d better try a new OS, right!

Can you please verify the date and time of your computer? Does it seems plausible?

Date and time are correct. Why?

I am trying to install the 3.9.5 version with an Endless usb stick but when I try to run the SanDisk there is a GRUB black page and I cannot type anything so I have to reboot the System.