Netbeans remote deployment on raspberrypi returns “make: Makefile: No such file or directory”

  • I tried to deploy a sample project following netbeans tutorial it returned followeing output:
cd '/home/pi/Documents/netbeansProject/Welcome_1/'
/usr/bin/make -f Makefile CONF=Debug
make: Makefile: No such file or directory
make: *** No rule to make target 'Makefile'.  Stop.
  • All that i got to know after searching about this is make is not able to find the make file named ‘Makefile’ but i already have it in the project in the ‘Important Files’ section. Still make cannot find it…
  • The difference that i noticed from the tutorial is that i didn’t get “Copying project files to…” in the output. Could it be that the Makefile never got to the rasberrypi and that’s why it can’t find it?
  • I tried opening remote terminal tab and Netbeans gave error ‘Local terminal is not supported on this system’ even though i was opening a remote terminal. Although i can ssh into raspberrypi through local terminal easily. (Even with terminal provided in Netbeans)
endless version 3.8.0
netbeans version 11.3

For NetBeans support report the bug here

I resolved it.