No desinstala los programas que ya no uso

No está funcionando la opción en el centro de programas para desinstalar o actualizar programas. Necesito actualizar Qgis y no me permite. Deseo desinstalar Midori y Pantallas en red, pero siempre dice que hay un error y no permite realizar ninguna acción de actualización, desinstalación o incluso, hay iconos de programas que ya no están y permanecen sin ninguna utilidad en el escritorio. También, después de la última actualización, no se pueden quitar las aplicaciones del escritorio, pero s se van sumando mientras se acutaliza o si por casualidad permite instalar alguna. ¿podrían ayudarme por favor?

eos-diagnostic-210506_213442_UTC-0300.txt (1,4 MB)

Saludos,

Que version de Qgis tienes actualmente?, la mas actual es la 3.16. Me puedes confirmar si tienes la version 3.9.4 de Endless?

La versión que tengo es 3.16 y no me deja actualizar a 3.18. la versión que tengo de endless es la 3.9.4. Creí que el archivo que envié tenía toda la información de mi versión de endless (eso diagnostic).

HOla, ya he realizado la actualización de Qgis a la versión 3.18, pero aún así, no me permite realizar la instalación de varios complementos (por ejemplo “Data Plotly”), ¿podrían ayudarme por favor?

The installation of the Plugin fails because the necessary Python Module plotly isn’t installed in the Flatpak’s version of Python.

To make it work, execute the following command:

flatpak run --command=pip3 --devel org.qgis.qgis install --user --force-reinstall plotly

This will install the Plottly module in the Flatpak’s local Python installation as a User module which in turn allows you to activate the Data Plottly Plugin in Qgis.

1 Like

He seguido los pasos que me sugieres @egrath, pero sigo sin poder instalar el complemento. Al ejecutar el comando concluye que el error persiste. ¿que devería hacer?

Probably the SDK isn’t installed on your Device (it was one mine). Just tested it on a clean VM with 3.9.4 and had to take the following step before:

sudo flatpak install -y org.kde.Sdk/x86_64/5.15

Now the original command works without throwing an error complaining about the missing SDK and in turn allows you to install the Plugin.

1 Like

Resultó prefecto. Gracias por la ayuda @egrath, ahora solo resta el problema de no poder desinstalar aplicaciones que ya no necesito. ¿podrías ayudarme por favor?

There are multiple options of uninstalling applications. Either you can use App Center, search for the Application in question and select uninstall. Or, you can use Terminal:

List all Applications currently installed

flatpak list

Remove a Application

flatpak uninstall -y org.videolan.VLC

(replace with the application you want to uninstall).

Removing obsolete Data

Applications store their private data (Configurations, …) most of the time in their private directory, located in ~/.var/app. You need to remove these directories too if you want to fully clean a uninstalled application. For the Terminal method, there’s also a corresponding switch to do this during uninstall:

flatpak uninstall -y --data org.videolan.VLC

Las aplicaciones no permites ser desinstaladas a través de Centro de aplicaciones, pero aún no he intentado la opción sugerida por ti @egrath . Intentaré y desúés informaré si hay error o no.