No updates available for ASUS 4110 (Endless OS 3.3.13)


I have recently bought an ASUS 4110 (All-in-One-PC) that runs Endless OS 3.3.13. I tried to update it via Settings->Details->Overview and unfortunately no OS updates are available. Additionally i try to install apps such as Google Chrome, Skype etc and i meet TLS certificate error and thus i can not proceed any longer with the installation.

I have tried to update it via terminal commands according to your following forum posts:

  1. google-chrome-install-error-even-everything-is-up-to-date/17716/23
  2. no-updates-available-for-endless-os-3-3-20/11412

and unfortunately i meet several errors such as bad signature etc and thus unable to proceed any longer.

For your better assistance i attach you the eos-diagnostics txt that i got today from my ASUS A4110 PC after trying to update it unsuccessfully and i would like to get ideas that could help me.

Additionally I attach you a screenshot that I get by
sudo ostree admin upgrade

eos-diagnostic-211028_191312_UTC 0300.txt (269.3 KB)


Thanks for your reply but I got the following error screenshot. Any idea what wrong is happening in order to proceed without any problem?


Thanks for your reply again but I came across the following screenshot and I do not know what to do.


Apologies for the trouble here. We only figured out the issue you are seeing last week. I have just updated the documentation with a new procedure, please try this:

Thanks a lot for your reply, but unfortunately no success. Same version 3.3.13 after restart.
For your better assistance, i attach several screenshots during this process. Any idea what could I do in order to fix it?

Additionally I got a gpg file (14 November 2019) size 1.2 KB and really i do not know what is going on?


Thanks for your patience as we figure this out.

Please could you try this command again:

   sudo ostree pull --url= eos

and post screenshots of the result. (I think you may have accidentally skipped this command earlier, or it failed?)

Then run again:

   sudo ostree admin upgrade --deploy-only

I just tested this on an installation running the same version as yours, and it works as laid out in the documentation, so I think we just have to figure out this final detail…

Thanks for your reply again, but unfortunately I did not have got success. For each command step in the documentation, I post a screenshot in order to be more convenient for you.


Weird, I don’t quite understand why you’re seeing that. Please try:

sudo ostree pull --url= eos os/eos/amd64/eos3
sudo ostree admin upgrade --deploy-only

Then reboot, hopefully that gets you to 3.3.20 and then you can continue the steps.

Thanks a lot again for your assistance!

This time it worked successfully for me and I got finally 3.3.20. Now what else I have to do to get the newest version without any problem?


1 Like

Final step:

sudo ostree admin deploy eos:os/eos/amd64/eos3a
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.