No Wi-Fi adapter found


#1

I have a problem with my wi-fi connection. I neither can see a wi-fi icon nor connect to wi-fi.
Everything was working good for a half of a year since I’ve bought my Asus Vivobook.
Please help me.

eos-diagnostic-190601_075955_UTC 0300.txt (800.6 КБ)


#2

Good Morning,
to me, it seems that your device has a hardware button which can physically enable/disable the wireless adapter (“Asus Wireless Radio Control”). Can you please try the following, to see if my guess is right.

  1. Open a Terminal and write:
lspci; lsusb
  1. Press the Wireless Button (FN Key and F2 at the same time) - probably some light will turn on on the device
  2. Run the commands from (1) again and checkif the output now has an additional line, something which sounds like a wireless adapter.

#3

Thank you a lot for your answer.

Unfortunately, when I wrote this command into Terminal it tell me that no such command was found. But then I reload my laptop and saw that the wi-fi icon emerged and my laptop connected to wi-fi. However, when I’ve tried to open few webpages through Google Chrome nothing downloaded and “No wi-fi adapter found” appeared. After one more reload the problem of neither icon nor connection remained. After third reload the icon was shown and the webpage downloaded.

Now it works.

To tell the truth I’m not certain for how long it will work and if it will work properly after one more reload.

One more time thank you a lot for your advice.

Maybe there is a possibility to ensure proper work of wi-fi in the future on case of "No wi-fi adapter found?


#4

@jprvita: As you are the author of the kernel module in question, any ideas on this?


#5

The logs that you posted earlier appear as if there is no wifi hardware at all in the laptop. As such, they confirm the problem you’re seeing, but don’t give us any clues.

Next time you see the wifi working, even if only partially working, please get new diagnostic logs (before rebooting) and post them here. Or even better if you can catch the case where the wifi adapter works, then disappears, then you capture logs at that point (also before rebooting).

Some other things you can try:


#6

Thank you for the advice.
Unfortunately, the problem still remains.
Here I post 3 files. First one when the wifi adapter worked, then disappearedeos-diagnostic-190603_102634_UTC 0300.txt (7.9 МБ), second few minutes later when the issue was solved eos-diagnostic-190603_102925_UTC 0300.txt (7.9 МБ). The third one when the problem emerged again eos-diagnostic-190603_105811_UTC 0300.txt (7.0 МБ).
Hope it will help.


#7

The logs show that you are still on the old BIOS version so I would recmmend updating to the latest one. Maybe that helps here. https://www.asus.com/Laptops/ASUS-Vivobook-14-X405UR/HelpDesk_BIOS/

Beyond that, we’ve seen some issues with this wifi card (Realtek 8822BE) and we’re hoping that the situation will improve when we switch to a new driver, but it may be 1-2 months before we have it available in Endless.


#8

One possibility is to switch to the BETA Release of EOS:

eos-stage-ostree demo

This will give you (currently) Kernel 5.0.0.15 which solves many driver problems, probably yours too.