Oh no! something has gone wrong ; ERROR

when i switched on my endless laptop today it loads the endless logo for too long and after that it shows an error on the attached picture.

can u help

1 Like

Turn off your computer and turn it on again

have done many times since yesterday

@mwleeds @wjt Could help?

so i had left it Switched ON for a few minutes now when im clicking it on form sleep it shows this

We have had a number of reports of this problem. If you hold down the power button to power it off, then turn it back on again, you should get back to the initial setup wizard.

i have been doing that, but no luck l even tried logging in with previous OS version but nothing

We recently configured 120 devices, 110 were AMD and 10 were Intel. All 10 Intel devices could not get past this screen on 3.7.8. The intel devices worked fine when first flashed with 3.6.3, but after updating, we could never get past this screen. The AMD devices all worked fine.

I have this problem too, i tried logging with previous version 3.7.7 and it is not working :frowning:

@worldpossible could you clarify if you’re referring to the image in the original post (“Oh no! Something has gone wrong.”) or the later image (“gnome-initial-setup Authentication error”). I am looking into the latter issue. There is not enough information to investigate the former.

We get that after an upgrade to 3.7.8 on an otherwise working machine previously running 3.6.3. We also get it when installing EOS fresh on a blank intel machine if installing 3.7.8

@worldpossible Would it be possible for you to get a diagnostic log after it happens? If you press Ctrl + Alt + F3, do you get a login prompt? This would only be possible on a computer that upgraded and already had accounts created, not a fresh reflash. Here would be the steps to get a log:

  1. Login as an administrator
  2. Run the command eos-diagnostics
  3. Press Ctrl + C to get back to a prompt after the “cannot open display:” error message (which is safe to ignore).
  4. Run the command sudo eos-diagnostics -H
  5. Insert a flash drive
  6. Run sudo blkid and note the device path for the flash drive, such as /dev/sdb1.
  7. Mount the flash drive with sudo mount /dev/sdb1 /mnt (replacing the device path as necessary).
  8. Copy the diagnostic log with cp eos-diagnostics-... /mnt (use the TAB key to complete the eos-diagnostics file name).
  9. Copy the hardware diagnostic log with cp eos-hwinfo-... /mnt.
  10. Unmount the flash drive with sudo umount /mnt
  11. Bring the flash drive to another computer and upload both logs.

files attached here, thank you @mwleedseos-diagnostic-200402_204240_UTC-0700.txt (2.8 MB)

Link to tar files for hardware diagnostics here: https://drive.google.com/open?id=1htKoilliVuIIXSi69WA77AmAESyD55K6

Thanks. Just to confirm again, it happens for a fresh install not just an upgrade of a modified install?

And, could you run sudo eos-enable-coredumps, reproduce the crash again, and then copy the core dump from /var/lib/systemd/coredump/ and upload that here?

Hi @mwleeds – the process of enabling coredumps seems to have prevented the error from occuring. Not sure what happened along that process. Anyways, I have attached the coredump logs here, but again, was unable to reproduce the crash.

I was told by my coworker a clean install still had the same problem, not just an upgrade. I can test that now on another intel machine.

https://drive.google.com/open?id=1snWFJw-7eUAvfLl4TcYhceEW75tDVwOf
https://drive.google.com/open?id=1dPsSt1ATaY7BCZIjlAphHjzsxOz0k863