Onscreen Keyboard No Longer Working

It appears the onscreen keyboard stopped working with the 3.9.0 update. It was working until the update around Nov 9. When I turn on the onscreen keyboard it only pops up when you click on the search field on the desktop. You can click and switch between alphabet and numbers and lower case and upper case but when you type a letter it doesn’t show on the search field where the cursor is. The onscreen keyboard doesn’t even appear when you try to use every where else. I used it a lot to login into websites. Can this be fixed? Is there a command that I can run to get it working again? Can your login be captured by a keylogger when you use the keyboard in Endless?

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

I cannot open the Terminal app. When I click on it it says Open in App Center. When I click on Open in App Center it says Sorry! There are no details for that application. I was able to open a few other applications that I tried. I cannot run eos-diagnostics from the console mode either. I can run dmesg and top.

The virtual keyboard stopped working with the 3.9.0 update. Can you see if you can get it to work on your machine with the 3.9.0 update. Maybe the 3.9.0.update may be causing the onscreen keyboard not to work.

Is this something that I need to worry about? Can somebody install a keylogger in Endless? I always use a non administrator account to go online. What is the purpose of the onscreen keyboard if that was the case ( impossible to install viruses or malware in Endless).

Hello! I have another problem on 2 notebooks in the office with 1D barcode scanners. We have internal barcodes with english letter Z, but after last update of Endless OS only first code recognize properly (with Z) and then it’s start changing it to russian Я while its set up english language when scanning is happening. It’s happen everywhere (browser, LibreOffice) like it some autocorrection working. Reboot help but only for one scan.
Can i get back to previous version for good? Because it’s really affecting a work and i’m thinking of deleting Endless OS becuase i dont even sure that it wil be fixed in near future.
P.S. It’s problem affecting only barcode scanners. If you type text from keyboard it’s ok. You can change language when you need and autocorrection doesnt happen.

  1. Open the application called ‘Terminal’
  2. In this application run the command:

sudo eos-rollback

I have also this problem. My onscreen keyboard and touchpad also not working today (asus notebook). External mouse working.
I can’t login in systeem to start diagnostic.

https://support.endlessos.org/help-center/After-an-update-my-computer-does-not-boot-How-do-I-recover

https://support.endlessos.org/help-center/After-an-update-my-computer-does-not-boot-How-do-I-recover

Step 2 says: 2. You will see the firmware screen with the manufacturer’s brand. Hold down the Shift key on your keyboard and wait a few seconds (still holding Shift down). On some computers, the GRUB menu will appear; go to step 4. On others, you’ll see the Endless logo, so you need to use another process; continue to step 3.

I see the Endless logo after I start my laptop. What other process do I need to use to access the GRUB menu and select the previous version.

Thank you very much, it worked! Turning off update for now, will be waiting for fix.

eos-diagnostic-201114_175409_UTC 0300.txt (2.7 МБ)

I got the SCRUB menu up with the 3.9.0 version highlighted and the 3.8.7 version below it. But the keyboard doesn’t work at all. I cannot select the 3.8.7 version because the down arrow doesn’t work. No key works including the escape key. The enter key doesn’t work either and I have to force a shutdown by holding the power button down. How can I boot with version 3.8.7?

Doing a Diagnosis on why your Keyboard does not work may be hard, but i’ll try:

  • How is your Keyboard connected (if it’s a PC, not a Notebook)
    – Only USB connected Keyboards work, also ones which connect through some kind of proprietary wireless dongle (like Logitech)
    – Bluetooth connected Keyboards don’t work as they are handled by the Operating System
  • In case you have a Notebook or USB connected one:
    – Can you enter the BIOS on your device?
    – Are there settings regarding the initialization of the USB stack? (Full Initialization, Limited, …)

If you just want to switch back from 3.9.0 to 3.8.7 when booted 3.9.0, open a Terminal and enter:

sudo eos-rollback

This will bring you back to 3.8.7.

Onscreen keyboard don’t work.
Only USB connected Keyboards Logitech work.

Thank you. I have a laptop and was using its keyboard. I used a keyboard that I plugged into the USB port and was able to go back to the previous OS. The virtual keyboard is now working.

Should I use any antivirus for Endless? Or it is not necessary. If so, which antivirus can I use.

Back on the original Topic regarding the On-Screen Keyboard.

Observations:

  • When the OSK is enabled, it pops up when GNOME Shell expects input (like Alt-F2 to run a command or the Google Input Box on the Desktop). However, it does not input the touched Keys into the appropriate location.
  • For other Applications which expect input, it does not pop up.

@EndlessYung FYI
@andrunko FYI

/update:

  1. Checked if it has something to do with Endless GNOME Extensions, so i disabled them all to get a Plain GNOME 3.38 Desktop ➞ same Result, does not work as expected
  2. Checked if there’s something in the GNOME Keyboard component in Endless Source Tree different from the official GNOME Repository ➞ they are on par (https://github.com/GNOME/gnome-shell/blob/master/js/ui/keyboard.js)
  3. Checked on Ubuntu 20.10 which also uses GNOME 3.38 ➞ it works there as expected :frowning:

/update 2: SOLUTION INSIDE

  1. The issue only occurs on systems which have been updated from 3.8.7 to 3.9.0.
  2. Doing a eos-factory-reset on a upgraded installation restores the desired behavior
  3. Doing completely fresh install too.

So my assumption is that some GNOME configuration in $XDG_CONFIG_HOME from 3.36 don’t play well with 3.38. Eventually this is an Upstream issue too.

1 Like

https://support.endlessos.org/help-center/Do-I-need-anti-virus-software-on-Endless-OS-What-makes-Endless-OS-more-secure