OS update disappeared from app center

Hello, few days ago I seen that I can update OS. For some reason download of OS was started automatically, before I know I had to do it by my self. OS was downloaded, and ready to be installed. There for some reason “image” to install it is gone and I can’t update OS. I think I have to reset App Center in some way. I restarted PC, waited to OS update “image” to come back but it have not returned.

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

Have found some commands from forum and tryed them out. I will not use eos-diagnostics command since I seen it reveals personal data.

gnome-software
17:51:08:0429 Gs State change on system///os-upgrade/com.endlessm.EOS.upgrade/* from unknown to installing is not OK
17:51:08:0603 Gs enabled plugins: desktop-categories, dpkg, eos-updater, external-appstream, os-release, provenance, appstream, provenance-license, desktop-menu-path, flatpak, generic-updates, hardcoded-blacklist, rewrite-resource, eos, eos-blacklist, icons, malcontent, odrs, key-colors, key-colors-metadata
17:51:08:0603 Gs disabled plugins: dummy, repos
17:51:09:0420 flatpak Ignoring duplicate content rating
17:51:09:0558 flatpak No matching appdata for org.gnome.Weather
17:51:09:0571 flatpak Ignoring duplicate content rating
17:51:11:0769 Gs FIXME: Unknown progress handling is not yet implemented for GsProgressButton
17:51:11:0769 Gs FIXME: Unknown progress handling is not yet implemented for GsProgressButton
17:51:11:0770 Gs FIXME: Unknown progress handling is not yet implemented for GsProgressButton
17:51:11:0770 Gs FIXME: Unknown progress handling is not yet implemented for GsProgressButton
17:51:12:0014 flatpak Ignoring duplicate content rating
17:51:12:0021 flatpak Ignoring duplicate content rating
17:51:12:0198 flatpak No matching appdata for org.gnome.Weather
17:51:12:0217 flatpak Ignoring duplicate content rating
17:51:12:0218 flatpak No matching appdata for org.gnome.Weather
17:51:12:0243 flatpak Ignoring duplicate content rating
17:51:24:0252 flatpak Warning: No xa.metadata in commit 63ec8da8222881568631a9278234eacb70b1593dcd0d07832a9299bc0774e0fe ref app/org.gnome.Freecell/x86_64/eos3
17:51:24:0257 flatpak Warning: No xa.metadata in commit f7a9b9a91c09d4629f415e13a7f01a03b3b155466d6337ca0c2a6fac05ab6e61 ref app/org.gnome.Solitaire/x86_64/eos3
17:51:32:0784 flatpak No matching appdata for org.gnome.Weather

eos-updater-ctl update
Traceback (most recent call last):
File “/usr/bin/eos-updater-ctl”, line 409, in
main()
File “/usr/bin/eos-updater-ctl”, line 405, in main
sys.exit(args.function(**args_dict))
File “/usr/bin/eos-updater-ctl”, line 204, in command_update
poll_result = command_poll(block=True, quiet=quiet)
File “/usr/bin/eos-updater-ctl”, line 183, in command_poll
return command_dbus(‘poll’, block, quiet)
File “/usr/bin/eos-updater-ctl”, line 159, in command_dbus
proxy.call_sync(qualified_method_name, parameters, 0, -1, None)
gi.repository.GLib.Error: g-io-error-quark: GDBus.Error:com.endlessm.Updater.Error.WrongState: Can’t call Poll() while in state Fetching (36)

With some comand playings I get to reset something since "update in orange overlay was gone, but after this command it returned:
eos-updater-ctl update
Changed state to Polling
Changed state to UpdateAvailable
======= Properties =======
State: Polling
CurrentID: ‘1dad9d3208096bbe175596e56fc7940170c8846254a6ef986cc0c4efc806c4f2’
DownloadSize: int64 119896285
DownloadedBytes: int64 0
ErrorCode: uint32 0
ErrorMessage: ‘’
ErrorName: ‘’
FullDownloadSize: int64 1753880191
FullUnpackedSize: int64 4082437552
OriginalRefspec: ‘eos:os/eos/amd64/eos3a’
UnpackedSize: int64 140896103
UpdateID: ‘2128f7fcd1e89f1074d5e71ae62044a0ba4051c4a6d4ecb960851e34ff7637b8’
UpdateLabel: ‘201005-133640’
UpdateMessage: ‘Built with eos-ostree-builder Release_3.8.6’
UpdateRefspec: ‘eos:os/eos/amd64/eos3a’
Version: ‘3.8.7’

Changed state to Fetching

What should I expect now to happend? Wait for to download OS, once before it sayed it have done that, but after I had problem that was not able to instal it. OS was alredy downloaded before. In app center it say that OS is downloading now. I will wait a day or two.
Now if I run gnome-software command it just open app center, no errors.

If I run: eos-updater-ctl update It write the same as before it did first time.


I can’t comment there, but problem for this is solved by fallowing instructions bellow.
Iam using Endless 3.8.6 version.

press the keys alt+f2, write the letter r and press enter

https://support.endlessos.org/en/help-center/Why-does-the-computer-seem-to-get-slower-over-time-or-when-visiting-a-lot-of-websites

This is all I see in app center under updates tab and on top left side it say, Checking… But I can click it to stop, and it won’t. Even on Update for Endless >>Cancel<< don’t do anything at all, and progresses bar never changed even first time it told me that it have “downloaded OS”.

I fallowed this: https://support.endlessos.org/en/help-center/How-do-I-make-a-debug-log-of-Endless-OS
Run this 2 commands:

  • Run killall gnome-software
  • Run gnome-software --verbose > gnome-software-verbose.txt – this will launch the app center and gather a lot of debug output to a text file

Here I tried to uninstall wiki in Indian language. App center, just close it self. I really like to uninstall it.

gnome-software-verbose.txt (603.7 KB)

I run gnome-software --verbose > gnome-software-verbose.txt again.
gnome-software-verbose2.txt (1.1 MB)
This time I have not done uninstall, since i seen all apps in Update tab. And OS, asking me if I like to download it by my own choice this time. When I closed Terminal App Center closed too.

This is what I see now:

Done download, all work okey, was able to update now.

Do you have any network issues? Your logs are full of lines like:

Error resolving “ostree.endlessm.com”: Name or service not known

Can you access the Internet via Chrome?

I removed some lines out, I don’t have network problems.