PS4 Controller for Endless


#1

Hey how do I use a PS4 controller on my Endless OS 3 Laptop.

Do i need to install any Drivers for USB connection or Bluetooth? If so how?

I previously ran into a few other issues but now its all good. My laptop just does not connect properly with the PS4 controller

When enabling Bluetooth, it does recognize the Controller but it says “disconnected” next to it

What am I doing wrong eos-diagnostic-190506_173606_UTC 0300.txt (691.1 KB)


#3

Hi,

often, problems with connecting certain Bluetooth Devices - like the PS 4 or Wii U Pro Controller - can be solved, by manually pairing it using the Bluetooth Stacks commandline tools instead of GNOME’s gui.

Run the following command:

bluetoothctl

This will open a shell where you can enter commands for the Bluetooth Stack. Enter:

agent on
scan on

Now turn on the Controller and enter pairing mode. You should see something like:

[NEW] Device 7E:4D:41:5C:B0:5D

This is the device you want to pair with. Enter:

pair 7E:4D:41:5C:B0:5D

This will pair set up the bond between your two devices. Now enter:

trust 7E:4D:41:5C:B0:5D

This will allow your controller to initiate the connection when turned on. Leave with exit. Up from this moment, the controller should also be visible in GNOME’s Bluetooth GUI.


#4

Hey thanks for the quick reply :smiley:

This sounds really promissing, but somehow the command bluetoolctl does not work for me?

Not sure why?

I tried the pair and trust command and nothing happens as well

P.S. I have no idea about Linux or any related OS at all .(


#5

Hi, i had a typo in my post, the command is bluetoothctl


#6

I did everything as explained and connecting the controller with my laptop worked fine. The big picture mode of steam still does not recognize my controller though.

But, on some games i can use the controller just fine, even without big picture mode but not all games.

Any possible suggestions for this?


#7

According to
https://support.steampowered.com/kb_article.php?ref=5006-ASLN-3202#controller
only a few Controllers are currently supported in Big Picture mode.


closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.