Raspberry Pi not booting with Endless OS 5.0.0

I tried booting on raspberry pi with my 480gb ssd, but it always get stuck on starting kernel.

Hello @RONIT_MEHTA, thanks for your report. Which model of Raspberry Pi are you using? Did it use to work with Endless OS 4?

Hi, I am using Raspberry Pi 4B with 8gb ram. Actually I was going to run endless os first time on my raspberry pi, so i just downloaded the latest version of endless os 5.0.0 of arm architecture for raspberry pi. While booting, it just shows some texts and then get stucked on 'starting kernel…". Pls help me to solve the issue.


I notice you try to boot the system on SSD!!! We have not tested that config before, actually. Interesting!

Does the Endless OS 5.0 system in the normal micro SD card can be booted?

Besides, please share how do you connect the SSD to the Raspberry Pi 4B board? Pictures are good, too.

I tried on my 64gb SD card too. But it was still showing the same thing “Starting kernel…”. And got stucked.

I connected the ssd to the usb 3.0 port of raspberry pi.
I also tried this os to run it on my sd card but still not working.
Please help me to fix this

Here is the text displayed on the monitor

I’d suggest to separate the problem into simple issues.

  1. How much power does the power adapter output? (My power adapter outputs 30 watts)
  2. Disconnect the USB-SSD and boot the Endless OS 5.0 on the micro SD card. Does the system boot up?
  3. The quality of the micro SD card: After flash Endless OS 5.0 image into the micro SD card, can both the FAT and EXT4 partitions on the SD card be mounted on other computers successfully? Get into the folders and open some text files for test.

Booting from USB storage part will take some time for investigation.

I dont think its something with my power adapter. It’s powerfull enough because I have run many other os.
I tried booting on micro sd card but still showing the same issue.
Micro sd card is also working fine without any issue or slow speed with other os.

We have confirmed that there are some issues related to boot Endless OS 5.0 on an USB storage device.

However, I cannot reproduce the boot issue with the system only on micro SD card on my RPi 4B (4GB).

Can you please connect the debug serial console (UART TXD0/RXD0) of RPi 4B to your another computer and help appending the loglevel=6 to boot command into /boot/uEnv.txt in the ostree partition (2nd partition):

$ sudo fdisk -l /dev/mmcblk1
Disk /dev/mmcblk1: 59.63 GiB, 64021856256 bytes, 125042688 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x65263cd8

Device         Boot  Start       End   Sectors  Size Id Type
/dev/mmcblk1p1        2048    206847    204800  100M  c W95 FAT32 (LBA)
/dev/mmcblk1p2 *    206848 125042654 124835807 59.5G 83 Linux
  1. Append loglevel=6 to boot command (the bootargs):
$ cat /boot/uEnv.txt 
bootargs=rw splash plymouth.ignore-serial-consoles quiet loglevel=0 ostree=/ostree/boot.1/eos/3ef84041e4bcbb2da7617346d353b4284f4e5b03f706e9908e11ac486682190b/0 loglevel=6
  1. Then, boot the RPi 4B with the micro SD card again. It should show more kernel messages for debug.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.


EOS has a new development version with newer kernel & new generated initramfs.

Can you please help test the new version as the image: