Screen rotation


#1

Hello community,

first of all I like to congratulate you on a nice and working Linux OS for computer beginners and for handheld devices too. I am using Endless on the Acer Convertible TravelMate Spin B mostly for work and it is really playing out so far.

Now I wanted to ask, if anyone has experience with getting the screen rotation to work. If I do it via xrandr in terminal or via the settings tap, the screen rotates very good. Problem is the internal sensor tho, who detects the vertical position of the laptop in correlation with the center of Earth, has no output. I tried the command monitor-sensor in terminal and it is waiting for output but nothing comes. Reading the eos-diagnostics I can find no loaded driver either, so I suspect there could be the problem.

Any hints appreciated and keep up the good work.
Greetings from Germany,
ent


#2

@entropie Automatic screen rotation definitely works on some laptops. (I have tested it on a Lenovo Yoga 900.) The behavior is not always perfect, and I usually leave it disabled.

It is quite possible that there is missing Linux kernel driver support for some laptop models, though.

Here is what I see on the Yoga 900:

roddy@endless:~/checkout/eos-release-engineering/apps$ monitor-sensor 
    Waiting for iio-sensor-proxy to appear
+++ iio-sensor-proxy appeared
=== Has accelerometer (orientation: normal)
=== Has ambient light sensor (value: 1.000000, unit: lux)

You would also have to make sure that the orientation lock is disabled, but from what you are reporting it does not sound like that is your problem:

Roddy


#3

Hello @roddy /- is it possible to permanently disable this so a user cannot re enable it?


#4

@ramcq @wjt Would you care to answer the question from @worldpossible?


#5

Hi Jeremy, I have observed this at least once re-enabling itself on my laptop despite most me definitely switching it off. There is likely a bug at work here. I will file it internally but we’re unlikely to be able to revisit it until post May once our current major release is completed. In the meantime, you can use two features together to make the setting stay off permanently.

Firstly use this mechanism https://help.gnome.org/admin/system-admin-guide/stable/dconf-custom-defaults.html.en to create a user profile that allows you to insert your own default settings - however, on Endless we also provide some defaults of our own, so you should replace Step #1 with cp /usr/share/dconf/profile/user /etc/dconf/profile and insert your new system db above the Endless-provided file-db: entries. You want to set the orientation-lock key in the folder [org/gnome/settings-daemon/peripherals/touchscreen] to true.

Secondly, use the dconf lockdown mechanism described at https://help.gnome.org/admin/system-admin-guide/stable/dconf-lockdown.html.en to make it impossible for the user to write a different value to that key.

Hope that helps! Let me know if we can help any further.


#6

Awesome, I think I’m close but I’ve never played with this stuff before.

I did:

sudo cp /usr/share/dconf/profile/user /etc/dconf/profile

then I edited /etc/dconf/profile/user to add system-db:local and look like:

user-db:user
system-db:local
file-db:/var/lib/eos-image-defaults/settings
file-db:/var/share/eos-default-settings/settings

after this, I followed step 2 of the link you provided:

then ran dconf-update and received this error:

Thank you for any further guidance!


#7

I think I’m all good. This link had a little more documentation around it to help me create the local.d not local db.

https://help.gnome.org/admin/system-admin-guide/stable/lockdown-file-saving.html.en


closed #8