Screen upside down since version 3.6.0


#1

Since upgrade to version 3.6.0 the screen is upside down. And cursor movements from touchpad are wrong.

The bootsplash “Endless” is correct.

How to fix this?

Where to rotate screen by 180degrees?

No problems with eos before.


#2

Sorry for the hassle here!

If it’s a laptop, could you try holding it upside down for a moment, and see if the display rotates to another orientation, just to see if the screen appears to be following an accelerometer or this is happening for some other reason?

Could you please post a diagnostic log?


#3

Try:

xrandr -o normal

or, if that doesn’t make any difference:

xrandr -o inverted

If that solves your problem, make it persistent by creating a file ~/.config/autostart/orientation.desktop with the following content:

[Desktop Entry]
Name=Set Display Orientation
Exec=xrandr -o normal
Type=Application

and then set the correct permissions on the file:

chmod +x ~/.config/autostart/orientation.desktop
gio set ~/.config/autostart/orientation.desktop metadata::trusted yes

#4

Thanks.

xrandr -o inverted in autostart fixed it.

It is an old HP Probook 6450b. It has three-axis digital motion detection with digital accelerometer for HP 3D DriveGuard.

It is possible to make the screen rotate 3 orientations left, right and upside down when turning the notebook. But never upside top. Fixing the screen at login screen works, but wrongly upside down.

Attached eos-diagnosticseos-diagnostic-190612_140026_UTC 0200.txt (881,3 KB)


#5

Sadly getting accelerometer support right on these HP laptops (especially old-ish ones) is a real pain.

A slightly better workaround here is to disable the service that handles the sensor readings, at the terminal:
sudo systemctl mask iio-sensor-proxy
then reboot

If you’re interested in going deeper into the problem, you could file a bug at https://github.com/systemd/systemd/issues which is where the sensor database is maintained.


#6

This doesn’t work.

“sudo systemctl status iio-sensor-proxy” shows “unit iio-sensor-proxy.service is masked”.

After a reboot “sudo systemctl status iio-sensor-proxy” shows:
loaded dead inactive reason masked

BUT the screen is inverted again and only “xrandr -o normal” fixes it.