Steam não está ''rodando''

Quando eu clico no ícone da Steam aparece a seguinte mensagem:
You are missing the following 32-bit libraries, and Steam may not run:
libgtk-x11-2.0.so.0
libbz2.so.1.0
então o programa fecha.

  1. Abra o aplicativo chamado ‘Terminal
  2. Copie e cole este comando no aplicativo Terminal:
flatpak kill com.valvesoftware.Steam
flatpak update --appstream && flatpak update -y
eos-updater-ctl update
flatpak uninstall -y --unused
flatpak update --appstream && flatpak update -y
flatpak run com.valvesoftware.Steam --reset
flatpak run com.valvesoftware.Steam

não sei exatamente o que deu errado, vou colocar aqui para ver se você pode me ajudar!

hugo@reactor-bomb:~$ flatpak kill com.valvesoftware.Steam
erro: com.valvesoftware.Steam não está em execução.
hugo@reactor-bomb:~$ flatpak update --appstream && flatpak update -y
Atualizando dados de appstream para remoto eos-apps
Atualizando dados de appstream para remoto eos-runtimes
Atualizando dados de appstream para remoto eos-sdk
Atualizando dados de appstream para remoto flathub
Procurando por atualizações…
Info: org.gnome.Platform está em fim de vida, com motivo: The GNOME 3.32 runtime has reached end of life. Please upgrade to a newer version.
Info: org.gnome.Platform está em fim de vida, com motivo: GNOME 3.30 Runtime has been declared as End of life, please upgrade to a newer version of the Platform.
Info: org.gnome.Platform.Locale está em fim de vida, com motivo: The GNOME 3.32 runtime has reached end of life. Please upgrade to a newer version.
Info: org.gnome.Platform.Locale está em fim de vida, com motivo: GNOME 3.30 Runtime has been declared as End of life, please upgrade to a newer version of the Platform.
Runtime exigido para org.gimp.GIMP/x86_64/stable (runtime/org.gnome.Platform/x86_64/3.36) localizado no remoto flathub
F: ops remaining after sort, maybe there is a dependency loop?

Novas org.gnome.Genius permissões:
wayland bus ownership [1]

[1] org.gnome.genius


    ID                                              Ramo              Op            Remoto             Baixar
  1. [✓] com.hack_computer.Clippy.Extension eos3 i eos-apps 123,1 kB / 122,1 kB
  2. [✓] org.freedesktop.Platform.ffmpeg-full 19.08 u flathub 1.0 kB / 3,6 MB
  3. [✗] com.google.Chrome eos3 u eos-apps 1.0 kB / 876,7 kB
  4. [✗] com.spotify.Client stable u flathub 1.0 kB / 131,9 MB
  5. [✗] org.freedesktop.Platform.openh264 2.0 i flathub 264,5 kB / 916,8 kB
  6. [✓] com.endlessm.extra.pt_BR.Content eos3 u eos-apps 11,6 MB / 82,9 MB
  7. [✓] org.gnome.Genius.Locale stable u flathub 1.0 kB / 1,8 MB
  8. [✓] org.gnome.Genius stable u flathub 1.0 kB / 8,7 MB
  9. [✓] org.gnome.Platform.Locale 3.36 i flathub 176,5 kB / 322,9 MB
  10. [✓] org.gnome.Platform 3.36 i flathub 146,4 MB / 322,9 MB
  11. [✓] org.gimp.GIMP stable u flathub 598,9 kB / 110,0 MB
  12. [✓] org.gnome.Weather.Locale stable u flathub 1.0 kB / 8,0 MB
  13. [✓] org.kde.Platform.Locale 5.14 u flathub 1.0 kB / 337,1 MB
  14. [✓] org.kde.kalzium.Locale stable u flathub 4,0 kB / 2,5 MB
  15. [✓] org.kde.kdenlive.Locale stable u flathub 89,3 kB / 2,3 MB
  16. [✓] org.kde.kgeography.Locale stable u flathub 4,0 kB / 6,0 MB
  17. [✓] org.kde.kwordquiz.Locale stable u flathub 31,2 kB / 665,4 kB
  18. [✓] org.laptop.TurtleArtActivity.Locale stable u flathub 1.0 kB / 713,4 kB
  19. [✓] org.laptop.TurtleArtActivity stable u flathub 1.0 kB / 6,2 MB
  20. [✓] org.libreoffice.LibreOffice.Locale stable u flathub 1.0 kB / 67,5 MB
  21. [✓] org.libreoffice.LibreOffice stable u flathub 1.0 kB / 273,8 MB
  22. [✓] org.kde.kdenlive stable u flathub 5,2 MB / 34,3 MB
  23. [✓] org.kde.Platform 5.14 u flathub 1.0 kB / 323,2 MB

Erro: Enquanto baixava https:// dl. google. com/linux/chrom.e/deb/pool/main/g/google-chrome-stable/google-chrome-stable_80.0.3987.132-1_amd64.deb: Erro ao resolver “dl.google. com”: Nome ou serviço desconhecido
Erro: Enquanto baixava http://repository.spotify. com/pool/non-free/s/spotify-client/spotify-client_1.1.26.501.gbe11e53b-15_ amd64.deb: Erro ao resolver “repository.spotify. com”: Nome ou serviço desconhecido
Aviso: Enquanto baixava https:// github. com/cisco/openh264/releases/download/v2.0.0/libopenh264-2.0.0-linux64.5.so.bz2: Erro ao resolver “github-production-release-asset-2e65be.s3.amazonaws. com”: Nome ou serviço desconhecido
Alterações concluídas.
erro: Houve um ou mais erros
hugo@reactor-bomb:~$

Atualizei as instruções acima tente novamente

Qual versão do Endless OS você tá usando?
Para verificar qual versão do Endless OS você está em Configurações :arrow_right: Detalhes

3.7.8 (200309-143433)

eu refiz como você falou e foi concluído os que faltava, porem ainda aparece:

~$ flatpak run com.valvesoftware.Steam


Overriding TZ to America/Sao_Paulo
Running Steam on org.freedesktop.platform 19.08.8 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
libgtk-x11-2.0.so.0
libbz2.so.1.0
/sysroot/home/hugo/.local/share/Steam/ubuntu12_32/steam
Installing breakpad exception handler for appid(steam)/version(1583800998)
Installing breakpad exception handler for appid(steam)/version(1583800998)
Installing breakpad exception handler for appid(steam)/version(1583800998)
Failed to load steamui.so - dlerror(): libgtk-x11-2.0.so.0: wrong ELF class: ELFCLASS64
Installing breakpad exception handler for appid(steam)/version(1583800998)
Installing breakpad exception handler for appid(steam)/version(1583800998)
[2020-03-15 11:30:11] Startup - updater built Mar 9 2020 22:33:50
[2020-03-15 11:30:11] Opted in to client beta ‘publicbeta’ via beta file
You are in the ‘publicbeta’ client beta.
Looks like steam didn’t shutdown cleanly, scheduling immediate update check
[2020-03-15 11:30:11] Checking for update on startup
[2020-03-15 11:30:11] Verificando se há atualizações…
[2020-03-15 11:30:11] Downloading manifest: client-download.steampowered.com/client/steam_client_publicbeta_ubuntu12
[2020-03-15 11:30:12] Download skipped by HTTP 304 Not Modified
[2020-03-15 11:30:12] Nothing to do
[2020-03-15 11:30:12] Verificando a instalação…
[2020-03-15 11:30:12] Performing checksum verification of executable files
[2020-03-15 11:30:13] Verification complete
[2020-03-15 11:30:15] Shutdown

não existe uma maneira de eu baixar esses pacotes (libgtk-x11-2.0.so.0
libbz2.so.1.0) um por um?

Hi, @Hugo_gabriel!

Have you tried to uninstall the app and then installing it again with the command flatpak install flathub com.valvesoftware.Steam?

i tried but not worked :frowning:

achei um caso muito parecido com o meu nesse link https://dev.getsol.us/T8294
parece que o problema é o fato de eu ativar a versão beta da steam,mas não tem como desativar agora pois não é possível entrar na steam depois desse erro.

I would recommend you to totally remove everything Steam related and then reinstall. Open a terminal and type:

flatpak uninstall -y com.valvesoftware.Steam
rm -Rf ~/.var/app/com.valvesoftware.Steam

This will remove every trace of Steam from your Installation (including your already downloaded games, they need to be redownloaded). Then reinstall with:

flatpak install -y com.valvesoftware.Steam

it didn’t work for me.

Tente novamente esses comando já está disponível uma nova versão do Steam para atualizar na Central de Aplicativos

  1. Abra o aplicativo chamado ‘Terminal
  2. Copie e cole este comando no aplicativo Terminal:
flatpak kill com.valvesoftware.Steam
flatpak uninstall -y --unused
flatpak update --appstream && flatpak update -y
eos-updater-ctl update
flatpak run com.valvesoftware.Steam --reset
flatpak run com.valvesoftware.Steam

Funcionou :slight_smile: