Steam not working anymore?


#8


#9

also tried. flatpak run --command=sh com.valvesoftware.Steam
(a Shell within Steam’s Flatpak Sandbox opens)

ls -la /app/lib/i386-linux-gnu/libc*

This will output the available 32 bit libraries provided by the “org.freedesktop.Platform.Compat.i386” Flatpak. Please post the output here.


#10

Hi,
try

flatpak update appstream -y
flatpak update -y
flatpak install flathub org.freedesktop.Platform.Compat.i386/x86_64/18.08 -y

#11


#12
  1. Abra la aplicación llamada ‘Terminal’
  2. En esta aplicación, ejecute el comando:
flatpak install --system flathub org.freedesktop.Platform.Compat.i386 -y
flatpak update --appstream && flatpak update -y

#13


#14

What version of Endless OS are you using?
To check which version of Endless OS you are in Settings :arrow_right: Details


#15


#16
  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#17

eos-diagnostic-190508_200319_UTC 0900.txt (1.3 МБ)


#18

It seems that there’s something strange going on with your system. You have installed some GNOME/Freedesktop Runtimes and SDKs from a Repository called “gnome”, which is no longer configured as a Remote Repository:

org.freedesktop.Platform/x86_64/1.4	gnome	45ba501d99df	?	499	1 МБ	system	
org.freedesktop.Sdk/x86_64/1.4	gnome	d6a8c46e30e0	?	1	3 ГБ	system	
org.gnome.Platform/x86_64/3.20	gnome	2d87c5138b16	?	666	7 МБ	system	
org.gnome.Platform/x86_64/3.22	gnome	d44159b609a6	?	681	1 МБ	system	
org.gnome.Sdk/x86_64/3.20	gnome	00b1b6bfae07	?	1	5 ГБ	system	
org.gnome.Sdk/x86_64/3.22	gnome	7ec9b226b95c	?	1	5 ГБ	system	

I’m relatively sure that this is the root cause of your problem, because the i386 Compatibility Runtime for Freedesktop - which is needed for Steam - is going to be installed from flathub, as the GNOME Repository is no longer configured.

Your best bet would be to reinstall the above Flatpaks from the Flathub repository. But i’m currently unsure how to do this without breaking your system - need a little more time :slight_smile:


#19
  1. Open the application called ‘Terminal’
  2. In this application run the command:

flatpak remote-delete gnome -y


#20


where I marked black with an unknown parameter -y


#21
  1. Open the application called ‘Terminal’
  2. In this application run the command:

sudo eos-fix-ostree-repo && flatpak update -y


#22


#23

Warning there be Dragons below

If you want to perform the actions below:

  • Make sure you understand whats going on and that there is a chance of completely messing up your system
  • Print the commands out or write them down as you have no Graphical User Interface after Step (1)
  1. Open your System Terminal with Ctrl-Alt-F2 and log in
  2. Make yourself root with
sudo bash
  1. Bring the System into run-level 3 with
systemctl isolate multi-user.target
  1. Switch to Terminal 2 with “Alt-F2”

  2. Uninstall the flatpaks with the wrong repository:

flatpak uninstall --force-remove -y org.freedesktop.Platform/x86_64/1.4
flatpak uninstall --force-remove -y org.freedesktop.Sdk/x86_64/1.4
flatpak uninstall --force-remove -y org.gnome.Platform/x86_64/3.20
flatpak uninstall --force-remove -y org.gnome.Platform/x86_64/3.22
flatpak uninstall --force-remove -y org.gnome.Sdk/x86_64/3.20
flatpak uninstall --force-remove -y org.gnome.Sdk/x86_64/3.22
  1. Install the flatpaks removed at (4) with the ones from flathub:
flatpak install -y flathub org.freedesktop.Platform
flatpak install -y flathub org.freedesktop.Sdk
flatpak install -y flathub org.gnome.Platform/x86_64/3.20
flatpak install -y flathub org.gnome.Platform/x86_64/3.22
flatpak install -y flathub org.gnome.Sdk/x86_64/3.20
flatpak install -y flathub org.gnome.Sdk/x86_64/3.22
  1. Cross your fingers and reboot:
reboot

#24

after the command sudo bash requests a password, it is not even installed from me


#25

Simply enter your current password.


#26

I can’t do it I enter my login
asks for a password which is not worth it. then I set the password but it is not entered press the keys, but he does not give anything. I will remove this shit easier and put the windows. tired 1.5 years of suffering, constantly problems.


closed #27

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.