Steam not working anymore?


#1

Hello everyone!

Since 2 days ago Steam is not working on my laptop anymore. When clicking on the App, either nothing happens or it loads for a bit and then stops, Tried to re-install multiple times

Any possible solution or cause for this? :frowning:eos-diagnostic-190503_183443_UTC 0300.txt (1002.6 KB)


#2

What happens if you run it from a terminal with:

flatpak run com.valvesoftware.Steam

(please post the output here)

Additionally, there are various things you can try:

Resetting Steam

flatpak run com.valvesoftware.Steam --reset

or Completely removing Steam, all its Data and Reinstall the latest version

flatpak uninstall com.valvesoftware.Steam
flatpak update --appstream --assumeyes
flatpak update --assumeyes
rm -Rf ~/.var/app/com.valvesoftware.Steam
flatpak install flathub com.valvesoftware.Steam --assumeyes
eos-add-to-desktop com.valvesoftware.Steam

#3

Hey, thanks for the quick reply!

Yeah I have removed the Steam App completely and re-installed it over the flatpak command and opening with it as well.

It works fine now and previous issues have been erased along side it. So as long as I run the Steam app via Terminal, and not via the downloaded app from the app store, everything is perfect!

Thanks for the help :smiley:


#4

Great to hear that. Let me summarize:

  1. If you run Steam from the Icon, it does not work
  2. If you run Steam via Terminal and flatpak run com.valvesoftware.Steam it works.

If so, this could probably be a bug - which should be filed -, as running it from the icon should simply invoke the needed flatpak-run command.


#5

Yes exactly, when clicking the Icon, downloaded from the App Store, nothing happens or it just loads for a bit and then stops.

Previously I also ran into the issue, that the Steam App did not load correctly. Only my library/games were loading (i was able to play them) and everything else (Profiles, Shop, Friends, Community, Market etc etc) did not load at all, as if I were offline. This also happened when clicking the App Icon. Some games did not have sound as well.

When running Steam via terminal everything is perfect and loads correctly now.

Not sure how to report a bug like this, though. Any advice?


#6

The bug reporting process is documented under:


#7

Hello need your help, steam does not load


#8


#9

also tried. flatpak run --command=sh com.valvesoftware.Steam
(a Shell within Steam’s Flatpak Sandbox opens)

ls -la /app/lib/i386-linux-gnu/libc*

This will output the available 32 bit libraries provided by the “org.freedesktop.Platform.Compat.i386” Flatpak. Please post the output here.


#10

Hi,
try

flatpak update appstream -y
flatpak update -y
flatpak install flathub org.freedesktop.Platform.Compat.i386/x86_64/18.08 -y

#11


#12
  1. Abra la aplicación llamada ‘Terminal’
  2. En esta aplicación, ejecute el comando:
flatpak install --system flathub org.freedesktop.Platform.Compat.i386 -y
flatpak update --appstream && flatpak update -y

#13


#14

What version of Endless OS are you using?
To check which version of Endless OS you are in Settings :arrow_right: Details


#15


#16
  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#17

eos-diagnostic-190508_200319_UTC 0900.txt (1.3 МБ)


#18

It seems that there’s something strange going on with your system. You have installed some GNOME/Freedesktop Runtimes and SDKs from a Repository called “gnome”, which is no longer configured as a Remote Repository:

org.freedesktop.Platform/x86_64/1.4	gnome	45ba501d99df	?	499	1 МБ	system	
org.freedesktop.Sdk/x86_64/1.4	gnome	d6a8c46e30e0	?	1	3 ГБ	system	
org.gnome.Platform/x86_64/3.20	gnome	2d87c5138b16	?	666	7 МБ	system	
org.gnome.Platform/x86_64/3.22	gnome	d44159b609a6	?	681	1 МБ	system	
org.gnome.Sdk/x86_64/3.20	gnome	00b1b6bfae07	?	1	5 ГБ	system	
org.gnome.Sdk/x86_64/3.22	gnome	7ec9b226b95c	?	1	5 ГБ	system	

I’m relatively sure that this is the root cause of your problem, because the i386 Compatibility Runtime for Freedesktop - which is needed for Steam - is going to be installed from flathub, as the GNOME Repository is no longer configured.

Your best bet would be to reinstall the above Flatpaks from the Flathub repository. But i’m currently unsure how to do this without breaking your system - need a little more time :slight_smile:


#19
  1. Open the application called ‘Terminal’
  2. In this application run the command:

flatpak remote-delete gnome -y


#20


where I marked black with an unknown parameter -y