“The Hack GNOME shell extension is not installed”

After installing Endless OS 5.1.0 on a dell and an HP laptop I installed the HACK application but when I run the application I get the following errors:

“The Hack GNOME shell extension is not installed”

Can’t Install “eos-hack@endlessos.org”:
This is an extension enabled by your current mode. You cannot install manually any update in that session.

How do I change modes so I can install the HACK GNOME shell, or resolve my issue in general?

Hi @Levi.

Yes, Hack was removed in Endless OS 5.1 . See the Hack section in the release notes: https://support.endlessos.org/en/endless-os/release-notes/5-1

In its place, Endless OS now includes a curated selection of the best tools for creating your own games, such as GDevelop, Pixelorama, Godot and (in Spanish versions) Pilas Engine.

@manuq how do I install hack then?

Good question, and thanks for pointing out this failure.
We were expecting this to work - the clubhouse tries to install the relevant Hack extension automatically, but as you have pointed out, this is failing.
https://extensions.gnome.org/extension/3690/hack/ is the extension that needs to get installed.

Sadly I think the browser plugin suggested by that site (which requires a host connector) isn’t going to work easily due to complications with Flatpak.

But from https://extensions.gnome.org/extension/3690/hack/ you can select the 3.38 shell version, extension version 11, and that will give you a download named eos-hackendlessos.org.v11.shell-extension.zip.
Extract this into ~/.local/share/gnome-shell/extensions/eos-hack@endlessos.org
then logout, login again,
and I think Hack might work from that point onwards.

@Daniel I tried to extract to the folder but I got an error stating the destination folder is read only.
I am logged in with what should be the admin account but it says I am not the “owner” so I cannot make any changes to the destination folder.
Any advice?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.