Tip | Using Steam on Endless OS

tips

#42

This has already been fixed
Update Steam


#43


#44

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#45

I purchased GTA V. But Proton gives me black screen, Proton beta version - same.


#46

@Blind_Jabber GTA 5 is not on the list of games supported by Proton https://steamdb.info/app/891390

What version of Endless OS are you using?
To check which version of Endless OS you are in Settings :arrow_right: Details

Steam Beta?


#47

#48

@Daniel Could help? :endless:


#49

Hi! When I launch Civilization 6 the game won’t show up / start and in Steam it says that the game is running.
I’ve tried to uninstall steam, uninstall the game, delete the com.valvesoftware.Steam file, restarting my PC and using the kill command on terminal. Can’t start a steam game. Tried everything. I have 3.5.6 Endless os. When I wrote sudo flatpak updatwe saw this:user@endless:~$ sudo flatpak update

Looking for updates…
flatpak update: Warning: No xa.metadata in commit 38efc5893c8b90b2658ed2889bcbdb4d65b2436fb8dcf70feba32932caaeda3f ref app/com.endlessm.translation/x86_64/eos3
flatpak update: Warning: No xa.metadata in commit d820ec5293561d48b6132a57775038ecb75d48effa3eb53011da5eecc945c444 ref app/de.billardgl.Billardgl/x86_64/eos3
flatpak update: Warning: No xa.metadata in commit 3c3c806e5bf6f49651c42b91d063cd9878f8194480006d28dcc11920fa6a6a42 ref app/org.squeakland.Etoys/x86_64/eos3
flatpak update: Warning: No xa.metadata in commit 3d5627ac4bacd36378514cb8dd4b1a52b481f12bac242a7a3f46c8a3f081e167 ref app/org.squeakland.Scratch/x86_64/eos3
flatpak update: Warning: No xa.metadata in commit 63ec8da8222881568631a9278234eacb70b1593dcd0d07832a9299bc0774e0fe ref app/org.gnome.Freecell/x86_64/eos3
flatpak update: Warning: No xa.metadata in commit f7a9b9a91c09d4629f415e13a7f01a03b3b155466d6337ca0c2a6fac05ab6e61 ref app/org.gnome.Solitaire/x86_64/eos3
user@endless:~$

Eos diagnostic file eos-diagnostic-190307_234526_UTC 0200.txt (1.9 МБ)


#50

eos-diagnostic-190406_093328_UTC 0400.txt (445.0 КБ)


#51

Can you try:
flatpak update --appstream
flatpak update -y
flatpak run com.valvesoftware.Steam --reset

This should make sure that you have the latest version of your installed packages and resets the steam sandbox. You have to re-download your games after the last command.


#52

Upgrade to Endless OS 3.5.8

Settings :arrow_right: Details :arrow_right: Look for updates


closed #53

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.