Touch pad problem after a sleeping mode

Hi

I have a problem regarding the touchpad. Once I close the laptop without turning it off, so it switches to a sleeping mode, and then open it up again, the touchpad doesn’t work. Please help me to solve the problem.

Thank you!

eos-diagnostic-200427_224249_UTC 0300.txt (798.1 КБ)

Upgrade to Endless OS 3.8.0 by App Center

Hi!

If the issue persist you can also reproduce the error and send us a diagnostic by following the steps from this article: How do I make a debug log of Endless OS?

Hi, the problem remains even after the update.
eos-diagnostic-200517_052943_UTC 0300.txt (450.0 КБ)

Hi,
after googling around a little bit, it seems that the driver for the ELAN1200 Touchpad (which is the one in your PC) still has some serious issues, ranging from being laggy, over discarding touches, to not working after sleep.

Can you please try to following commands after waking from sleep:

sudo modprobe -r hid-multitouch
sudo modprobe hid-multitouch

If this makes your Touchpad work, we will try to automatically:

  1. Run the first command before sleep
  2. Run the second command after waking up from sleep

I tried the commands - it didn’t help

Here’s diagnotics file after I tried the commands.
eos-diagnostic-200519_083536_UTC 0300.txt (447.9 КБ)

Before digging deeper, can you please open a Terminal and update to the latest version of EOS, 3.8.1 has been released shortly ago:

eos-updater-ctl update

Then reboot and check if the problem is still there. If it is, let us know. Additionally, i highly recommend you to update your Notebooks BIOS Software, yours is rather old and often the manufacturer fixes many issues in there.

https://www.asus.com/support/FAQ/1008859/

I have upted the system to 3.8.1. The problem is still here.

Also, I tried updating BIOS but it doesn’t work when a USB-stick is plugged in. So I didn’t manage to finish the update.

How far have you come with updating?

  1. You need to put the extracted content of the downloaded BIOS to the root of the USB Stick (E403NA-AS.310)
  2. In the BIOS there is a option to start the Updater

If you are stuck somewhere, please post Photos of your Display, so that we can work it out together.

If the stick is plugged in, thw BIOS doesn’t react… So the controllers don’t work, neither does the touchpad

So you can’t enter the BIOS as soon as you plug in the USB Stick, as the Keyboard no longer reacts?

Right. If the stick isn’t plugged in, everything works. But the update file is on the stick

Hm… very interesting. Can you please first enter the BIOS and then connect the USB stick as soon as you are in the Update Section? Does that work?

Nope, the whole process stops once the stick is plugged. So when I am in the Update section and plug in the stick, the process stucks.

This sounds to me like the System has some issues with the USB Stick. If you can, try:

  • Use another USB Stick
  • Use another Port on the device