Two User Accounts Very Slow and Useless Now

I have five user accounts. The one I had been using exclusively for the last five months became so slow that I couldn’t use it any more. The other four are still OK for now. I added another account and after about five weeks it got to be as slow as the previous one and I can’t use it anymore. It takes about 5 to 10 minutes to login. After it launches everything else you click on is very slow: takes at least 5 minutes. I can launch settings in about 5 or more minutes but I cannot do anything with it. Nothing there works.

It looks like each account now will run at normal speed for a while and then really slow down. I created another 10 accounts so that I can keep using the PC. WIll go to the next account when the one I am working on stops working. Kind of incovenient. What do you think is the problem and what can I do? I think I will give admnistrator privileges to all of my accounts as I am the only one using the PC so that I can always add new user accounts just in case the same thing happens to my original admnistrator account. Thanks in advance.

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

@west4 Please make sure to send your diagnostic.

I cannot open theTerminal application not even from the administrator account. First I click on it from Settings then I click on Open In App Center and I get this message:Sorry! There are no details for that application.

I get the same message for the following applications which do not open. They all seem to me systems applications: System Monitor, Archive Manager, Parental Controls, Remote Desktop.

I can open the System application and all of the other apps that I tried that are not system apps like the games and educational apps even from the non administrator account.

The Terminal app shows under Integration that the Search and Notifications are turned on. These are the only two System Features listed. But when you click on Open In App Center I get the Sorry! there are no details for that application message.

I guess there is no solution to this problem?

Can you please send us the diagnostic Leandro mentioned earlier - we need this to do some investigation about your problem.

Unfortunately, I cannot do the diagnostics. See my second post where I said that I cannot open the Terminal application not even from the Administrator account. This is a quote from my post:
“I cannot open the Terminal application not even from the administrator account. First I click on it from Settings then I click on Open In App Center and I get this message:Sorry! There are no details for that application.” I can open most other applications.

Is there any other way to do the diagnostics? And can you open the Terminal application on your computer?
Thanks.

Before logging in, press Ctrl-Alt-F2. This will put you to console mode. Log in there with your user and run eos-diagnostics. If that works you need to copy the resulting file to some USB stick and upload it here.

Process:

sudo bash
mount /dev/sdb1 /mnt
cp eos-diagnostic* /mnt
eject /dev/sdb1

I assume that /dev/sdb1 is the inserted USB stick, which is normally the case if you have only one HDD installed.

If you are unable to generate the diagnostic because your system is sluggish on the console too, make screenshots of the following commands:

  1. dmesg
  2. top

The first one will output a huge amount of information, only the last page is of interest. The second one displays all running processes, ordered by their cpu usage. Eventually some process has gone wild and consumes all of your systems resources.

I cannot run the eos-diagnostics but I can run the dmesg and top commands which give me their respective reports.
The problem is with two user accounts with no administrator privileges. Cntrl-Alt-F2 lets me login through one of my three administrator accounts.
I got the following results when I tried to run the cp eos-diagnostics:
cp: missing destination file operand after eos- diagnostics. Try cp-help for more information.
Another time I got this:
cp-eos diagnostics
endless OS Diagnostics file saved as:
/root/eos-diagnostics-200804_172012_UTC+0800.txt
please send that file(not this message) to endless community or support
Another time I got: bash:/root/eos-diagnotstics…txt: no such file or directory.

When I ran the dmesg I got a long report that scrolls down in a couple of seconds. The command top gave a three and half pages report. I don’t know how to take a screen shot. How do I take a screen shot and send it to you?
Also, the three administrator accounts are OK. It’s just two user accounts with no administrative privileges that slowed down all of the sudden and are so slow that I cannot use them. I assume the other eight new user accounts are OK. It seems that when I ran the two user account in question they might have left information in memory that left me with very little or no RAM memory. Do you think this is a possibility? Thanks.

Another question: How do I check to see how much RAM memory I have left to work with?

Use

cat /proc/meminfo

to get information about the (un-)used memory. The output will look like:

MemTotal:        8124804 kB
MemFree:         6611824 kB
MemAvailable:    7031204 kB
Buffers:           59684 kB
Cached:           395396 kB
SwapCached:            0 kB
Active:           782484 kB
Inactive:         257424 kB
Active(anon):     586276 kB
Inactive(anon):      728 kB
Active(file):     196208 kB
Inactive(file):   256696 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:      12187204 kB
SwapFree:       12187204 kB
Dirty:               116 kB
Writeback:             0 kB
AnonPages:        585016 kB
Mapped:           235320 kB
Shmem:              2164 kB
KReclaimable:      68448 kB
Slab:             187628 kB
SReclaimable:      68448 kB
SUnreclaim:       119180 kB
KernelStack:       13088 kB
PageTables:        16104 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:    16249604 kB
Committed_AS:    4233848 kB
VmallocTotal:   34359738367 kB
VmallocUsed:       99716 kB
VmallocChunk:          0 kB
Percpu:            76800 kB
HardwareCorrupted:     0 kB
CmaTotal:              0 kB
CmaFree:               0 kB
HugePages_Total:       0
HugePages_Free:        0
HugePages_Rsvd:        0
HugePages_Surp:        0
Hugepagesize:       2048 kB
Hugetlb:               0 kB
DirectMap4k:      231232 kB
DirectMap2M:     3962880 kB
DirectMap1G:     6291456 kB

Interesting parts are:
MemFree and SwapTotal/SwapFree. It may be possible that your system has not enough memory and is trying to swap out blocks of memory from currently not used but running applications to disk. To check if this is the case, run:

vmstat 1 100

This will produce something like:

procs -----------memory---------- ---swap-- -----io---- -system-- ------cpu-----
 r  b   swpd   free   buff  cache   si   so    bi    bo   in   cs us sy id wa st
 2  0      0 6573920  67788 494424    0    0   761   194  235  424  4  4 90  2  0
 0  0      0 6541700  67788 499344    0    0  3832     0 1105 1747  6  4 89  2  0
 0  0      0 6553860  67788 499244    0    0     0     4  304  403  1  0 99  0  0
 1  0      0 6553860  67788 499244    0    0     0     0  156  247  0  0 100  0  0

The interesting parts here are the columns si and so which are swap-in (=read from swap into memory) and swap-out (=write from memory to swap). These should be zero in both columns. As soon as your systems starts swapping you have to take action like reducing the amount of background processes or extending your physical memory.

To take a screenshot from the console: Use your Mobile Phone and make a Photo :slight_smile:

Screenshots of dmsge command.
I



These two screenshots come before the first two above.


I couldn’t run cat /proc/meminfo
I ranvmstat 1 100 for first slow accounts. I got a 5 on the first line for so and I got 0 for all other si so.

I ran vmstat 1 100 for the second slow account and I got 0 for all si so.
The second slow account took almost ten minutes to launch. Then it took a few minutes for Chrome to launch and after that it was running at normal speed. I tried again the first slow account that showed a 5 for the first so. It took eight minutes to launch and chrome and settings never launched.

Hi,
you issue isn’t swapping, according to your screenshots it’s probably a faulty HDD. The controller tries to re-read a sector for a long time until it succeeds successfully. This can take a long time and is probably what you feel as a sluggish delay.

Why there are fast accounts is a interesting case too. I can only imagine that some cache is helping here which prevents reads from a fault location (because it’s already in the cache).

Anyway, i highly recommend you to back up your data and replace the drive.

Thanks for the response. I have had other problems with this laptop. It’s an acer laptop that came with Endless installed. It worked fine for a year except at times it freezes completely and I have to force a shutdown to reboot. Other times when it goes into sleep mode it takes a few attempts before it gets going again. Do you think I can use this laptop to download and reinstall Endless OS? Can I downloaded directly on a USB 16G drive which I have or do I need a 64 G drive.

I am not sure I want to download the Endless OS on this HD since it has a least one bad sector. I have a Windows 10 HP laptop. Maybe I can download it from there and put it on a USB drive. I just need the basic OS and don’t need the full version as long as the basic version works for the internet and libre Office. I need it for Word and PDF. Is it easy enough for anybody with limited PC skills to download and install?

When I tried to download it on my HP Windows laptop about a year ago it got a message that I needed to disable bit locker first. Is this still true?

I have to find a HD that will work on this laptop first. How hard is it to replace the HD?