Unable to change resolution/display settings/recognize vga computer monitor

eos-diagnostic-200904_210430_UTC 0200.txt (393.1 KB)

i installed eos on my new rpi4 4gb, i have tried to connect it to a vga monitor, the vga monitor says no input (usually if the resolution is a problem it will say input not supported).
I then connected my rpi4 to a hdmi tv, it then worked. but i am unable to change any display settings, or even use my vga monitor as a second display (its not recognized at all). i have tried rm .config/monitors.xml it says that file does not exist. i tested the vga monitor using raspbian and it works (i did have to change the default resolution to a lower resolution in raspbian)

can you please assist to get my rpi4 to recognize the vga monitor and be able to set the resolution.
thank you

To connect a VGA Display to HDMI, you need an active converter, because HDMI has digital only signals and VGA needs analog ones.

sorry i do have an adapter, iv attached a picture of it
adapter

You can try to “force” the resolution on the output. Open a Terminal, then run:

xrandr

This will display some information about the connected displays. Remember the output (like HDMI-1). Then run:

xrandr --newmode "1920x1080" 173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode HDMI-1 1920x1080
xrandr --output HDMI-1 --mode 1920x1080

You need to replace the values here with your actual values. To calculate those Numbers, use the Tool cvt with the desired parameters, something like:

cvt 1920 1080 60

Will give you the parameters:

Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Grab them from here. If this works for you tell me, then we will write a script which runs on bootup to set this automatically.

i managed to get it to work finally, i copied the config.txt file from my working raspbian sd card
i only uncommented the following commands
hdmi_force_hotplug=1
hdmi_group=2
hdmi_mode=22

strangely enough for the hdmi mode, raspian lets me use a higher resolution of mode 81, but if i try that on endless, it goes back to the message of no signal. would the addmode solution above help me get it to work on 1366x768 60Hz ? instead of being stuck on 1280x768 60Hz

Eventually other options in the config.txt are different, that make a difference? Do a visual compare with the Tool “Meld”