Unable to see wireless icon


#1

Hi,

I installed Endless on my laptop alongside of Windows 7 32 bit OS on Sunday. I don’t see an option to connect wirelessly. I am only getting wired connectivity option. I also don’t see an icon where I can turn wi-fi on or off.

Any solution?


#2

@Krishna_A

https://www.youtube.com/watch?v=Pj31IVuV58w


#3

@LeandroStanger

Thanks for that video, but that still doesn’t help me in sorting out the problem. In the status icons all I can do is turn on/off bluetooth.

Do I need to uninstall and reinstall Endless?


#4

@mhall119 Could help


#5

Hi @Krishna_A,

There are some wireless cards that the manufacturer hasn’t provided us with drivers for, it’s possible that your computer might have one of those. I can check to be sure, but I’ll need to get a diagnostics file from you. Please follow these instructions and upload the file they create into a comment there. Thanks!


#6

eos-diagnostic-171221_114721_UTC 0530.txt (210.8 KB)

Hi @mhall119,

As requested, I have uploaded the diagnostic file. Please let me know if you need anything else.


#7

Unfortunately your wifi device (Broadcom BCM43142) is not supported by Endless OS at this time because it does not have open source Linux drivers. We hope to improve here in future.

In the mean time, you could purchase a USB-WiFi adapter, or alternatively it should be possible to open the computer and replace the internal broadcom WiFi card with a different card that is supported by Linux (e.g. an Intel WiFi card).


#8

Hi Daniel,

Thanks for that information. Will any USB wireless adapter work? Or do you have any recommendation? I also have one in mind (TP-Link TL-WN725N 150Mbps Wireless N Nano USB Adapter)(Black)).
Merry Christmas and a Happy New Year.


#9

I’m not really sure if that device will work well with the drivers we include in Endless.
It looks like that one well-supported device is the D-Link DWA-131 rev E1


#10

TP-Link adaptors are generally very good. Their site (http://www.tp-link.com/us/download/TL-WN725N.html#Driver) includes Linux drivers. I do not know if Endless includes support for those drivers the drivers, but TP-Link adaptors generally work out of the box with various Linux distress.

bill


#11

@wove I purchased TP-LINK TL-WN823N. I am able to see the list of available wireless networks but am not able to connect to them. I downloaded the Linux driver from this link http://www.tp-link.com/us/download/TL-WN823N.html#Driver. Is Linux the correct driver to download? If so, how do I install the driver?

Thanks for all your help in advance.


#12

Endless OS would use the Linux drivers. Endless does not permit installing low level system items. I do not know what if any TP-Link drivers are included with Endless. The WN725 adapter I have works out of the box. It is based on RealTek, which is generally supported out of the box in Linux.

You could include diagnostic file and ask that the Endless team look at it and ask them if possible to include the TP-Link drivers.

Sorry I know that is not specifically helpful, but the Endless team is very good and will probably respond once the hub-bub of the holidays have past.

bill


#13

@Krishna_A seconding this: please connect your TP-Link wireless device, attempt to connect to a network, then follow these instructions and attach the new diagnostics file here.


#14

@wjteos-diagnostic-180105_115029_UTC 0530.txt (234.5 KB)
Hi Will,

I am attaching the diagnostics file as requested.

Please let me know if you need anything else and thanks a lot for all your help. Another question. Should I go ahead and purchase WN725 at this point? Please let me know.


#15

Hi, thanks for this log. Here’s the interesting stuff:

Jan 05 11:47:12 endless kernel: usb 1-1.1: RTL8192EU rev B (SMIC) 2T2R, TX queues 3, WiFi=1, BT=0, GPS=0, HI PA=0
...
Jan 05 11:47:26 endless wpa_supplicant[635]: wlxd46e0eae7ecd: SME: Trying to authenticate with 6c:72:20:f9:b0:44 (SSID='ASHOK' freq=2472 MHz)
Jan 05 11:47:26 endless kernel: wlxd46e0eae7ecd: authenticate with 6c:72:20:f9:b0:44
Jan 05 11:47:26 endless NetworkManager[602]: <info>  [1515133046.5306] device (wlxd46e0eae7ecd): supplicant interface state: scanning -> authenticating
Jan 05 11:47:26 endless kernel: wlxd46e0eae7ecd: send auth to 6c:72:20:f9:b0:44 (try 1/3)
Jan 05 11:47:26 endless kernel: wlxd46e0eae7ecd: send auth to 6c:72:20:f9:b0:44 (try 2/3)
Jan 05 11:47:26 endless kernel: wlxd46e0eae7ecd: send auth to 6c:72:20:f9:b0:44 (try 3/3)
Jan 05 11:47:27 endless kernel: wlxd46e0eae7ecd: authentication with 6c:72:20:f9:b0:44 timed out
Jan 05 11:47:27 endless NetworkManager[602]: <info>  [1515133047.1720] device (wlxd46e0eae7ecd): supplicant interface state: authenticating -> disconnected
Jan 05 11:47:27 endless NetworkManager[602]: <info>  [1515133047.2722] device (wlxd46e0eae7ecd): supplicant interface state: disconnected -> scanning
[... a few more attempts ...]
Jan 05 11:47:46 endless wpa_supplicant[635]: wlxd46e0eae7ecd: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="ASHOK" auth_failures=2 duration=20 reason=CONN_FAILED
Jan 05 11:47:46 endless NetworkManager[602]: <info>  [1515133066.7204] device (wlxd46e0eae7ecd): supplicant interface state: authenticating -> disconnected
Jan 05 11:47:50 endless NetworkManager[602]: <warn>  [1515133070.7648] device (wlxd46e0eae7ecd): Activation: (wifi) association took too long, failing activation

I searched our internal support system and it seems we’ve seen similar problems with this exact chipset (RTL8192EU) before. The last user who reported this issue said that they tested the device on some other Linux machines – it worked on 32-bit Ubuntu but not on 64-bit Ubuntu (which is the most similar to Endless OS). Do you have access to a 64-bit Ubuntu machine that you could test this device on, both out-of-the-box and with the driver from TP-Link’s website? (It’s not possible to add new drivers on your own machine on Endless OS.)

If @wove’s got this exact device and it works, this would probably be the quickest path to working wireless on your Endless system!


#16

I don’t have a 64 bit Ubuntu. I also tried loading Ubuntu using a CD drive and plugged the adapter, however I am not able to see the wireless icon. I am not sure how to install drivers for Linux Ubuntu. How to check kennel version for Ubuntu and Endless OS? I have version 14.04 LTS. I think I should purchase the WN725 adapter.


#17

@wjt I purchased a Tp_Link WN725N to use because at the time I installed Endless it did not support the Broadcom card installed in my laptop (Dell DW1510). The WN725 worked just fine with Endless, however with an update Endless added support for the Dell DW1510 and the WN725N was no longer needed.

I wanted to confirm that the WN725 was still working with Endless, but I discovered that it appeared to no longer connect to the wireless network. Upon further investigation I found the WN725 would work if I removed the built in wireless card.

I found that the network preferences which has a switch to turn off wireless cards does not actually allow the user to select which wireless card/adapter they want to use.

It seems like there is a possibility of an internal wireless card blocking a USB wireless adapter from working. I would suggest @Krishna_A hold off purchasing another wireless adaptor until this is investigated a bit more.

bill


#18

HI Again,

I installed Endless OS today and see that I am able to connect to wireless using the TP-LInk adaptor I already have WN725, however there is no sound output in my Dell Vostro 2520 Laptop. eos-diagnostic-190106_163800_UTC 0530.txt (8.7 MB)

I have also uploaded the EOS diagnostic file.

Please advise.


closed #19