Unable to update/install anything


#21

fix-repo.log (2,5 KB)
eos-diagnostic-170914_225539_UTC 0200.txt (360,3 KB)

Just tried your suggestion from the other topic. Updates are not working. Sadly I am not sure if I’ve done it the right way. There so many comments and commands… Many thanks to you for caring :slight_smile:


#22

Were you still connected to the internet when you ran this?

GLib.Error: g-resolver-error-quark: Error resolving ‘ostree.endlessm.com’: Name or service not known (0)

It’s very strange that you keep getting these errors resolving host names. I’m beginning to wonder if it’s a problem with your internet service provider and not with Endless OS itself. @wjt @dan thoughts on this one?


#23

It got past the important parts of the script, but you’re having a network issue as @mhall119 pointed out. These types of issues should not normally cause problems with the system (I don’t think it’s what caused you to get into this state), but it does cause a problem for this script, which is trying to download missing files. There are 2 issues with you’re repo indicated by these messages:

Marking commits with missing objects as partial in /sysroot/ostree/repo
Commit 8c30669098ec948fa948aee79e17441268d169542e7d39ea46d06ebc0f6d0f7a already marked as partial
Commit 544227a635b16b31833ee446661a8c108d364e9c8909748848f3c937eaef842f already marked as partial

That means that some app/runtime/os is missing files in the repository. What happens next is that one of these tries to be updated to get the missing files:

Pulling 8c30669098ec948fa948aee79e17441268d169542e7d39ea46d06ebc0f6d0f7a commit from eos-sdk for runtime/com.endlessm.apps.Platform.Locale/x86_64/1

But then you hit the networking problems. You can just keep running this script until it succeeds, though. It will just pick up where it left off.

Thanks very much for the feedback. I’ve never had a system with these issues, so it’s been a little hard to figure out how to fix them :slight_smile: If you don’t mind, can you run the following command:

for ref in `ostree refs`; do rev=`ostree rev-parse $ref`; echo $ref $rev; done

You can just paste the output in your reply. Thanks!


#24
flow@flow:~$ for ref in `ostree refs`; do rev=`ostree rev-parse $ref`; echo $ref $rev; done
eos-apps:app/org.gnome.Gnote/x86_64/eos3 3c228ba5d49c4e5bf2874edeb0aeedb99d5e2169d60682f5d54ca45a3d835fb3
eos-apps:app/org.gnome.Solitaire/x86_64/eos3 f7a9b9a91c09d4629f415e13a7f01a03b3b155466d6337ca0c2a6fac05ab6e61
eos:os/eos/amd64/eos3 544227a635b16b31833ee446661a8c108d364e9c8909748848f3c937eaef842f
ostree/1/1/0 9c37aaeaf98a3777a05c522d3a6470796fafe04221b2f1b37a1ae224395057c2
gnome:runtime/org.gnome.Platform/x86_64/3.22 d44159b609a60910cc4ac6176bcac448ae1a964b81b1917598d6246ec1838d9d
gnome:appstream/x86_64 c117e3684254a08f71bce0a8daa6098cafd34a6d58a6bb2e084aa344ece12078
eos-sdk:runtime/com.endlessm.apps.Platform/x86_64/1 8c0184e8734ec784fe5c9cb74b7e6f216002509680ff0223bc04d32f8f78a9c7
gnome-apps:appstream/x86_64 1970684b8e3b1493a4d46cd81707a7822d19aa6750b02215dbbda7444ed6fbb6
eos-apps:app/org.mozilla.Firefox/x86_64/eos3 3cd1c5e1dd8b6570c108e56fffd7f8294be57f9d952b90185baa1b272471ca5d
eos-sdk:runtime/com.endlessm.apps.Platform.Locale/x86_64/1 8c30669098ec948fa948aee79e17441268d169542e7d39ea46d06ebc0f6d0f7a
eos-sdk:app/com.endlessm.EknServices/x86_64/eos3 da7df31933c8b06ea6f934060e02f1e4a1b8fa527d1e8c1b8babaee0f70cabae
eos-apps:appstream/x86_64 d9b420831a84e8b1fe6db6fce7b3810514324c7fa5790bfba920fcf96f860c9e
eos-runtimes:appstream/x86_64 6e5478b58f591c8b5702be28a42a9c3ee5ffd5057c17b4531622163ecbac1823
eos-sdk:appstream/x86_64 a6c73ffb7dd6b2abdaa2326ba7256e71504acf79eb03a9e540745270a479fc87

Ok, again, many thanks for your help. I’ll try to fix my problems in running the script again and again :wink:
I’ll tell you about result, if there will be one. Thought my internet connection was doing well, so let’s see…


#25

Hello, connoisseurs. I have a similar problem. The AppCenter informs me of an update to the Endless Platform, but when I click Update, the line disappears for a few seconds, and then it reappears. What’s interesting is that the update has been installed through the terminal.

It’s not a problem, just a little annoying.


#26

@NofFyddink
Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command: eos-diagnostics
  3. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

#27

Thanks for answer. Sorry, I read the whole thread, but i’m did not to do it immediately. Tonight, when I’m being at home, I’ll definitely do it and attach the file.


#28

Hi!
Now I tried to run the script several times, but nothing has changed.
It always had stopped at the same time and now it is not working at all.

I will try the update in an other ones wifi, when I get the time to do that.
When your guesses are right it should work in a well-performing network?!


#29

eos-diagnostic-170918_210248_UTC 0300.txt (830,9 КБ)


#30

If it’s something strange about your particular network yes, that should make it work.


#31

@LeandroStanger Well, were there any oddities?


#32

@wjt @mario @roddy @feaneron @ramcq Could help


#33

I mean report


#34

wait for some developed respond


#35

Ok. Thanks, I’ll be wait.


#36

@NofFyddink I think that is a known, and harmless, problem. But the log doesn’t actually have anything relevant in it. Can you reboot your computer; launch the app center; reproduce the problem (click update, wait for the line to disappear and reappear); then re-run eos-diagnostics and attach the new log here.


#37

Ok, i’ll do it later.


#38

eos-diagnostic-170920_205510_UTC 0300.txt (324,1 КБ)


#39
сен 20 20:53:41 endless gnome-software-service.desktop[1115]: 17:53:41:0058 GsPluginEos system/flatpak/*/runtime/com.endlessm.apps.Platform/1 runtime cannot have runtime!
сен 20 20:53:41 endless gnome-software-service.desktop[1115]: 17:53:41:0061 GsPluginEos system/flatpak/eos-sdk/runtime/com.endlessm.apps.Platform/1 runtime cannot have runtime!
сен 20 20:53:41 endless gnome-software-service.desktop[1115]: 17:53:41:0064 GsPluginEos system/flatpak/*/runtime/org.gnome.Platform/3.22 runtime cannot have runtime!
сен 20 20:53:41 endless gnome-software-service.desktop[1115]: 17:53:41:0066 GsPluginEos system/flatpak/gnome/runtime/org.gnome.Platform/3.22 runtime cannot have runtime!
сен 20 20:53:48 endless gnome-software-service.desktop[1115]: 17:53:48:0198 GsPluginEos system/flatpak/eos-sdk/runtime/com.endlessm.apps.Platform/1 runtime cannot have runtime!

I believe this is going to be fixed with the 3.3.0 update.


#40

Good. And is there information - when will the update be released?