USB Webcam not detected

I have plugged an USB webcam to the PC.

In the eos-diagnostic I can see the webcam is plugged:
Bus 009 Device 002: ID 041e:4055 Creative Technology, Ltd Live! Cam Video IM Pro

But no app can detect it. It is as if the webcam wasn’t plugged at all. I have tried several USB ports without success. I tried with Zoom, Webcamoid, Cheese and the webcam does not appear and is not detected.

What can I do to solve this? Thank you.

eos-diagnostic-231129_151355_UTC-0400.txt (1.3 MB)

The webcam is working well on an old windows system.

Sorry, looks like this webcam is not supported by modern versions of Linux.

Thank you for the reply. What a surprise that even Linux practices planned obsolescence. Endless…

So I have to bury myself one more Congolese child mining coltan so we can produce another product. Sorry dear Chinese political prisoners, looks like Endless has expired the Creative driver lifetime.

How do I know the next new webcam I buy today will be Endless compatible? Is there a list somehow? Would Logitech be a preferable choice? Logitech write: Windows 8+, macOS 10.10+, ChromeOS.

Jesus called in a loud voice, “Lazarus, come out!” The dead man came out, his hands and feet wrapped with strips of linen, and a cloth around his face. Could a IT developer bring back to life the Creative Live! Cam Video IM Pro which is not dead really.

Thank you. Endless

1 Like

Unfortunately looks like the webcam only ever had limited support on Linux through installing external/experimental drivers and such, if it had obtained an “out-of-the-box” level of support back in the day it would have probably had a much longer support lifetime.

Any USB webcam you buy today is almost certainly going to work just fine, USB webcams have been closely adhering to a common standard in recent years. The fact the Logitech one you mention has ChromeOS support is a very promising sign, because ChromeOS is based on Linux and doesn’t let you install special drivers.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.