Was unable to update Freedesktop Platform after 3.8.4 upgrade

Before upgrading to new version 3.8.4 I performed all notified regular updates which went fine except Freedesktop Platform update did not proceed. Figuring this might need the system upgrade first I went ahead and did that but still no Freedesktop Platform update - just hung at Preparing… Meanwhile GNOME Application Platform successfully updated to version 3.36.
Soo… I ran sudo flatpak repair and everything verified OK. Then I ran sudo flatpak update with the following terminal output:

Looking for updates…
Info: org.gnome.Platform.Locale is end-of-life, with reason: The GNOME 3.32 runtime is no longer supported as of 11th March 2020. Please ask your application developer to migrate to a supported platform.
Info: org.gnome.Platform is end-of-life, with reason: The GNOME 3.32 runtime is no longer supported as of 11th March 2020. Please ask your application developer to migrate to a supported platform.

    ID                                Branch Op Remote  Download
  1. [✓] org.freedesktop.Platform.openh264 19.08 u flathub 1.0 kB / 117 bytes
  2. [✓] org.gnome.Platform.Locale 3.36 u flathub 1.0 kB / 323.0 MB
  3. [✓] org.gnome.Platform 3.36 u flathub 2.7 MB / 324.5 MB

Updates complete.
denis@endless:~$

NOW everything is running fine after a reboot with no more updates available BUT I have ended up with TWO Freedesktop Platforms installed, one of size 822.6MB and the other 694.8MB.
That does not worry me if everything works but one question is do I need both and which one should I delete (I remember it was asking me to update the 694.8MB file so presumably that is the old one)?

I hope this might help you as it appears org.gnome.Platform is EOL and that was holding up my update.
Any feedback you can give would be appreciated.

Hi!

Thanks for notifying, Can you send us a diagnostic?

How do I make a debug log of Endless OS?

This is the debug file I just created:

eos-diagnostic-200710_091910_UTC-0400.txt (1.02 MB)

  1. Open the application called ‘Terminal’
  2. In this application run the command:

flatpak uninstall --unused -y

Well this is interesting! I booted up Endless OS and was again given the option to update FreeDesktop Platform (19.08.11) which as I type this is still again stuck in Preparing… after bigger download this time of 89.1MB (was just 117bytes before). Original FreeDesktop is version 18.08.39 822.6MB but system will not let me uninstall now because the replacement is NOT installed. In Terminal, repair still verifies OK BUT update just gives me the same warnings about outdated org.gnome.Platform and then says “Nothing to do.” (presumably because regular installer is stuck but it does not give me the chance to override and force install).
What next??
OK after writing the above I rebooted and now FD Platform 19.08.11 was installed and no further software updates available, plus BOTH FD Platforms appeared installed in App Center.
I tried running your terminal command but only got “Nothing unused to uninstall” with or without sudo.
So… I went into AppCenter and tried uninstalling both Platforms but now got following messages:
Cannot uninstall 18.08 as needed by com.google.Chrome/eos3
Cannot uninstall 19.08 as needed by org.libreoffice.Libreoffice/stable
I do not mind if both Platforms stay installed as long as these two Apps work but I assume it is something you will need to clean up. I do not want to have to keep reinstalling 19.08 if it disappears again but Libreoffice may crash according to the message I’m getting.
Let me know if you want to try any other solution - it’s COVID19 time after all and I’m retired anyway!

Hi,

As you noted you need both those runtimes installed as long as you have apps which use them. The App Center’s download size estimates are not fully accurate so it may be that it’s telling you an update is several hundred MB when in reality it is far less than that.