App-Center plugins missing

Hello, I have problems with the app center. The update does not work, a plugin is missing. Already browsed all posts, but no solution found. If someone could help me, that would be very nice.

packagekit-refine
rpm-ostree
epiphany

Hi, please access the Terminal app and enter this command:

eos-updater-ctl update
flatpak update --appstream -y
flatpak update -y

In addition to the commands Byron_Diaz gave, can you please also provide us with a diagnostic if the problem still persists.

eos-diagnostics

Endless OS doesn’t use packagekit, rpm-ostree or epiphany, so there’s no reason these plugins should be present. The cause of this issue must be something else!

Please run:

gnome-software --quit
gnome-software --verbose 2>&1 | tee gnome-software.log

then reproduce the problem. Now, hit Ctrl+C. Run:

eos-diagnostics

and attach both the diagnostic file, and gnome-software.log from your home directory.

Hi, thanks for your suggestions. Did it all. Attached now the files. Thank you in advanceeos-diagnostic-200829_113217_UTC 0200.txt|attachment (838,2 KB) gnome-software.log (436,4 KB)

again …eos-diagnostic-200829_113217_UTC 0200.txt (838,2 KB)

These errors in your gnome-software log are suspicious:

09:31:07:0528 OSTree Ignoring remote ‘gnome’ due to no valid collection ID being configured for it: Remote "gnome" not found
09:31:07:0528 OSTree Ignoring remote ‘gnome-apps’ due to no valid collection ID being configured for it: Remote "gnome-apps" not found

But I don’t have a solution, sorry.

A couple of ideas:

  1. Do you have parental controls configured for this user? What does malcontent-client display if you run it in a Terminal window?
  2. You have org.gnome.Iagno installed from eos-apps, but this should have been moved to flathub many OS updates ago. Please open a Terminal window and run:
pkexec /usr/sbin/eos-update-flatpak-repos

You will need to authenticate. Once it is complete, please copy the output to a text file, save it, and restart your computer.

Hello, did as recommended, without success, everytime when running the proramm-app-tool “no such Metadata Object hfu9988w9934b …” .Enclosed the txt-file with pkexec output.eos-update-flatpak-repos-200911.txt (1,0 KB)

No such metadata object 0cf327988d5c326bf3efaa4251ef019ee2006d84f1eb6736c03b6cd6a9bc5e3a.commit

OK, this is a good clue. Thanks for providing the full output. Run these two commands:

gnome-software --quit
flatpak uninstall app/org.gnome.Iagno/x86_64/eos3

If that succeeds, open the app center again and try to update once again.

If it fails, try:

gnome-software --quit
pkexec eos-fix-ostree-repo

(It will take a long time).

Hi, after uninstalling app started without errror message, now it’s updating 30 - 40 apps, it takes some time …

1 Like

OK, it works so far, everything was updated except “com.endlessm.apps.platform 3” and “freedesktop.platform 19.08.12”. Any idea? And many thanks for your help.

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)