Beta Release | Endless OS 3.9.0~beta1

The first beta of Endless OS 3.9.0 is now out. Please follow these instructions if you want to join the beta testing program; bear in mind that the chance of encountering bugs is higher than in a regular stable release. As always, please ensure your data is backed up!

Endless OS 3.9.0 and later will only be available for 64-bit systems. 32-bit ARM devices, such as Endless Mini, will remain on 3.8.7.

GNOME 3.38

In this release the desktop and most of its components were updated to the versions from GNOME 3.38, bringing new features, performance improvements and bug fixes.

Updated hardware support

We have updated our low-level software platform, which should improve stability and hardware compatibility.

  • Linux kernel 5.8, bringing support for the latest PC hardware and several fixes to existing drivers and core kernel code, including security fixes.
  • NVIDIA driver 450.66, adding support for new NVIDIA graphics cards.
  • Other low-level userspace components were also updated, bringing in new features and bug-fixes (e.g. systemd, Xorg, etc).

In addition, a number of hardware support bugs were fixed for this release, improving and expanding the hardware compatibility of Endless OS.

Other Improvements and Changes

  • The desktop application grid now always display all installed applications in the system, making it easier to find new applications and content.
  • Flatpak was updated to version 1.8.2 to keep compatibility with the latest features and bug fixes.
  • Other general bugfixes and improvements.
2 Likes

@andrunko The Podman been updated?

Podman was 1.5.1 on 3.8.7 and is still on the same version in Beta 1.

@andrunko:

Question 1:

Is it by purpose, that the Icon for the Documents Application has been changed to GNOME default and no longer is the one used in 3.8.7?

Question 2:

Will there be a option to run a Wayland session instead of the (good working, but aging) Xorg one?

Yep, unfortunately we’ve not been able to update Podman in this cycle.

Yes!

X will remain the default for this cycle but we hope to make Wayland an option.

There are some issues with Bluetooth in this Beta, but i have to do more investigation about it.

Symtoms:

Unable to pair any new devices with 3.9.0~beta1. In the GUI, no error message is shown, when pairing with bluetoothctl, one of the following errors is spilled out during the connect phase:

Failed to connect: org.bluez.Error.InProgress
Failed to connect: org.bluez.Error.Failed

Workaround:

Pair the device in 3.8.7, it will still continue to work as expected in 3.9.0~beta1

Testhardware:

  • Intel Wireless AC9260
  • Edimax Wifi AC600 Bluetooth 4.0 USB Adapter

Both show the same behavior

/edit:
The device class doesn’t matter. Tried HID and OBEX devices, same behavior. Below a sample showing the full pairing attempt with my iPhone:

egon@nevermind:~$ bluetoothctl
Agent registered
[Keyboard K380]# power on
Changing power on succeeded
[Keyboard K380]# agent on
Agent is already registered
[Keyboard K380]# scan on
Discovery started
[CHG] Controller A0:51:0B:FA:5D:F1 Discovering: yes
[CHG] Device 71:EC:1C:C3:83:6B RSSI: -41
[CHG] Device 71:EC:1C:C3:83:6B TxPower: 7
[CHG] Device 75:27:A2:08:38:11 RSSI: -91
[NEW] Device 88:A4:79:7D:4A:26 Egon iPhone 11 Pro Max
[Keyboard K380]# pair 88:A4:79:7D:4A:26
Attempting to pair with 88:A4:79:7D:4A:26
[CHG] Device 88:A4:79:7D:4A:26 Connected: yes
Request confirmation
[agent] Confirm passkey 511271 (yes/no): yes
[CHG] Device 88:A4:79:7D:4A:26 Connected: no
[CHG] Device 88:A4:79:7D:4A:26 Connected: yes
[Keyboard K380]# trust 88:A4:79:7D:4A:26
[CHG] Device 88:A4:79:7D:4A:26 Trusted: yes
Changing 88:A4:79:7D:4A:26 trust succeeded
[CHG] Device 88:A4:79:7D:4A:26 Modalias: bluetooth:v004Cp730Ad0D70
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 00000000-deca-fade-deca-deafdecacafe
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 00001000-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 0000110a-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 0000110c-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 0000110e-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 00001116-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 0000111f-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 0000112f-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 00001132-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 00001801-0000-1000-8000-00805f9b34fb
[CHG] Device 88:A4:79:7D:4A:26 UUIDs: 02030302-1d19-415f-86f2-22a2106a0a77
[CHG] Device 88:A4:79:7D:4A:26 ServicesResolved: yes
[CHG] Device 88:A4:79:7D:4A:26 Paired: yes
Pairing successful
[CHG] Device 88:A4:79:7D:4A:26 ServicesResolved: no
[CHG] Device 88:A4:79:7D:4A:26 Connected: no
[Keyboard K380]# connect 88:A4:79:7D:4A:26
Attempting to connect to 88:A4:79:7D:4A:26
Failed to connect: org.bluez.Error.Failed

I wrote up my thoughts/comments on my blog. Overall, great stuff!

2 Likes

@nedrichards Thanks for that, appreciated! Some of the issues reported there are already being tracked and will be available in the final version, some others are being discussed and will likely be addressed in the final release or in a subsequent release. We just released beta2 which includes a change to increase the target area when dragging icons from different pages of the desktop grid, please try it out and let us know if it works any better for you.

Yeah, that’s much faster and easier to use (once you know where to go of course). Still has the behaviour where you have to “knock” on the active area to advance more than one screen at a time.

Also the lack of two line labels is somewhat unfortune for “Document…” and “Document…” (that’s Viewer and Scanner) next to each other by default on my last screen (not on the grid before, added in alphabetical order on migration)

1 Like

Would The Developers of Endless Possibly Put into The Next Edition A Virtual Assistant To Help with Online Chores!

This version of OS does not run Steam Launcher. I wrote in support of Steam and was told: “Apparently, there was an error while loading one of the .dll files in Steam. This error may have several reasons.”
Most likely, this means that EndlessOS 3.9.0~beta1 doesn’t have or damaged the software component that Steam needs.
Please fix it in the new version, Steam is one of the programs I often run in Endless OS.
p.s. I had to roll back to a stable OS version to continue using Steam.

What happens if you run it from a terminal with:

flatpak run com.valvesoftware.Steam

(please post the output here)

Additionally, there are various things you can try:

Resetting Steam

flatpak run com.valvesoftware.Steam --reset

or Completely removing Steam, all its Data and Reinstall the latest version

flatpak uninstall com.valvesoftware.Steam
flatpak update --appstream --assumeyes
flatpak update --assumeyes
rm -Rf ~/.var/app/com.valvesoftware.Steam
flatpak install flathub com.valvesoftware.Steam --assumeyes

I installed a new version of Endless OS beta and there this bug has already been fixed. If you tell me how to rollback to the first beta version, I will follow your instructions.

Hi there! My screen displays error:no such device:ostree,can not turn it on,how can I fix it?
Thanks in advance!
Chuky

Thank you very much for your help but I am completely useless with programs, and I do not have a USB stick with Endless programme so at the moment I am seriously considering buying a cheap second hand laptop. I am disappointed because my Asus vivo book lasted only 50 weeks to the day. Was bought new on the 4th.of November last year.
Thanks again for your help.

Charlie

Hi Charlie,

The hardware of your computer works fine, you don’t need a new one! This is an unfortunate software bug which can be worked around. If you get in touch with Asus (or the place where you bought the laptop) they should be able to re-install it with a working version of Endless OS. But, if you can get hold of absolutely any Linux USB stick to boot from, simply accessing the Endless OS hard drive from a different OS, can make this problem disappear, or if needed you can follow the steps that @egrath describes.

Thanks,
Rob

Thanks a lot for your help, Very kind of you.
Kind regards

Charlie