Endless OS 3.8.0 не удается установить приложения

Не удается установить приложения из центра приложений.

Hi,
open a Terminal and type:

flatpak update --appstream -y
flatpak install -y org.telegram.desktop
eos-add-to-desktop org.telegram.desktop

Hi!

Please let us know if it works.

Something that would help us a lot to understand the problem would be this:

  1. Open the application called ‘Terminal’
  2. In this application run the command:

eos-diagnostics

  1. The above command will create a file with the information of your system (example: eos-diagnostic-160614_111731_UTC + 0100.txt); Send us this file so we can analyze and see a possible solution

eos-diagnostic-200507_101916_UTC 0300.txt (688.6 КБ)

Do have configured any other Flatpak repositories beside the ones installed per default? In the Screenshot above i see a remote “winepak”, but can’t find any reference to it in the diagnostic log.

Да, пытался настраивать репозитории и добавлять новый. Ошибка возникла до установки репозитория, с самого момента установки операционной системы. Высылаю свежий лог.eos-diagnostic-200508_143538_UTC 0300.txt (880.8 КБ)

  1. Open the application called ‘Terminal’
  2. In this application run the command:
killall gnome-software
flatpak remote-delete winepak -y
flatpak update --appstream && flatpak update -y
eos-updater-ctl update
flatpak uninstall -y --unused
gnome-software

qwe@endless:~$ killall gnome-software
qwe@endless:~$ flatpak remote-delete winepak -y
ошибка: Неизвестный параметр -y
qwe@endless:~$ flatpak update --appstream && flatpak update -y
Updating appstream data for remote eos-apps
Updating appstream data for remote eos-runtimes
Updating appstream data for remote eos-sdk
Updating appstream data for remote flathub
Error updating: Error updating appstream2: No such ref (org.flathub.Stable, appstream2/x86_64) in remote flathub or elsewhere; Error updating appstream: No such ref (org.flathub.Stable, appstream/x86_64) in remote flathub or elsewhere
Updating appstream data for remote winepak
Looking for updates…
Info: org.gnome.Platform.Locale is end-of-life, with reason: The GNOME 3.32 runtime is no longer supported as of 11th March 2020. Please ask your application developer to migrate to a supported platform.
Info: org.gnome.Platform is end-of-life, with reason: The GNOME 3.32 runtime is no longer supported as of 11th March 2020. Please ask your application developer to migrate to a supported platform.
Nothing to do.
qwe@endless:~$ eos-updater-ctl update
Changed state to Polling
Changed state to Ready
======= Properties =======
State: Ready
CurrentID: ‘51610f7af0cc1d2e0880024e634d00883a0f61bbdf00656f384aa7fb647f5789’
DownloadSize: int64 0
DownloadedBytes: int64 0
ErrorCode: uint32 0
ErrorMessage: ‘’
ErrorName: ‘’
FullDownloadSize: int64 0
FullUnpackedSize: int64 0
OriginalRefspec: ‘’
UnpackedSize: int64 0
UpdateID: ‘’
UpdateLabel: ‘’
UpdateMessage: ‘’
UpdateRefspec: ‘’
Version: ‘’

Traceback (most recent call last):
File “/usr/bin/eos-updater-ctl”, line 409, in
main()
File “/usr/bin/eos-updater-ctl”, line 405, in main
sys.exit(args.function(**args_dict))
File “/usr/bin/eos-updater-ctl”, line 209, in command_update
force=force, timeout=timeout)
File “/usr/bin/eos-updater-ctl”, line 191, in command_fetch
return command_dbus(‘fetch’, block, quiet, parameters)
File “/usr/bin/eos-updater-ctl”, line 159, in command_dbus
proxy.call_sync(qualified_method_name, parameters, 0, -1, None)
gi.repository.GLib.Error: g-io-error-quark: GDBus.Error:com.endlessm.Updater.Error.WrongState: Can’t call Fetch() while in state Ready (36)
qwe@endless:~$ flatpak uninstall -y --unused

    ID                                    Ветка         Op
  1. [-] org.gnome.Platform 3.32 r
  2. [-] org.gnome.Platform.Locale 3.32 r
  3. [-] org.winepak.Platform.Compat32 3.0 r
  4. [-] org.winepak.Platform.Locale 3.0 r

Uninstall complete.
qwe@endless:~$ gnome-software
12:57:17:0485 Gs plugin appstream took 1,6 seconds to do setup
12:57:17:0656 Gs enabled plugins: desktop-categories, dpkg, eos-updater, external-appstream, os-release, provenance, appstream, provenance-license, desktop-menu-path, flatpak, hardcoded-blacklist, rewrite-resource, eos, eos-blacklist, icons, malcontent, odrs, key-colors, key-colors-metadata
12:57:17:0656 Gs disabled plugins: dummy, repos, generic-updates
12:57:18:0629 Gs Couldn’t hold the Mogwai Scheduler daemon: GDBus.Error:org.freedesktop.DBus.Error.Failed: D-Bus peer ‘:1.432’ already has a hold on the scheduler
12:57:40:0349 Gs not handling error failed for action refine: failed to get permissions: Unable to load metadata from remote flathub: No such ref (org.flathub.Stable, ostree-metadata) in remote flathub or elsewhere
12:57:40:0771 Gs not handling error failed for action refine: failed to get size: Unable to load metadata from remote flathub: No such ref (org.flathub.Stable, ostree-metadata) in remote flathub or elsewhere
12:58:09:0471 Gs not handling error failed for action refine: failed to get permissions: Unable to load metadata from remote flathub: No such ref (org.flathub.Stable, ostree-metadata) in remote flathub or elsewhere
12:58:09:0603 Gs Result of screenshot downloading attempt with status code ‘6’: Peer failed to perform TLS handshake: Ошибка при получении данных: Соединение разорвано другой стороной
12:58:09:0620 Gs Result of screenshot downloading attempt with status code ‘6’: Peer failed to perform TLS handshake: Ошибка при получении данных: Соединение разорвано другой стороной
12:58:10:0441 Gs not handling error failed for action refine: failed to get size: Unable to load metadata from remote flathub: No such ref (org.flathub.Stable, ostree-metadata) in remote flathub or elsewhere

Can you please perform the following steps:

  1. Run the following command
flatpak install --verbose --ostree-verbose -y org.telegram.desktop 2>&1 | tee ~/telegram.txt

This will again try to install Telegram, but this time does a very verbose logging of every action taken. A file named telegram.txt will be created in your Home Directory. Please upload this file to this thread here.

telegram.txt (4.2 КБ)

OK, here we are. I think the problem is because of this error:

Ignoring remote ‘flathub’ due to error loading its refs: Peer failed to perform TLS handshake: Ошибка при получении данных: Соединение разорвано другой стороной

For some unknown reason, the TLS Handshake which is used to establish a secure connection between your computer and the remote one terminates unexpectedly.

IMHO there is something between EOS and Flathub which tries to intercept the connection, eventually some kind of Antivirus with Packet Inspection running on your Host (as you are running in VirtualBox)