Firefox no longer working after update to Endless OS 3.8.0

Hi!
I have a similar problem. Firefox stopped loading any page yesterday after a few days with the new release. I tried flushing the dns, but the commands I found on google refer to a nsdc file which is missing. I read everything about eos 3.8 and I followed the thread.I also uninstalled and reinstalled Firefox twice. I managed to roll back to eos 3.7.8 last night and Firefox got back online, I spend couple of hours fixing it as it was before the re-installation. Then I turned it off. This morning Updates said Firefox needs to “update” 76.0 ->75.0. Even before I did this update, Firefox started giving me the same message “We can’t connect to the server at support.mozilla.org.” for all websites. Logs returns several important notes, “unable to create socket on wlp3s0 (5) for fe80::3ecf:a0a2:****:32f6%3#123”, which is my IPv6 address. I rolled back once more and I will restart after I send this post.
EDIT: After rolling back, I actually rolled back to 3.8, so I rolled back back to 3.7.8. And I got Firefox back on. I restated the laptop and after the restart Firefox was offline again, no websites. I disabled all my 3 addons just to make sure and when I restarted it wasn’t fixed.
Please advise!

So currently you are on 3.7.8 and Firefox is still not working, is that right? Verify by opening up the settings, then navigate to “About”:
image
If you are on 3.7.8: Is the Problem only related to Firefox? Can you connect to Websites with Chrome?

In every case, can you please supply us with a Diagnostic by opening up a Terminal and running

eos-diagnostics

Then upload the file which gets generated in your Home Directory here to this thread.

Interesting case that only Firefox can’t access the outside world. We have to determine the reason for this:

Can you please post the output of the following command:

flatpak info --show-permissions org.mozilla.firefox

This will show the permissions granted to Firefox, which should include the permission to access the network and should look approximately like:

[Context]
shared=network;ipc;
sockets=x11;pulseaudio;pcsc;
devices=all;
filesystems=xdg-download;
persistent=.mozilla;

[Session Bus Policy]
org.gnome.SessionManager=talk
org.freedesktop.Notifications=talk
org.gtk.vfs.*=talk
org.freedesktop.ScreenSaver=talk
org.mpris.MediaPlayer2.org.mozilla.firefox=talk
org.a11y.Bus=talk
org.freedesktop.FileManager1=talk

[System Bus Policy]
org.freedesktop.NetworkManager=talk

If that looks the same on your side, can you please run:

flatpak run --command=curl org.mozilla.firefox -I www.google.at

This will run the curl network utility inside the Firefox Sandbox and print the status of the retrieval. If this works without an error, we now know the the problem is not Flatpak related, but has something to do with the Firefox application.

HTTP/1.1 200 OK
Content-Type: text/html; charset=ISO-8859-1
P3P: CP=“This is not a P3P policy! See g.co/p3phelp for more info.”
Date: Wed, 06 May 2020 08:27:32 GMT
Server: gws
X-XSS-Protection: 0
X-Frame-Options: SAMEORIGIN
Transfer-Encoding: chunked
Expires: Wed, 06 May 2020 08:27:32 GMT
Cache-Control: private
Set-Cookie: 1P_JAR=2020-05-06-08; expires=Fri, 05-Jun-2020 08:27:32 GMT; path=/; domain=.google.at; Secure
Set-Cookie: NID=203=PGyHPZzUhJegEWe49KaEl9SqDA15nWq1opG3uidjKzblwqGcytmUuFP_wwslCtASHTfZ9ltJCZaI0eYhTIoMEEvJOoonUpRSQPU4LvYBa2i8vsfA7LNvAmpPLO12GG-tiLnOLJgDCgztnvHV-g9j1bZ73AXwSPhhBDwWb3fAZss; expires=Thu, 05-Nov-2020 08:27:32 GMT; path=/; domain=.google.at; HttpOnly

OK, now we know that your system has no network problems and also the sandbox for Firefox is correctly configured - i assume the problem within Firefox. Can you please completely wipe your Firefox configuration by running:

rm -Rf ~/.var/app/org.mozilla.firefox

And then re-run Firefox. If the problem still persists, take a look at the settings to verify that you are using no proxy:

2 posts were merged into an existing topic: Wi-Fi not working after upgrade to 3.8.0

Settings are at no proxy, wiped out Firefox configuration. The problem persists as soon as I reboot. I had to rollback back and forth again to get Firefox online. I don’t understand why it works with 3.7.8 and not with 3.8, for just one session to that. Please advise!

If it works with 3.7.8 i recommend you to stay there until 3.8.1 has been officially released (with the Hope that it has been fixed there). To permanently roll back to 3.7.8, open a Terminal and type:

eos-rollback

It’s confusing but for a while there were two copies of Firefox in the app center, one provided by Endless (but using Mozilla’s official release) with ID org.mozilla.Firefox, and one provided by Mozilla directly with ID org.mozilla.firefox. (Note F vs f.) I have just unpublished org.mozilla.Firefox from the app center. (Users on that will not be migrated over to the Mozilla one automatically just now, but I hope this will be ready for the June release of the OS.)

Based on the information provided here it seems you are using the Mozilla-provided version (lower-case f). We would be able to confirm this from the output of eos-diagnostics.

It seems there are three distinct cases:

  1. In 3.8.0, Firefox can never connect to the network. Other applications, including Chrome, can connect, and curl when run in the Firefox sandbox can connect.
  2. In 3.7.8, the first time you boot, Firefox works.
  3. After you reboot into 3.7.8 again, Firefox stops working again.

Very weird, indeed. It would be useful to have the output of eos-diagnostics 3 times, once after reproducing each of these three cases (assuming I have understood correctly).

Is there anything interesting in the pages shown if you browse to about:networking in Firefox in the case where it is not working?

Finally, what is the exact error message Firefox gives you when it fails to connect to (for example) google.com? Please could you take a screenshot?

Hi!
@egrath I am at eos 3.7.8 now. And I am afraid t turn off, as it means firefox will be disconnected again. It reconnects after the first rollback to 3.7.8, but after reboot it goes offline again.
@wjt I will post diagnostics for each case by the end of the day.

Just did a side by side comparison of the two 3.7.8 logs with Meld, but there’s nothing in which leads me to the cause of your issue. What was the reason that you made your system read-write, are there any further steps you tried to nail down the problem?

I didn’t make my system read-write. Please explain. I am going step by step through Firefox forums and trying different solutions. But I can’t find how to flush dns.

Hi,
the following message appears in the log:

*************************************************************
*                        WARNING                            *
* eos-dev-fix or eos-convert-system was run on the system!! *
*************************************************************

This means that the system has been converted to read-write, which is normally only intended for EOS’s developers or under very special circumstances.

This started appearing in my diagnostics files since I began rolling back and forth from 3.8 to 3.7.8. I didn’t do anything intentionally.

OK, lets dig deeper.

Open a Terminal and type:

flatpak run --command=sh org.mozilla.firefox

Once inside the Flatpak sandbox for Firefox, run:

export NSPR_LOG_MODULES="nsHttp:2,cooke:2,timestamp,sync"
firefox 2>&1 | tee -a ~/Downloads/firefox-log.txt

Now Firefox will open up, and produces a huge amount of logging information which is stored in a file under ~/Downloads/firefox-log.txt. Try to open some site, then close Firefox and upload the resulting log here.

firefox-log.txt (626.9 KB)

Can you please open about:config in Firefox, then set the value of

network.dns.disableIPv6=true

… and try again. Do you have any Addons installed?

Done that the very first day. Didn’t help. I have three: an ad blocker, duckduckgo and a password manager.
But I just figured out that after reboot, the other “safety” browser I just downloaded, Epiphany, aka Web Gnome, also shows the same error. As if that is not enough, Wire Desktop gave me this error message:


EDIT: Chromium works though.

Any solution, please?

I feel forsaken. Please advise!