Just flashed EOS 4.0.4 on Raspberry pi 4 goes straight to emergency mode

Hello everyone, I was really hoping to have my kids use endlessos on our raspberry pi 4B.

  • I have downloaded the basic image from the site (4.0.4) and flashed it on a 16gb micro sd card.
  • I have inserted the sd card into my pi4 and after a short while an endless os background with a logo on it appeared on the screen.
  • After a minute or so that screen disappears and the system goes into emergency mode.
  • I’ve tried also connecting a keyboard to actually go into this emergency mode and see what the logs were but the keyboard doesn’t work at all.

Is there anything I could try before giving up?


That’s tricky to diagnose. I don’t suppose you have a UART console kit handy? The boot logs may be presented there or if not it should be easy to set that up.

Hey Daniel, thanks a lot for your reply!
I don’t currently have a UART console kit at the moment.

I’ve tried using the keyboard just before endlessos has been booted and I can use it just fine.
After booting and seeing the screen with the logo the keyboard doesn’t work anymore.

I can enter the u-bootloader command line before the os boots. Can I maybe use it to start the operating system with some kind of options?

Does the operating system save any logs on disk? I could access them by opening the SD on my computer.

Thanks again for your help!

The failure you’re describing sounds like the OS can’t find the disk - so unfortunately there wouldn’t be any logs saved there. Most likely UART console is the only practical way to debug. If you have the latest EEPROM firmware you could try booting from USB instead - but I’m not sure if anyone has tested this, and the keyboard issue may also prevent USB from working.

We do have a similar sounding issue booting Raspberry Pi 400 and I have learned that this issue could extend to some regular RPi4s that have the latest SoC revision. So there’s a decent likelihood that you are facing this known issue that we haven’t yet resolved.

Thanks a lot for the explanation, Daniel.

So even if I see the endlessos logo it might mean it is not recognizing the partition where to install the operating system?

I am a software developer. If I wanted to solve this problem where should I look in the source code?

Yes. u-boot accesses the SD card, loads the next stage of booting (Linux & the Endless initramfs) into RAM, and executes it. The Endless logo appears on-screen.

The emergency mode failure at this point usually indicates that Linux cannot access the main filesystem for some reason.

Many components are involved in the bootup process, to know where to look in the source code we really need to understand the failure first, and I think UART console is the most realistic way forward there.

However, if I am to guess, you are seeing the same issue that prevents us booting on Raspberry Pi 400. We have not tested yet, but this could likely be fixed by either one of the following u-boot code changes.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.