No sound device but sound is working


#1

If I go to setting then sound, I have no sound device installed for either input or output. If I open Audacity I cannot select an output device because there aren’t any.
But I can play mp3 files without a problem, and I can also play Youtube videos and hear the sound when using Google Chrome.
I’ve attached the diagnostic file. Can anyone help please? I need to be able to use Audacity and other sound recording / playing software.
eos-diagnostic-181117_190508_UTC 0100.txt (1.1 MB)


#2

I ran aplay - l (as suggested in another thread) and this was the result:

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: VT1708S Analog [VT1708S Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 2: VT1708S Alt Analog [VT1708S Alt Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0


#3

I’ve plugged in a USB soundcard but that didn’t work either. I also plugged in a small mixing desk which has its own USB sound device but that doesn’t show up either.
All these worked with Linux Mint which was on the computer immediately before Endless.


#4

Thanks for the report. For some reason the audio management service is crashing.

Nov 17 18:01:21 endless kernel: pulseaudio[1101]: segfault at 8 ip 00007fd81b07cd6b sp 00007fff15851200 error 4 in module-alsa-card.so[7fd81b079000+7000]
Nov 17 18:01:21 endless kernel: Code: 28 00 00 00 0f 85 05 02 00 00 48 83 c4 18 5b 5d 41 5c 41 5d c3 66 2e 0f 1f 84 00 00 00 00 00 48 8b 5e 08 48 8b 45 48 48 85 db <48> 8b 40 08 0f 84 fb 00 00 00 48 85 c0 0f 84 f2 00 00 00 48 89 c6 
Nov 17 18:01:22 endless systemd[617]: pulseaudio.service: Main process exited, code=dumped, status=11/SEGV
Nov 17 18:01:22 endless systemd[617]: pulseaudio.service: Failed with result 'core-dump'.

@jprvita any suggestions?


#5

I have tried running Endless from the USB stick I used to install it on this computer and have the same issue, i.e. no sound devices.


#6

I re-downloaded Endless 3.5.1 and created a new USB stick. I used this new stick to boot up my work computer (different components and spec to my home one) and this shows no audio devices too, although the audio works fine when I boot up from the hard disk which is Linux Mint.
So…
2 different computers
2 different USB sticks
2 different downloads
1 operating system

Is there anywhere I could download an older version of Endless to try?


#7

Any ideas on this folks?


#8

@Daniel Could Help? :endless:


#9

Ok, I’ve created a USB stick with Endless 3.4.8 and booted up my work PC with it. With this version I have a sound device, a volume slider and all music/sound functions work. So it appears the problem is with the later versions of Endless.
Over to you, Endless - I can’t do any more to troubleshoot this, but I am happy to provide any further information that I can to help you solve the problem.

@Daniel @jprvita @wjt


#10

Try doing the following on your 3.5.1 installation:

  • Open a Terminal window
  • Run sudo eos-enable-coredumps
  • Restart the computer, log in, and reproduce the problem
  • Run coredumpctl – I expect you will see at least one entry with /usr/bin/pulseaudio in the EXE column
  • Run sudo coredumpctl -o pulseaudio.coredump dump /usr/bin/pulseaudio. This should show some information about the crash in your terminal window, and also create a file named pulseaudio.coredump.
  • Send us pulseaudio.coredump, somehow. It will probably be too large to attach to this forum.

#11

You can access the file here:


#12

Thanks. We also found a PC in our lab that seems to hit the same problem. Investigating…


#13

It’s good to know that it isn’t just me.
I hope you can solve the issue soon as I’d like to update my machines to the latest version.


#14

Hey I am glad I found this thread. Was trying to troubleshoot but to no avail. I have Endless loaded on my Dell Lat E6520 with 8GB Ram, i7, 500GB drive. No Output Devices listed but I can hear audio. It does not allow configuration. I installed a bluetooth dongle to use an external speaker. The bluetooth speaker shows up but it will not me to toggle to the ON switch or configure it in anyway. I did have linuxmint 19 installed previously and everything worked.


#15

Sorry for the delay here!

We believe we have fixed this issue for Endless version 3.5.2, which should be available in 1-2 weeks.

If you would like to test it sooner, I have published a 3.5.2-beta1 release, you can get it via the beta program:


#16

I’ll wait for the official release I think. Any idea when that will be available?


#17

Endless 3.5.2 is available now as a software update for existing installs.
Full image downloads & release notes will come soon.


#18

I’ve updated my work computer to 3.5.2 and the sound is now working correctly. I’ll update my home PC over the weekend and let you know what happens.


closed #19