No updates available for Endless OS 3.3.20

eos-diagnostic-200117_131010_UTC 0100.txt (301.7 KB)
Hello,

I am unable to update Endless version 3.3.20.
After clicking on “Check for updates now” I get the response “No updates available”.

I have tried the following solution:
sudo bash
systemctl stop eos-updater
ostree admin set-origin eos https://ostree.endlessm.com/ostree/eos-amd64 os/eos/amd64/eos3a
systemctl start eos-updater
eos-updater-ctl update

with the following result:
katalin@endless:~$ sudo bash
root@endless:~# systemctl stop eos-updater
root@endless:~# ostree admin set-origin eos https://ostree.endlessm.com/ostree/eos-amd64 os/eos/amd64/eos3a
root@endless:~# systemctl start eos-updater
root@endless:~# eos-updater-ctl update
Changed state to Polling
Changed state to Ready
======= Properties =======
State: Polling
CurrentID: ‘23aa6887296044293d9f507d1dffee46c7f90c15b3d7266d52dbc4da9e50dc25’
DownloadSize: int64 0
DownloadedBytes: int64 0
ErrorCode: uint32 0
ErrorMessage: ‘’
ErrorName: ‘’
FullDownloadSize: int64 0
FullUnpackedSize: int64 0
OriginalRefspec: ‘’
UnpackedSize: int64 0
UpdateID: ‘’
UpdateLabel: ‘’
UpdateMessage: ‘’
UpdateRefspec: ‘’

Traceback (most recent call last):
File “/usr/bin/eos-updater-ctl”, line 355, in
main()
File “/usr/bin/eos-updater-ctl”, line 351, in main
sys.exit(args.function(**args_dict))
File “/usr/bin/eos-updater-ctl”, line 186, in command_update
fetch_result = command_fetch(block=True, quiet=quiet)
File “/usr/bin/eos-updater-ctl”, line 173, in command_fetch
return command_dbus(‘fetch’, block, quiet)
File “/usr/bin/eos-updater-ctl”, line 145, in command_dbus
proxy.call_sync(‘com.endlessm.Updater.’ + function_name, None, 0, -1, None)
GLib.Error: g-io-error-quark: GDBus.Error:com.endlessm.Updater.Error.WrongState: Can’t call Fetch() while in state Ready (36)
root@endless:~#

I would really appreciate any help I could get.

  1. Open the application called ‘Terminal’
  2. Copy and paste this command into the Terminal application:
flatpak update --appstream && flatpak update -y
eos-updater-ctl update
  1. Wait for a notification saying that it is to restart the computer and Click to restart the computer

Hi,

Can you try the following commands:

sudo bash
systemctl stop eos-updater
ostree admin set-origin eos https://ostree.endlessm.com/ostree/eos-amd64 os/eos/amd64/eos3
systemctl start eos-updater
eos-updater-ctl update

The difference between that and what you’ve already tried is the eos3 rather than eos3a

Thank you very much for the quick reply and for your help!

Thank you very much for your reply! I will keep this solution in mind as well, might come in handy the next time I have troubles.

Note that these steps are only applicable if you’re on 3.3.x, not after you’re on 3.4.x or later.

Thank you for bringing that to my attention!