Printer and terminal

I have bought a new Acer with Endless os.
I have installed printer drivers for Brother DCPL2510D
Driver OK but printer does not print
I have followed instructions to get diagnostics from Terminal.
Terminal does not allow typing (read only IS disabled)
So simple but very effective.
No reply.
Dead end.
Please help!!!

I’ve never heard of you not being able to type into the Terminal before. Is the same true if you create a new user account?

Anyway, unfortunately I don’t think its going to help much in this case. Unfortunately printer support on Linux & Endless has been a tricky topic over the years. At this point we are focusing our Endless OS printer support around printers that are compatible with smartphones (i.e. ones that support driverless printing) and as far as I can see from a quick google search, your printer is not one of those :frowning:

or maybe it does support IPP over the network…
Have you tried network printing or only USB?

From what i’ve checked in the Manual, the Printer supports IPP and uses PCL6 as it’s printing language, so yes, if you connect the device using the Network, printing should work with the generic driver:


Can you please try to connect it using Network - there should be a Ethernet port on the device which can connect to the corresponding port on your router.

Thank you for the support.
No Ethernet port is available on this printer.

OK, then no network connection :slight_smile:

According to, one must perform special steps to make this model compatible with Linux. As these instructions are for Ubuntu, we need to adopt them for EOS.

  1. Remove the Printer in Settings
  2. Now, run the following commands in Terminal:
wget -O - | dpkg --extract - ~/brother
bash ~/brother/opt/brother/legacyusb/ -c
  1. Disconnect your Printer physically and restart your computer
  2. Reconnect the Printer and add them again
  3. Should work now (hopefully)

Thank you.
I cannot type in Terminal. Does not accept typing. Read only is NOT checked.
Please check the screenshot below.
Uploading:Screenshot from 2021-05-12 12-04-12.png…

OK, let’s try to solve the Keyboard issue first. Can you please press Alt-F2 and enter eos-diagnostics


Then, upload the generated file here in this Thread. Eventually there’s some indication in there why you can’t type anything in the Terminal.


  1. Keyboard works without Issues in other Applications i assume?
  2. Can you please try to disable high contrast mode.
  3. Can you please try to enable the On-Screen Keyboard and check if you can type with it in Terminal.

eos-diagnostic-210512_185959_UTC 0300.txt (1.0 MB)
High contrast was the issue.

Thank you.
I did run the commands.
Still no print.
Here is new diagnostics after the commands.
eos-diagnostic-210512_193527_UTC 0300.txt (1.3 MB)

Did the command produced any output?

hyperlink ok

2nd command

Please run the second command too :slight_smile:

bash ~/brother/opt/brother/legacyusb/ -c

2nd command