Release | Endless OS 3.3.20

Endless OS 3.3.20 was released for existing users today (January 14th, 2020).

Updates from 3.3.x to latest stable should now work again

A few issues have prevented some users on Endless OS 3.3.x from upgrading to the latest stable release (currently 3.7.6). This release fixes two of the known issues:

  1. The installation of LibreOffice from Flathub fails. When users update from 3.3 to 3.7, the LibreOffice app is installed as a Flatpak (whereas previously it was part of the base operating system). This process has not worked for the last few months, meaning no users could update past 3.3.19.
  2. Some users who have apps installed which use old Flatpak runtimes could not update from 3.3.19 due to a bug in a script that runs during the boot process. If you’re affected by this issue, the log will have the following message from eos-updater: “Fetch: failed to pull necessary new flatpaks for update: Remote “gnome” not found”.

If your computer is running Endless OS 3.3.19 or earlier, you can now update by going to the Details pane in the Settings app and clicking the “Check for updates now” link in the bottom right corner. After the update is applied, you will get a notification that a reboot is required. After rebooting, you will need to update again from 3.3.20 to the latest release – 3.7.6 at the time of writing – using the same process.

If you are still not able to update to 3.7.6, please collect debugging information by following these instructions and post on the community forum.

This release of Endless OS does not affect users who are already on any release later than 3.3.19.

Known Issues

  • Some computers may not successfully update from 3.3.20 to the latest stable release due to not having enough available disk space. This issue especially affects 32 GB Endless Mini computers. You can check the available disk space using the Disks app. On an Endless Mini, ensure you’ve selected the partition which says “Mounted at /var/endless-extra” from the list on the left:

    If it has less than about 6 GB free, uninstall a few larger apps using the App Center and try updating again. After updating successfully, you can re-install some or all of those apps: the update process requires more disk space while it’s happening than after it is applied.

3 Likes