Update fail. Use Endless OS 3.3.19

Hi. I still have the same problem. i stuck on version 3.3.19. i have tried all the methods mentioned above but nothing help me.
is there any solution?

Can you please:
1.) Open a Terminal and enter journalctl -f -u eos-updater
2.) Open another Terminal and enter eos-updater-ctl update
3.) Paste the output from (1) here

admin@endless:~$ journalctl -f -u eos-updater
– Logs begin at Sun 2019-06-09 15:17:49 EEST. –
Июн 09 15:17:54 endless systemd[1]: Starting Endless OS Updater…
Июн 09 15:17:54 endless eos-updater[909]: Acquired a message bus connection
Июн 09 15:17:54 endless eos-updater[909]: Changing to state Ready
Июн 09 15:17:54 endless eos-updater[909]: Exporting objects
Июн 09 15:17:54 endless eos-updater[909]: Acquired the name com.endlessm.Updater
Июн 09 15:17:54 endless systemd[1]: Started Endless OS Updater.
Июн 09 15:25:49 endless eos-updater[909]: Changing to state Polling
Июн 09 15:25:49 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:50 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/70/83275ee04acaf9f19fc070df8132861acb8171d18e2587efbfc06bca7f5ef7.sizes2: Server returned status 404: Not Found
Июн 09 15:25:50 endless eos-updater[909]: libostree pull from ‘eos’ for os/eos/amd64/eos3 complete
security: GPG: commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 1.7 kB
Июн 09 15:25:50 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:50 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:50 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/bd/139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3.sizes2: Server returned status 404: Not Found
Июн 09 15:25:51 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/bd/139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3.sig: Server returned status 404: Not Found
Июн 09 15:25:51 endless eos-updater[909]: libostree pull from ‘eos’ for os/eos/amd64/eos3a complete
security: GPG: commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 569 bytes
Июн 09 15:25:51 endless eos-updater[909]: Error polling for updates using libostree P2P code; falling back to old code: No collection ID set for currently booted deployment.
Июн 09 15:25:51 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:51 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/70/83275ee04acaf9f19fc070df8132861acb8171d18e2587efbfc06bca7f5ef7.sizes2: Server returned status 404: Not Found
Июн 09 15:25:51 endless eos-updater[909]: libostree pull from ‘eos’ for os/eos/amd64/eos3 complete
security: GPG: commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 1.7 kB
Июн 09 15:25:51 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:51 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:51 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/bd/139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3.sizes2: Server returned status 404: Not Found
Июн 09 15:25:51 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/bd/139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3.sig: Server returned status 404: Not Found
Июн 09 15:25:51 endless eos-updater[909]: libostree pull from ‘eos’ for os/eos/amd64/eos3a complete
security: GPG: commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 569 bytes
Июн 09 15:25:51 endless eos-updater[909]: Using product branch os/eos/amd64/eos3
Июн 09 15:25:51 endless eos-updater[909]: Recording metric event 99f48aac-b5a0-426d-95f4-18af7d081c4e: (Acer, Swift SF314-52, os/eos/amd64/eos3a)
Июн 09 15:25:51 endless eos-updater[909]: Changing to state UpdateAvailable
Июн 09 15:25:54 endless eos-updater[909]: Changing to state Fetching
Июн 09 15:25:54 endless eos-updater[909]: Fetch: using old code due to lack of repo finder results
Июн 09 15:25:54 endless eos-updater[909]: Fetch: eos:os/eos/amd64/eos3a resolved to: bd139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3
Июн 09 15:25:54 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/bd/139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3.sizes2: Server returned status 404: Not Found
Июн 09 15:25:54 endless eos-updater[909]: libostree HTTP error from remote eos for https://ostree.endlessm.com/ostree/eos-amd64/objects/bd/139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3.sig: Server returned status 404: Not Found
Июн 09 15:25:54 endless eos-updater[909]: libostree pull from ‘eos’ for 0 refs complete
security: GPG: commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 569 bytes
Июн 09 15:25:54 endless eos-updater[909]: Fetch: pull() completed
Июн 09 15:25:54 endless eos-updater[909]: Fetch: commit bd139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3 cached
Июн 09 15:25:54 endless eos-updater[909]: Fetch: finished pulling using old code
Июн 09 15:25:54 endless eos-updater[909]: Fetch: pulling any necessary new flatpaks for this update
Июн 09 15:25:54 endless eos-updater[909]: 50-default.json:
Июн 09 15:25:54 endless eos-updater[909]: All flatpak ref actions that this commit wants to have applied on deployment:
- install (collection-id: com.endlessm.Apps|remote: eos-apps):app/com.endlessm.CompanionAppService/x86_64/eos3
- install (collection-id: com.endlessm.Sdk|remote: eos-sdk):runtime/org.freedesktop.Platform.Icontheme.EndlessOS/x86_64/1.0
- install (collection-id: org.flathub.Stable|remote: flathub):app/org.libreoffice.LibreOffice/x86_64/stable
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.CompanionAppService/x86_64/eos3
- install (collection-id: com.endlessm.Sdk|remote: eos-sdk):app/com.endlessm.CompanionAppService/x86_64/stable
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.EknServices/x86_64/eos3
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.EknServices2/x86_64/stable
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.EknServices3/x86_64/stable
- install (collection-id: com.endlessm.Sdk|remote: eos-sdk):app/com.endlessm.EknServicesMultiplexer/x86_64/stable
Июн 09 15:25:54 endless eos-updater[909]: Action application progresses:
(None)
Июн 09 15:25:54 endless eos-updater[909]: 50-default.json:
Июн 09 15:25:54 endless eos-updater[909]: Flatpak ref actions that need to be prepared while fetching this commit:
- install (collection-id: com.endlessm.Sdk|remote: eos-sdk):runtime/org.freedesktop.Platform.Icontheme.EndlessOS/x86_64/1.0
- install (collection-id: org.flathub.Stable|remote: flathub):app/org.libreoffice.LibreOffice/x86_64/stable
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.CompanionAppService/x86_64/eos3
- install (collection-id: com.endlessm.Sdk|remote: eos-sdk):app/com.endlessm.CompanionAppService/x86_64/stable
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.EknServices/x86_64/eos3
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.EknServices2/x86_64/stable
- uninstall (collection-id: (null)|remote: none):app/com.endlessm.EknServices3/x86_64/stable
- install (collection-id: com.endlessm.Sdk|remote: eos-sdk):app/com.endlessm.EknServicesMultiplexer/x86_64/stable
Июн 09 15:25:56 endless eos-updater[909]: Remote none did not have a summary cache or app/com.endlessm.CompanionAppService/x86_64/eos3 was not found in it, assuming that app/com.endlessm.CompanionAppService/x86_64/eos3 does not have a runtime
Июн 09 15:25:56 endless eos-updater[909]: Remote none did not have a summary cache or app/com.endlessm.EknServices/x86_64/eos3 was not found in it, assuming that app/com.endlessm.EknServices/x86_64/eos3 does not have a runtime
Июн 09 15:25:56 endless eos-updater[909]: Remote none did not have a summary cache or app/com.endlessm.EknServices2/x86_64/stable was not found in it, assuming that app/com.endlessm.EknServices2/x86_64/stable does not have a runtime
Июн 09 15:25:56 endless eos-updater[909]: Remote none did not have a summary cache or app/com.endlessm.EknServices3/x86_64/stable was not found in it, assuming that app/com.endlessm.EknServices3/x86_64/stable does not have a runtime
Июн 09 15:25:56 endless eos-updater[909]: Looking up flatpak remote name for collection ID com.endlessm.Sdk
Июн 09 15:25:56 endless eos-updater[909]: Failed to find a remote name for collection ID com.endlessm.Sdk: Could not find remote with collection ID ‘com.endlessm.Sdk’
Июн 09 15:25:56 endless eos-updater[909]: Looking up flatpak remote name for collection ID org.flathub.Stable
Июн 09 15:25:56 endless eos-updater[909]: Failed to find a remote name for collection ID org.flathub.Stable: Could not find remote with collection ID ‘org.flathub.Stable’
Июн 09 15:25:57 endless eos-updater[909]: libostree HTTP error from remote eos-sdk for https://ostree.endlessm.com/ostree/eos-sdk/objects/bd/9e6224cee41ae096e736e919009ce5dd6304676265d27b49d6274d5dd76834.sizes2: Server returned status 404: Not Found
Июн 09 15:25:58 endless eos-updater[909]: libostree HTTP error from remote eos-sdk for https://ostree.endlessm.com/ostree/eos-sdk/objects/bd/9e6224cee41ae096e736e919009ce5dd6304676265d27b49d6274d5dd76834.sig: Server returned status 404: Not Found
Июн 09 15:25:58 endless eos-updater[909]: libostree pull from ‘eos-sdk’ for runtime/org.freedesktop.Platform.Icontheme.EndlessOS/x86_64/1.0 complete
security: GPG: summary+commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 1 size: 568 bytes
Июн 09 15:25:58 endless eos-updater[909]: libostree HTTP error from remote eos-sdk for https://ostree.endlessm.com/ostree/eos-sdk/objects/bd/9e6224cee41ae096e736e919009ce5dd6304676265d27b49d6274d5dd76834.sizes2: Server returned status 404: Not Found
Июн 09 15:25:58 endless eos-updater[909]: libostree HTTP error from remote eos-sdk for https://ostree.endlessm.com/ostree/eos-sdk/objects/bd/9e6224cee41ae096e736e919009ce5dd6304676265d27b49d6274d5dd76834.sig: Server returned status 404: Not Found
Июн 09 15:25:58 endless eos-updater[909]: libostree pull from ‘eos-sdk’ for runtime/org.freedesktop.Platform.Icontheme.EndlessOS/x86_64/1.0 complete
security: GPG: summary+commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 568 bytes
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.html5-codecs/x86_64/18.08 already installed, updating to most recent version instead
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.html5-codecs/x86_64/18.08 has no updates either, nothing to do
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.Locale/x86_64/18.08 already installed, updating to most recent version instead
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.Locale/x86_64/18.08 has no updates either, nothing to do
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/18.08 already installed, updating to most recent version instead
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/18.08 has no updates either, nothing to do
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform/x86_64/18.08 already installed, updating to most recent version instead
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform/x86_64/18.08 has no updates either, nothing to do
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.libreoffice.LibreOffice.Locale/x86_64/stable already installed, updating to most recent version instead
Июн 09 15:25:58 endless eos-updater[909]: flathub:runtime/org.libreoffice.LibreOffice.Locale/x86_64/stable has no updates either, nothing to do
Июн 09 15:25:59 endless eos-updater[909]: libostree HTTP error from remote flathub for https://dl.flathub.org/repo/objects/e7/871dca5a2cb83475ba20c6b357b5b2d94b1e66760d7be2eb0e42fe13f15b7c.sizes2: Server returned status 404: Not Found
Июн 09 15:25:59 endless eos-updater[909]: libostree HTTP error from remote flathub for https://dl.flathub.org/repo/objects/e7/871dca5a2cb83475ba20c6b357b5b2d94b1e66760d7be2eb0e42fe13f15b7c.sig: Server returned status 404: Not Found
Июн 09 15:25:59 endless eos-updater[909]: libostree pull from ‘flathub’ for app/org.libreoffice.LibreOffice/x86_64/stable complete
security: GPG: summary+commit http: TLS
non-delta: meta: 3 content: 0
transfer: secs: 0 size: 569 bytes
Июн 09 15:26:00 endless eos-updater[909]: flathub:runtime/org.gnome.Platform.Locale/x86_64/3.28 already installed, updating to most recent version instead
Июн 09 15:26:00 endless eos-updater[909]: flathub:runtime/org.gnome.Platform.Locale/x86_64/3.28 has no updates either, nothing to do
Июн 09 15:26:00 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/1.6 already installed, updating to most recent version instead
Июн 09 15:26:00 endless eos-updater[909]: flathub:runtime/org.freedesktop.Platform.VAAPI.Intel/x86_64/1.6 has no updates either, nothing to do
Июн 09 15:26:00 endless eos-updater[909]: eos-sdk:runtime/com.endlessm.CompanionAppService.Locale/x86_64/stable already installed, updating to most recent version instead
Июн 09 15:26:00 endless eos-updater[909]: eos-sdk:runtime/com.endlessm.CompanionAppService.Locale/x86_64/stable has no updates either, nothing to do
Июн 09 15:26:00 endless eos-updater[909]: flathub:runtime/org.gnome.Platform/x86_64/3.28 already installed, updating to most recent version instead
Июн 09 15:26:00 endless eos-updater[909]: Fetch: failed to pull necessary new flatpaks for update: Remote “gnome” not found
Июн 09 15:26:00 endless eos-updater[909]: Changing to error state: org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code1, 1, Remote “gnome” not found

Please try:

sudo bash
systemctl stop eos-updater
ostree admin set-origin eos https://ostree.endlessm.com/ostree/eos-amd64  os/eos/amd64/eos3a
systemctl start eos-updater
eos-updater-ctl update

This should ensure that your system looks at the correct location for updates and will push you to the current version - 3.5.9 at the moment, 3.6.0 soon.

admin@endless:~$ sudo bash
root@endless:~# systemctl stop eos-updater
root@endless:~# ostree admin set-origin eos https://ostree.endlessm.com/ostree/eos-amd64 os/eos/amd64/eos3a
root@endless:~# systemctl start eos-updater
root@endless:~# eos-updater-ctl update
Changed state to Polling
Changed state to UpdateAvailable
======= Properties =======
State: Polling
CurrentID: ‘7083275ee04acaf9f19fc070df8132861acb8171d18e2587efbfc06bca7f5ef7’
DownloadSize: int64 0
DownloadedBytes: int64 0
ErrorCode: uint32 0
ErrorMessage: ‘’
ErrorName: ‘’
FullDownloadSize: int64 0
FullUnpackedSize: int64 0
OriginalRefspec: ‘’
UnpackedSize: int64 0
UpdateID: ‘’
UpdateLabel: ‘’
UpdateMessage: ‘’
UpdateRefspec: ‘’

Changed state to Fetching
Changed state to Error
======= Properties =======
State: Fetching
CurrentID: ‘7083275ee04acaf9f19fc070df8132861acb8171d18e2587efbfc06bca7f5ef7’
DownloadSize: int64 0
DownloadedBytes: int64 569
ErrorCode: uint32 0
ErrorMessage: ‘’
ErrorName: ‘’
FullDownloadSize: int64 1433835620
FullUnpackedSize: int64 3413080197
OriginalRefspec: ‘eos:os/eos/amd64/eos3a’
UnpackedSize: int64 0
UpdateID: ‘bd139ca00437571f92aa35126da9e1cad352dd45e24b8c7b58991b09bee936b3’
UpdateLabel: ‘190511-135626’
UpdateMessage: ‘Built with eos-ostree-builder Release_3.5.8’
UpdateRefspec: ‘eos:os/eos/amd64/eos3a’

Traceback (most recent call last):
File “/usr/bin/eos-updater-ctl”, line 355, in
main()
File “/usr/bin/eos-updater-ctl”, line 351, in main
sys.exit(args.function(**args_dict))
File “/usr/bin/eos-updater-ctl”, line 190, in command_update
apply_result = command_apply(block=True, quiet=quiet)
File “/usr/bin/eos-updater-ctl”, line 177, in command_apply
return command_dbus(‘apply’, block, quiet)
File “/usr/bin/eos-updater-ctl”, line 145, in command_dbus
proxy.call_sync(‘com.endlessm.Updater.’ + function_name, None, 0, -1, None)
GLib.Error: g-io-error-quark: GDBus.Error:com.endlessm.Updater.Error.WrongState: Can’t call Apply() while in state Error (36)

i have tried and nothing changed.
the result is in the previous message.

Please can you provide the output of running the script I provided?

rm -f eos-update-flatpak-repos
https://raw.githubusercontent.com/endlessm/eos-boot-helper/eos3.3/eos-update-flatpak-repos
chmod +x eos-update-flatpak-repos
sudo ./eos-update-flatpak-repos

I know you ran this before, but without knowing what the output was, it’s not really possible to help further. On this thread it did the trick for someone with (what seemed to be) exactly the same problem with the missing gnome remote.

i don’t know how but my os is updated to 3.6.0.
maybe because of i have changed the region and language from Ukraine to other countries.

I also cant update endless os 3.3.19 can someone help me please
file:///sysroot/home/aldijana/eos-diagnostic-190905_232524_UTC+0200.txt

Hi. Pls help to check mine. Thanks

eos-diagnostic-191114_155128_UTC 0800.txt (822.9 KB)

Thanks for the report and apologies for the problems here.

For reference, the error in your case is:

eos-updater[1296]: Changing to error state: org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code1, 1, Checking out tree: Couldn't find file object '89d3a18c2d5e90c5349dab5f559b652dce39b83b47c59d9105627e22ddebb3b3'
eos-autoupdater[9445]: EOS updater state is: Error
eos-autoupdater[9445]: EOS updater error (org.gtk.GDBus.UnmappedGError.Quark._g_2dio_2derror_2dquark.Code1): Checking out tree: Couldn't find file object '89d3a18c2d5e90c5349dab5f559b652dce39b83b47c59d9105627e22ddebb3b3'
systemd[1]: eos-autoupdater.service: Main process exited, code=exited, status=1/FAILURE

I’ll ask internally to see what the next steps are.

Thanks.

Appreciate your help.

Hi,

I’ve been facing the same problem. I managed to update to 3.3.19 by following other posts but I’m stuck here.

Appreciate any help,
Many thanks,

Eroleos-diagnostic-191119_002232_UTC 0000.txt (368.8 KB)

@xela_jean_cruz, you have likely hit a bug in an old version of Endless OS that we have since fixed, where some ostree objects could be lost.

Please open the 'Terminal’ application and run the command:

rm -f eos-fix-ostree-repo
wget https://raw.githubusercontent.com/endlessm/eos-meta/master/eos-tech-support/eos-fix-ostree-repo
chmod +x eos-fix-ostree-repo
sudo ./eos-fix-ostree-repo

The final command may ask for your user account password. Nothing will be shown as you type it in.

Finally reboot and try the update process again.

Hi @Mecka, thanks for reporting this and apologies for the trouble caused.

For reference the relevant errors here are:

eos-updater[1576]: Error occurred whilst pulling flatpak flathub:runtime/org.freedesktop.Platform.openh264/x86_64/19.08: While trying to apply extra data: apply_extra script failed, exit status 256
eos-updater[1576]: Fetch: failed to pull necessary new flatpaks for update: While trying to apply extra data: apply_extra script failed, exit status 256
eos-updater[1576]: Changing to error state: com.endlessm.Updater.Error.Fetching, 5, Error fetching update: While trying to apply extra data: apply_extra script failed, exit status 256

I’ll follow up internally and get back to you.

Hi @Mecka

We’re investigating the problem internally.

For now though, you can workaround the problem by opening Terminal and running the following commands.

rm -f eos-update-flatpak-repos
wget --quiet https://raw.githubusercontent.com/endlessm/eos-boot-helper/e510a0b4/eos-update-flatpak-repos
chmod +x eos-update-flatpak-repos
sudo ./eos-update-flatpak-repo
flatpak install flathub org.libreoffice.LibreOffice

Now try the OS update again and you should be advanced to EOS-3.7.

Hi Daniel,

Thanks. I ran those commands. Although sudo ./eos-update-flatpak-repo returned an error stating ‘unknown command’ I was able to do the update.
Now I’m at 3.7.4
Another 13 updates appeared in the App center and did those too (Although had to repeat 2-3 times as ‘Update all’ does not work all the time, conflicting priorities during updates??)

Anyway, now all ıs up-to-date and running OK.

Thanks again for your support.
I attached the most recent diagnostics file in case it helps to compare the status prior to the update.eos-diagnostic-191120_221431_UTC 0000.txt (1.3 MB)

Hi. I cant update endless os. Current version 3.3.19. When try to update, update fail.eos-diagnostic-191202_234653_UTC 0200.txt (336.7 КБ)

  1. Open the application called ‘Terminal’
  2. In this application run the command:
rm -f eos-update-flatpak-repos
wget --quiet https://raw.githubusercontent.com/endlessm/eos-boot-helper/e510a0b4/eos-update-flatpak-repos
chmod +x eos-update-flatpak-repos
sudo ./eos-update-flatpak-repos
flatpak install flathub org.libreoffice.LibreOffice -y
flatpak update --appstream && flatpak update -y
  1. Now try the operating system upgrade again and go to Endless OS 3.7.5

Hi,

Can you try again. Today 3.3.20 was released which should fix your problem: Release | Endless OS 3.3.20