Release | Endless OS 4.0.2

Endless OS 4.0.2 has been released as an over-the-air upgrade. The only notable change in this release is a fix for a regression in 4.0.1. There will be no new installation images since the regression only affected upgrades on existing systems, not new installations: 4.0.1 is fine for new installations.

Here’s the fix in question, taken from our wiki:

Web Safety internet connection issues

Computers with web safety enabled before upgrading to Endless OS 4.0.1 were no longer able to connect to the internet at all. This problem is resolved in this release.

If you are unable to go online after upgrading to Endless OS 4.0.1, open a Terminal window, type the following command, and press Enter :

pkexec eos-safe-defaults disable

Then restart your computer. If your problem is caused by this Web Safety bug, it should now be able to connect to the internet once again. Web Safety will be re-enabled when you update to Endless OS 4.0.2 or newer.

3 Likes

Comment faire la mise à jour vers Endless OS 4.0.2 ?

Use the App Center

Hi, I’m having trouble updating to 4.0.2. I tried doing it from the App Center, but it was bugged, so I tried updating through the terminal using this commmand I found in this post:

flatpak update --appstream && flatpak update -y
eos-updater-ctl update

But it didn’t work & this was the result:

Here’s my diagnostic file → eos-diagnostic-211225_134418_UTC-0500.txt (3.2 MB)

With 4.0.2 I’ve just seen behaviour that seems to resolve down to https://github.com/flatpak/flatpak/pull/4568 I resolved it with rm ~/.cache/flatpak/system-cache/summaries/* but that fix may be worth getting into a release.

after updating OS to Endless 4.0.2; Build ID: 211215-130341 the system uploading very slowly and apps runs slowlyeos-diagnostic-211230_132544_UTC 0300.txt (999.5 КБ)

Is your current network connection set as metered? Try:

eos-updater-ctl update --force

The diagnostic file shows the update beginning to be fetched.

1 Like

Thanks, I’ve opened a task

Your diagnostic file shows that eos-split-flatpak-repo is running in the background. This may be the cause. It will take some time but only needs to run once.