[solved] Running windows applications on eos flatpak error install


#1

hi, i have trid to install this

but i have this error:

Failed to install org.winepak.Platform.Extension.d3dx9: While trying to apply extra data: runtime/org.winepak.Platform/x86_64/3.0 not installed
domenico@endless:~$

thank you


#2

With current EOS (3.6.2), i personally no longer use the WinePak approach to run Windows applications. Instead i’ll use toolbox to run Fedora 29 inside a container. In this container (which has full access to your home directory), i install the latest Wine to run Windows applications. Works by far better than the outdated Winepak :slight_smile:


#3

@egrath, thank you!

it is work fine, only minor problem after logout: container not start
solved with:
sudo chown -R $USER ~/.local/share/containers/storage/overlay-containers

some usefull tricks:

Your first toolbox

Once toolbox is installed, two simple commands are required to get started:

$ toolbox create

This will download an OCI image and create a toolbox container from it. Once this is complete, run:

$ toolbox enter

Once inside the toolbox, you can access common command line tools, and install new ones using DNF.

When the prompt is inside a toolbox, it is prepended with a diamond: this indicates that the prompt is inside a toolbox container.

Commands and usage

toolbox create [--container <name>]

Creates a toolbox container. This will download an OCI image if one isn’t available (this is required to create the container). By default a Fedora image matching the version of the host is used. Used without options, toolbox create will automatically name the container it creates. To create additional toolboxes, use the --container <name> option.

toolbox enter [--container <name>]

Enters a toolbox for interactive use. Used without options, toolbox enter opens the default toolbox. If there is more than one toolbox, use the --container name option to specify the toolbox to enter.

toolbox list

Lists local toolbox images and containers. Note: it is typical to see two images listed, one with a localhost prefix and one with a registry.fedoraproject.org prefix. These are a normal result of the toolbox creation process.

toolbox rm [--force] <name>

Removes one or more toolbox containers. The --force option removes the container even if it is running.

toolbox rmi [--force] <name>

Removes one or more toolbox images.

toolbox --help

Lists available commands.

Exiting a toolbox

To return to the host environment, either run exit or quit the current shell (typically Ctrl+D).


#4

An additional convenience tip would be to create a .desktop file for your most often used windows applications:

  1. Create a new MyApplication.desktop file under ~/.local/share/applications (name it similar to the application you want to run)
  2. This file should contain something like (adopt to your specific environment):
[Desktop Entry]
Name=MyApplication
Type=Application
Icon=/sysroot/home/egon/tmp/M/MyApplication.png
Terminal=true
Exec=/usr/bin/toolbox run --container WindowsContainer wine /sysroot/home/egon/tmp/M/MyApplication.exe
  1. If you want to application to show up on the desktop, use eos-add-to-desktop MyApplication