"Something went wrong" message shown on 4.0.0

Hi, this is the file and, I want to say I’m having problems to work on my laptop. After the upgrade, all sistem work really good on the first day, but in the next day, I was really bad experience; not run, not show my sistem, or not working at all. I really need my laptop working good because I’m near to my graduation on university, if you can help I will give you all information that you need.–full-journall||.txt (1,2 MB)

I’ve looked at the diagnostic file you provided and there are many strange things happening but I can’t understand why.

Can you explain the sequence of events up to the point where you created this diagnostic file? It looks like what happens is:

  • You tried to start your computer, but after a long wait you got the error message photographed above
  • You powered off the computer and started it up again. This time, it started successfully, and you created the diagnostic file

Is that right?

Yes that’s right, but all happened in the second day of the upgrade; on the first day it work normal.

OK, so it is now working normally, at least some of the time?

I have spoken to some colleagues and the best guess is that this is being caused by an issue with the touchpad. The diagnostic file is full of messages like this:

nov 25 20:34:44 endless kernel: i2c_hid i2c-ELAN1200:00: i2c_hid_get_input: incomplete report (16/16466)

and anecdotally this can cause the system to slow down to the point that normal services fail to start. Searching the web there is some suggestion that this can be triggered by sleeping and waking the computer (rather than shutting it down), so if you find that a shutdown and fresh start avoids the problem, you could try avoiding suspending the computer.

I perceived that there must be a relationship with the touch panel. The computer has worked most of the time, but when suspending, or temporarily locking the computer, the whole system is slow and the touch panel does not work. So, I do not leave my computer suspended to avoid that error, but I would like to ask, is there any way to fix such problem?

While the computer is being used, and without failures, ENDLESS works perfectly; so a second question arises, can I, even with that touch panel problem, install applications that I need? Well at this moment I need to install R, and I hope I can use it without major problems.

There have been past threads about using R on Endless OS, such as:

Another option not mentioned there is to use toolbox, which is pre-installed in Endless OS, to launch a container for some other Linux distribution (such as Fedora) and install R there.

I try whit the post Installing R and R studio, and the option toolbox but really not work. I follow the instructions but on terminal you read “fail open the file”. And, my touch pad still not working…

I have not yet managed to install R or R studio, none of the tutorials work; also, toolbox doesn’t work, at least not on my system.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.