Unable to update Endless 0S 3.2.3


#1

Hi everyone,

I’m having trouble updating my OS.
some assistance will be greatly appreciated.

  • com.endlessm.platform + com.endlessm.apps.platform won’t update.

eos-diagnostic-190418_003936_UTC 0300.txt (230.7 KB)


#2
  1. Open the application called ‘Terminal’
  2. In this application run the command:
rm -f eos-fix-ostree-repo
wget https://raw.githubusercontent.com/endlessm/eos-meta/master/eos-tech-support/eos-fix-ostree-repo
chmod +x eos-fix-ostree-repo
sudo ./eos-fix-ostree-repo && flatpak update -y


#3

Hi Leandro,

I tried that already.
it boils down to:
GLib.Error: g-resolver-error-quark: Error resolving ‘ostree.endlessm.com’: Name or service not known (0)


#4

Settings :arrow_right: Details :arrow_right: Look for updates


#5

Doesn’t work m8.
keeps failing…


#6

@LeandroStanger please do not post random scripts & commands unless you have a detailed understanding of the problem being faced and the solution you are proposing.

@Gillespie, I installed the exact version of Endless that you have and tested the OS upgrade here, it worked fine.

I think what you are facing is a network connectivity problem. Do you have another way of connecting to the internet, or another wifi network, that you could try?

Alternatively in the Terminal app try running: sudo ostree admin upgrade. It may ask for your password.


closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.