Update from 3.9.0 to 3.9.1 failed and keeps failing

  • A few weeks ago my laptop automatically updated from 3.9.0 to 3.9.1. The next time I booted it, it automatically took me to what seemed to be EOS’ First Boot Experience. I refused to go through it at first but after a few unsuccessful attempts trying to fix the issue, I decided to go through it. Once I passed the “add your full name” step, nothing else happened and I was stuck and only left with the option of shutting the computer down.
  • I booted again and, through the GRUB menu, I chose 3.9.0 instead of the newest 3.9.1. It booted well. But I’m still not able of successfully updating to 3.9.1. I get a message saying the computer can’t download updates/files because it’s a read-only file system.
  • I even tried rolling back using pkexec eos-rollback but I got this error message:
    Traceback (most recent call last): File "/usr/bin/eos-rollback", line 52, in <module> locked = sysroot.try_lock() gi.repository.GLib.Error: g-io-error-quark: Read-only file system (21)
  • When trying to generate a screenshot, I couldn’t do it since I kept getting messages saying I don’t have sufficient permissions to save files in the computer. So anything that requires me to download something or even upload something is not possible now.
  • I managed to create an EOS-diagnostics file and a Verbose file but for some reason I can’t upload it here from that computer, so I am using a different one to create this post.

Any help will be appreciated!

It seems something has gone wrong during the Upgrade to 3.9.1. Can you please run:

sudo ostree admin undeploy 0

This will remove the 3.9.1 deployment, leaving you with 3.9.0. Then, after a reboot, please run:

eos-updater-ctl update --force

After this command has been finished, please again reboot, now 3.9.1 should be there. If your problem still persists, please let us know for further assistance.

@egrath Thank you. I performed both instructions, which seemed to work properly, but the issue persists. Any other idea will be much appreciated.

Digging a little bit deeper in your Logs, it seems that your Filesystem has some issues which also need to be fixed. Please follow the instructions in this Thread:

After you performed this, please once again boot into 3.9.0, undeploy 3.9.1 and reinstall it. If the problem then still persists, chances are good that your NVME disk is going to die sooner or later.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.