App Center Issues

After the EOS 5 update I am experiencing some issues with the App Center - the update check takes longer and there are a lot of “Loading Application Details” screens while browsing the pages of the individual apps - it goes to the point where it is very hard to actually use the App Center.

eos-diagnostic-230311_191601_UTC 0200.txt (1.3 MB)

Adding to the above - the overall performance of the system is way worse after updating to EOS 5.

1 Like

Having the same problem.
It’s impossible to do anything with the App Center…

Yes, the AppCenter is quite unresponsive, search for Apps needs a lot of (or better too much) patience.

After having found some App and clicking on it, I have to wait several minutes before I can proceed with installing it. I gave up and restarted AppCenter after having enabled “Settings > Privacy > Metrics” after having seen a hint in journalctl. Now it appears to work better.

Addtional error:

quite recent diagnostic of this system can be found in this post

this “Key expired error” is persisting:

maybe there is an obsolete runtime/application installed. How could I track down, which one?

What do you see if you run

flatpak update -v

in a Terminal window? Do you get the same signature error? The Flatpak CLI may give more details than Software.

What files do you have in: /var/lib/flatpak/repo?

What is the output of:

ostree remote gpg-list-keys

produces lots of messages, please find enclosed the transcript created with

flatpak update -v 2>&gnoring-duplicate-content-rating1 | tee flatpak-update_2023-04-17.txt
sudo flatpak update -v 2>&1 | tee -a flatpak-update_2023-04-17.txt
flatpak-update_2023-04-17.txt (213.8 KB)

see also the discussion in this posting: ignoring duplicate content rating

drwxr-xr-x 7 root root 4096 Apr 17 11:08 .
drwxr-xr-x 8 root root 4096 Apr 17 11:09 …
-rw-r–r-- 1 root root 1837 Apr 11 14:06 config
-rw-r–r-- 1 root root 3896 Dec 27 2017 eos-sdk.trustedkeys.gpg
drwxr-xr-x 3 root root 4096 May 13 2017 extensions
-rw-r–r-- 1 root root 2852 Dec 27 2017 flathub.trustedkeys.gpg
-rw------- 1 root root 0 Dec 27 2017 .lock
drwxr-xr-x 258 root root 4096 May 13 2017 objects
drwxr-xr-x 5 root root 4096 Dec 3 2019 refs
drwxr-xr-x 2 root root 16384 Apr 17 10:55 state
-rw-r–r-- 1 root root 7839581 Jan 10 2020 summary
-rw-r–r-- 1 root root 569 Jan 10 2020 summary.sig
drwxr-xr-x 3 root root 4096 Apr 17 11:09 tmp

Key: 63C3FCD3C48FBF116A2F4ACC9E08D8DABA02FC46
Created: Wed 14 May 2014 08:51:20 PM CEST
Expires: Sat 30 Jun 2029 06:18:11 PM CEST
UID: EOS OSTree Signing Key 1 (EOSK1)
Advanced update URL:
Direct update URL:
Key: 20D52D6D31C3C2C2C24E481AFCF17B17F1F8E157
Created: Sat 11 Jun 2016 07:47:38 PM CEST
Expires: Tue 27 May 2031 12:50:32 AM CEST
UID: EOS Flatpak Signing Key 1 (EFSK1)
Advanced update URL:
Direct update URL:

sorry for the delayed answer …

I’m suspicious of this file. Can you try this to rename it away?

sudo mv /var/lib/flatpak/repo/eos-sdk.trustedkeys.gpg{,.bak}

looks like this salvaged the “Key expired” problem … thanks a lot

but AppCenter is still very unresponsive. Searching for Conjure needs about 20 sec followed by no response for several minutes after clicking into the search result. After more than six (!) minutes I gave up waiting for the detailed information.

once again, searching is almost impossible with the AppCenter, @wjt any news about it?

I switched to the command line for searching and installing, but I consider the CLI a bit uncomfortable …

Can you please run the following command:

{ killall gnome-software; gnome-software --verbose; } > ~/gnome-software.txt

Then, do something in App Center which induces the behavior. Terminate the command line with Ctrl-C and upload the generated file gnome-software.txt from your Home directory here.

I re-tried a search in AppCenter today and apparently AppCenter is usable again, it returns search results in a timely manner, although I don’t know since when. Despite I tried your suggestion and got in the first run a message saying:

GDBus.Error:org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying

then I re-tried it with

{ killall gnome-software; gnome-software --verbose; } > ~/gnome-software.txt 2>&1

and here is the resulting log: gnome-software.txt (801.9 KB)

Current status:

The search works now with an acceptable speed (i.e. searching for MarkDown needs around 10 sec for getting results, but when I try to get more information about a result, by clicking into e.g. ThiefMD, nothing happens at all for several minutes. There is no hint that it is working. I gave up after several minutes (having switched between AppCenter and FireFox (typing this message here). When I guess correctly that I can find ThiefMD under the topic work and scroll down the list manually the detailed info about ThiefMD pops up with a reasonable delay.

So there is still room for improvement.

Since it is apparently not only the AppCenter, which is misbehaving, I started a new thread

and I am still hoping for some help

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.