Missing apps for "Another window session manager"

In this thread @wove suggested to use “Save Desktop” in “Another window session manager” as an alternative to hibernation. In trying to set up “Another window session manager” I encountered the following problem:
There are apparently some package(s) missing on my vanilla EndlessOS 5.0.1. @wove does not remember having installed anything special, so he could not provide any additional tips, what I might install additionally.
What is missing?
How can I install the missing pieces?
Any help is appreciated.
eos-diagnostic-230326_163444_UTC 0200.txt (1.1 MB)

Since it looks like nobody has an idea here, I opened an issue at github.

and got the recommendation to install the missing pieces via apt

Since Endless OS is a Debian derivative distribution, you can install the gtop via:
apt install gir1.2-gtop-2.0 libgtop2-dev

but that won’t be possible. Any ideas what to do under EnndlessOS?

You could use apt after running:

sudo eos-dev-unlock --hotfix

but any packages you install will disappear with each subsequent OS update. I don’t recommend doing this.

You might be able to download the .deb with apt download gir1.2-gtop-2.0, open it in File Roller, extract the .typelib file and copy it to somewhere in /usr/local (which is actually a symbolic link to /var/local, a writeable path). I tried this quickly but it didn’t work. I assumed that /usr/local would be in the gobject-introspection search path, but maybe it is not.

@wjt thanks. nlpsuge modified the package and it starts, but I encountered other problems

@wjt after some modifcation of AWSM by nlpsuge finally AWSM loaded, but it is disfunctional for saving the session on logout/restart/shutdown. It throws an error/exception, for details see in the issue at github. This is as far as I unterstand nlpsuge due to a compatibility problem of gnome-shell 41. Current version of gnome-shell is 44.

Any ideas when EOS will upgrade gnome-shell to a more up-to-date version?

Sorry, no timeline for that at present.

sorry to read that. So this alternative to hibernation is currently not viable and I repeat my plea for hibernation.


Still no news?

No chance for hibernation or saving sessions?

with the new patches for Gnome 41 “Another Window Manager” is able to save applications on shutdown and restart them during startup. It is complaining about being unable to start/use ydotool.service, which was also reported as error for other Linux distributions, where the solution is to install it with the “standard” packet manager, i.e. apt, dnf, etc.

How can I use the ydotool.service under EndlessOS?

In the meantime I created executables with Q4OS, which run apparently without problems in EndlessOS.

Where should I put them and how can I enable my own service?

I guess /usr/local/bin might be a good place, but I still have no idea where to put the ydotool.service file for systemd and what permissions I have to set for it that it can access /dev/uinput.

Since it is quite silent here, I went Googling and found out that I have to create a .config/systemd/user directory and I have put ydotool.service there. I copied the binaries to /usr/local/bin and then asked systemd to reload its config with systemctl --user daemon-reload, enabled and started the service systemctl --user enable ydotool.service && systemctl --user start ydotool.

I am not sure if that is the correct solution, but I hope so. Any comments folks?

everything seems to be fine. I had feared that it is useless since the ydotoold running under my user account cannot access /dev/uinput and I do not want to make it world writeable, but that proved to be wrong. It works at least as far as I can see.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.