Beta Release | Endless OS 3.8.0~beta1

The first beta of Endless OS 3.8.0 is now out. Please follow these instructions if you want to join the beta testing program; bear in mind that the chance of encountering bugs is higher than in a regular stable release. As always, please ensure your data is backed up!

Note that this update is available for Intel and Raspberry Pi 4 users only, updates for ARM/Mini users are currently not available and will be re-enabled in future releases.

GNOME 3.36

In this release the desktop and most of its components were updated to the versions from GNOME 3.36, bringing new features, performance improvements and bug fixes.

Some highlights:

The improved lock screen, including a new password-peeking functionality

The user menu options have been slightly reorganized, including a visible suspend option to make it easier to suspend your computer

The Settings app was also improved in several places, making it easier to navigate

Parental Controls

On new installations, parental controls can now be enabled when you first start the computer, at the same time as creating the main user account.

Once configured, there is now a dedicated Parental Controls application to make it easier to find and adjust the parental controls settings.

Updated hardware support

We have updated our low-level software platform, which should improve stability and hardware compatibility.

  • Linux kernel 5.4, bringing support for the latest PC hardware and several fixes to existing drivers and core kernel code, including security fixes;
  • NVIDIA driver 440.64, adding support for new NVIDIA graphics cards;
  • GRUB 2.04, making us closer to upstream and in turn more stable and secure, due to shipping a more widespread codebase;
  • Low-level userspace components were updated, bringing in new features and bug-fixes: systemd 244, PulseAudio 13, Mesa 19.3.3, among others.

In addition, a number of hardware support bugs were fixed for this release, improving the and expanding the hardware compatibility of Endless OS. We are also collaborating with Linux developers to improve our Raspberry Pi 4 edition, currently released in preview form.

Other Improvements and Changes

  • Updated Chromium. We’ve updated to Chromium 80.0.3987.163 bringing new security fixes to Endless’ built-in web browser.

Known Issues

  • Enabling the “zoom” accessibility feature, either on the login screen or while using the desktop, crashes the graphical interface. If you currently have this feature enabled, disable it before updating to this beta release.

If your desktop or login screen are crashing due to this bug, follow these steps to disable the feature:

  • Start computer

  • Press Ctrl+Alt+F2 to open a text mode session

  • Enter your username, and hit Enter

  • Enter your password, if you have one, and hit Enter

  • Type each of the following commands, and press Enter after each one

    gsettings reset org.gnome.desktop.a11y.applications screen-magnifier-enabled

    sudo -u Debian-gdm -s /bin/sh -c ‘dbus-launch gsettings reset org.gnome.desktop.a11y.applications screen-magnifier-enabled’

  • Press Ctrl+Alt+F1 to return to graphical mode


I’m having an issue running Chromium in this release. The log error is:

/usr/lib/chromium-browser/chromium-browser: error while loading shared libraries: cannot open shared object file: No such file or directory

dpkg -l chromium-browser

chromium-browser 80.0.3987.163+dev77.afe0cd2-28bem1 amd64        Chromium we

ldd /usr/lib/chromium-browser/chromium-browser (0x00007fffa4301000) => /usr/lib/chromium-browser/ (0x00007fd26ea82000) => /lib/x86_64-linux-gnu/ (0x00007fd26ea62000) => /lib/x86_64-linux-gnu/ (0x00007fd26ea41000) => /lib/x86_64-linux-gnu/ (0x00007fd26ea37000) => /lib/x86_64-linux-gnu/ (0x00007fd26e8f6000) => /lib/x86_64-linux-gnu/ (0x00007fd26e8f1000) => /lib/x86_64-linux-gnu/ (0x00007fd26e8c5000) => /lib/x86_64-linux-gnu/ (0x00007fd26e6c2000) => /lib/x86_64-linux-gnu/ (0x00007fd26e6b6000) => /lib/x86_64-linux-gnu/ (0x00007fd26e6b1000) => /lib/x86_64-linux-gnu/ (0x00007fd26e49f000) => /lib/x86_64-linux-gnu/ (0x00007fd26e299000) => /lib/x86_64-linux-gnu/ (0x00007fd26e285000) => /lib/x86_64-linux-gnu/ (0x00007fd26e07b000) => /lib/x86_64-linux-gnu/ (0x00007fd26de75000) => /lib/x86_64-linux-gnu/ (0x00007fd26de17000) => /lib/x86_64-linux-gnu/ (0x00007fd26dcf1000) => /lib/x86_64-linux-gnu/ (0x00007fd26dba3000) => /lib/x86_64-linux-gnu/ (0x00007fd26db6f000) => /lib/x86_64-linux-gnu/ (0x00007fd26db40000) => /lib/x86_64-linux-gnu/ (0x00007fd26daff000) => /lib/x86_64-linux-gnu/ (0x00007fd26da6c000) => /lib/x86_64-linux-gnu/ (0x00007fd26da19000) => /lib/x86_64-linux-gnu/ (0x00007fd26da14000) => /lib/x86_64-linux-gnu/ (0x00007fd26d83c000) => /lib/x86_64-linux-gnu/ (0x00007fd26d7d1000) => /lib/x86_64-linux-gnu/ (0x00007fd26d794000) => /lib/x86_64-linux-gnu/ (0x00007fd26d589000) => /lib/x86_64-linux-gnu/ (0x00007fd26d406000) => /lib/x86_64-linux-gnu/ (0x00007fd26d305000) => /lib/x86_64-linux-gnu/ (0x00007fd26d2da000) => /lib/x86_64-linux-gnu/ (0x00007fd26d2a4000) => /lib/x86_64-linux-gnu/ (0x00007fd26d293000) => /lib/x86_64-linux-gnu/ (0x00007fd26d245000) => /lib/x86_64-linux-gnu/ (0x00007fd26d125000) => /lib/x86_64-linux-gnu/ (0x00007fd26d0ef000) => /lib/x86_64-linux-gnu/ (0x00007fd26c9fc000) => /lib/x86_64-linux-gnu/ (0x00007fd26c8fd000) => /lib/x86_64-linux-gnu/ (0x00007fd26c8d6000) => /lib/x86_64-linux-gnu/ (0x00007fd26c8bc000) => /lib/x86_64-linux-gnu/ (0x00007fd26c6fb000)
/lib64/ (0x00007fd27894d000) => /lib/x86_64-linux-gnu/ (0x00007fd26c63c000) => /lib/x86_64-linux-gnu/ (0x00007fd26c635000) => /lib/x86_64-linux-gnu/ (0x00007fd26c431000) => /lib/x86_64-linux-gnu/ (0x00007fd26c22b000) => /lib/x86_64-linux-gnu/ (0x00007fd26c21f000) => /lib/x86_64-linux-gnu/ (0x00007fd26c1ab000) => /lib/x86_64-linux-gnu/ (0x00007fd26c1a2000) => /lib/x86_64-linux-gnu/ (0x00007fd26c19d000) => /lib/x86_64-linux-gnu/ (0x00007fd26c150000) => /lib/x86_64-linux-gnu/ (0x00007fd26bf8f000) => /lib/x86_64-linux-gnu/ (0x00007fd26bf81000) => /lib/x86_64-linux-gnu/ (0x00007fd26bf6c000) => /lib/x86_64-linux-gnu/ (0x00007fd26bf4e000) => /lib/x86_64-linux-gnu/ (0x00007fd26beab000) => /lib/x86_64-linux-gnu/ (0x00007fd26bea5000) => /lib/x86_64-linux-gnu/ (0x00007fd26be46000) => /lib/x86_64-linux-gnu/ (0x00007fd26be1b000) => /lib/x86_64-linux-gnu/ (0x00007fd26bdff000) => /lib/x86_64-linux-gnu/ (0x00007fd26bde7000) => /lib/x86_64-linux-gnu/ (0x00007fd26bba2000) => /lib/x86_64-linux-gnu/ (0x00007fd26bb85000) => /lib/x86_64-linux-gnu/ (0x00007fd26bb7a000) => /lib/x86_64-linux-gnu/ (0x00007fd26ba71000) => /lib/x86_64-linux-gnu/ (0x00007fd26b9ca000) => /lib/x86_64-linux-gnu/ (0x00007fd26b710000) => /lib/x86_64-linux-gnu/ (0x00007fd26b6d7000) => /lib/x86_64-linux-gnu/ (0x00007fd26b6d2000) => /lib/x86_64-linux-gnu/ (0x00007fd26b6c3000) => /lib/x86_64-linux-gnu/ (0x00007fd26b6b5000) => /lib/x86_64-linux-gnu/ (0x00007fd26b673000) => /lib/x86_64-linux-gnu/ (0x00007fd26b66a000) => /lib/x86_64-linux-gnu/ (0x00007fd26b665000) => /lib/x86_64-linux-gnu/ (0x00007fd26b654000) => /lib/x86_64-linux-gnu/ (0x00007fd26b522000) => /lib/x86_64-linux-gnu/ (0x00007fd26b51b000) => /lib/x86_64-linux-gnu/ (0x00007fd26b501000) => /lib/x86_64-linux-gnu/ (0x00007fd26b421000) => /lib/x86_64-linux-gnu/ (0x00007fd26b3ed000) => /lib/x86_64-linux-gnu/ (0x00007fd26b3e7000) => /lib/x86_64-linux-gnu/ (0x00007fd26b3d6000) => /lib/x86_64-linux-gnu/ (0x00007fd26b3cf000) => /lib/x86_64-linux-gnu/ (0x00007fd26b2a0000) => /lib/x86_64-linux-gnu/ (0x00007fd26b281000) => /lib/x86_64-linux-gnu/ (0x00007fd26b0ff000) => /lib/x86_64-linux-gnu/ (0x00007fd26b0eb000) => /lib/x86_64-linux-gnu/ (0x00007fd26b0b1000) => /lib/x86_64-linux-gnu/ (0x00007fd26b078000) => /lib/x86_64-linux-gnu/ (0x00007fd26aff5000) => /lib/x86_64-linux-gnu/ (0x00007fd26afcd000) => /lib/x86_64-linux-gnu/ (0x00007fd26afae000) => /lib/x86_64-linux-gnu/ (0x00007fd26ae90000) => /lib/x86_64-linux-gnu/ (0x00007fd26ae39000) => /lib/x86_64-linux-gnu/ (0x00007fd26ae30000) => /lib/x86_64-linux-gnu/ (0x00007fd26ae26000) => /lib/x86_64-linux-gnu/ (0x00007fd26adf9000) => /lib/x86_64-linux-gnu/ (0x00007fd26add4000)

And I’ve attached an eos-diagnostic eos-diagnostic-200417_161552_UTC 0100.txt (3.0 MB)

Hi @nedrichards, thanks for the report. I am trying to understand what is going on here and am a bit lost. I tried the exact same versions here and everything seems to work fine and also as you can see from your ldd output above, chromium is linking to (opposed to

Could you please check the output of the following commands please:

$ ldd /var/lib/codecs/chromium-browser/ | grep openh264
$ ldd /usr/lib/chromium-browser/ | grep openh264

The only thing I can think of that could be breaking is that you have an old linking to on /var/lib/codecs/chromium-browser, but if that is the case we need to understand why this happens to you.

OK, this is deeply strange. After a reboot it now launches fine and I’m seeing those lld’s linking to => /lib/x86_64-linux-gnu/ (0x00007fd3d2d1f000)

So everything seems fine?!? I’m almost more suspicious now that it works than when I thought it didn’t.

@nedrichards Good to know it works now.

I suspect you had an old linking to lying around on /var/lib/codes/chromium-browser and after reboot it got updated (it gets updated by eos-codecs-activate.service). But if that is the case why it didn’t get updated in the first place when you upgraded to beta1 and rebooted is a mistery.

Yeah, that makes sense. This device had paid and unlocked codecs back in the day, if that makes a difference.

We’ve detected an issue on eos-codecs-activate that would prevent it from updating the codecs if the old one had the same size as the new one. This will be fixed in final 3.8.0.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.