Help me recover documents. Endless OS fails to boot

After about a year working fine, Endless is unable to boot. At first it stuck on the Endless boot logo. After many attempts to boot, it now gets stuck past the logo, on a blank screen.

I already captured some behind the scenes images and selecting from the previous installations in the “Advanced” section of the Boot Menu, as suggested by @egrath here. I have “Endless 3.6.3” and “Endless 3.6.4” and both fail to work.

I would like to be able to recover my documents.
Here is what I managed to capture during boot:

There’s something strange happening as your filesystem gets mounted read-only and thats the reason your system does not come up.

To get more information, we need a complete log of whats going on during boot. The easiest way to archieve this, is to:

  1. Enter the Bootloader by holding Shift (BIOS-Boot) or ESC (UEFI-Boot)
  2. Press E to edit the default boot entry.
  3. Remove splash and quiet from the boot list (navigate with cursor, remove with backspace):

  1. Boot with F10 and record the entire boot sequence with your mobile phone. You should now also see the very early boot messages.

Is there anything interesting in? Something with can help us analyze the problem?

1 Like

I apologize for the quality of the image. I did my best to choose the best video-frames and to remove some overlapping info but I don’t know what to look for, unfortunately. I suspect FAILED is bad and I hope I did’t put them in the wrong order. Thank you for understanding

Seems like your root-Filesystem is corrupted. Let’s try to fix that.

Boot your PC to the Boot manager and edit the boot entry to like like:

and boot with F10.

Now you’ve been in the emergency shell. Enter the following commands:

umount /sysroot
fsck /dev/sda2

In my case there’s little output since my root-Filesystem is clean, but in your case, there should be messages displayed. Enter yes when prompted if problems should be fixed.


When finished, enter:


Then power cycle your PC. If you system will still not come up, there’s a good chance that your SSD is dying.

1 Like

fsck /dev/sda2
I got this error:

type mount and check from which partition /sysroot is mounted before unmounting. Use this partition for the fsck command.

1 Like

I couldn’t see /sysroot in the result of mount. Probably I don’t know where to look:

but I just tried
unmount /dev/sda3
fsck /dev/sda3

and it fixed a lot of stuff. I ran fsck again just to see it’s clean.
The system didn’t find the command sync

At this point I tried to boot and it works!
Thank you very much for your help. Is there anything else I should check?

I would highly recomment you to make a Backup of your Data. A corrupted filesystem normally only occurs when either:

  • The disk is going to die
  • The system has been powered off without a shutdown

If you never simply turned off your system while it was running, chances are good that the first one is slowly approaching.

1 Like

Yes, the system was repeatedly powered off without shutdown, my fault. I will backup and try to change the bad habit.
Thank you again for your help.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.