Internet connection keeps breaking up

Hi all,

A lot of the time my internet connection is gone. Very annoying.
While on other pc and phones it’s still ok.
The whole day, it’s only on my laptop. All the other devices are doing great.

So, either it’s completely gone, or it’s very slow. (have connection 600mb fibre optic)
Could it be something with my wi-fi adapter?

Already did the eos-diagnostic.
Hopefully someone can find something that will help.

Thanks very much

eos-diagnostic-210504_114723_UTC 0100.txt (3.3 MB)

I assume a power management issue - which is often a issue with the chipset used in your card. Please follow the instructions in the following Thread to fix it:

Hi egrath,

Thanks for your reply.
I did as you asked.

After this, I restarted.
But I don’t know if anything happend?
What can I do to check it? Do I just continue using my laptop and see if it’s ok or ?

Thank you!

You don’t see any immediate effect. Just keep using your computer as usual and keep an eye on wifi issues.

Alright. Will do that.
Will let you know when I see some effects.

Thanks very much!

Alright, after a few hours of normal pc use I can say that it’s not better…
Ik keeps cutting off or some moments it’s very very slow…
Other moments there seems to be no problem.

Again, on 3 other devices there is no problem.
Laptop is only 1 year old.

Thanks for finding some solutions!

Can you please do a diagnostic immediatly after the problem has occured and upload it. Also write down the exact time and tell us so that we can correlate the timeframe with the information in the log.

Ok, I will do that. (could be today or even tomorrow …)
Better just after the problem? Or during the problem (if possible)?
At the moment everything seems ok, but that can change fast :frowning:
Thank you!

That doesn’t matter, relevant is the diagnostic and the time when it happened.

Hi egrath,

At the moment it’s very slow. Downloading a map of 80 mb, tells me it will take 2 hours!! :frowning:
Also opening this web-page took me a couple of minutes.
So I did the diagnostic at this moment. (also uploading this file is very slow )
Hope we can fix this. Thanks very much!!
eos-diagnostic-210506_160908_UTC 0100.txt (2.4 MB)

And just as I press enter to post this previous message, the download is completed…
Back to “normal” ?!?! So strange.
Anyway, the diagnostic was from during this slow time.

It seems that your Wireless card is continiously scanning for the Wireless network when the issue occurs. Can you please try the following:

  1. Open Wireless settings and navigate to “Identity”
  2. Enter the following Text into the BSSID field: 0c:8e:29:97:ab:37
  3. Apply the settings, then restart your computer
  4. Verify if that helped

With this settings we “pin” your Access Point, so the card is no longer scanning and simply connects to this Access Point when in Range.

Thank you egrath.

I did as you say. The BSSID field was blank, but also had 2 options to choose, where the text you said was one of them.
Did apply, then restart.
Now, I will continue using the pc and hope that it helped.

I will let you know asap if it worked or not.

Already would like to thank you for helping me. Really appreciate it !

Alright, so after a few hours of using my pc, it seems the problem is not fixed…
It keeps cutting off, and very slow…
Also I notice every time I use the Bluetooth, I get a lot of messages on the top right of my screen that says: Activation of network connection failed.
This is the same message that I get when my wifi is completely gone.
It’s not that the wifi only cuts off only when I have mu Bluetooth on. But maybe an error in the same line?

Bluetooth and WIFI are handled by the same piece of hardware and low-level driver in the system, so yes, chances are good that the issues are related. Unfortunately i’m running out of ideas how to fix the issue. A few more ideas:

  1. Try to completely reset the Network Manager configuration:
sudo rm -Rf /etc/NetworkManager/*

(then, reboot)

  1. Try a Live CD with Ubuntu to see if the error is there too. This would help in diagnosing if it’s a hardware or software issue. Use the most recent Ubuntu version available.

  2. If (2) has no issues, switch to EOS Development branch, which has much newer software components and eventually has a fix for the issue. It may have other side effects though. (i’m running the development branch for a few months now without issues).

Ok, I tried the reset, which worked, because when I restarted I had to give the wifi pass.
Hope for this to work.

Try a cd is at the moment not possible, because I don’t have a cd space on my laptop…
So, would have to buy an external one. But maybe I’ll just do that…
But have no idea on how to do steps 2 and 3.
I’m a true noob on these issues…

I’m just thinking that I think the problem started when I moved to a new place… So with new wifi.
In my previous place I don’t think I had this problem… (only the Bluetooth connection warning)
Could it be something with this router for wifi ? Maybe just a configuration on there?
Just thinking out loud, maybe stupid, I don’t know.

Also, when my girlfriend is uploading some files/pictures on her laptop, it disturbes my Bluetooth.
But when I’m uploading, no problem…
Weird things.

Thank you!

You don’t need a CD drive for running a Live CD :slight_smile: That’s just a relic from years ago - if you download a Live CD from e.g. Ubuntu, you can use the Fedora Media Writer to “write” it to a USB stick and boot from it.

As Bluetooth and Wifi both use the 2.4 Ghz Frequency, it’s often the case that bluetooth has issues when there’s a huge amount of noise in the air (from Wifi, your Microwave Ofen, a DECT wireless Phone, …). For example, when i do large transfers over Wifi i can’t use a Bluetooth mouse at it gets laggy. One solution to this is to connect to the 5 Ghz Wifi which most Routes today support. This Band is not that polluted as the 2.4 and works more reliable in most environments, especially in cities where you probably have neighbors with Wifi Networks.

Try if your Router has this option and connect to the 5 Ghz Network. If this is not possible or if the current steps don’t work reliably, we will do the switch to the development branch together :slight_smile:

lol, told you I was a noob :slight_smile:

The strange thing is that last year on my previous location there wasn’t any problem and we had a internet connection up to 50MB fibre optic. (When tested I always had around 30MB download and upload speed)
Now we have a internet connection up to 600MB fibre optic… (Now when testing my speed it’s around 40MB download and 50MB upload …)

The installer of the router (Orange) that we have now told us that this new router automaticly switches to the best connection. Between 2.4 Ghz and 5 Ghz …

I’ll have to go in the routers address: 192. … ? And see if I can change the frequency?
Would that be for all devices? Because I have a mobil phone that doesn’t support 5Ghz, and the laptop of my girlfriend either … :frowning:

Thanks for your patience … :slight_smile:

It depends on your network and your router model. If the router supports it, i would recommend you to broadcast another SSID on the 5 Ghz Band and connect to it.

The address of your router is - good luck.

/edit: Just looked again at your Diagnostic. It seems that your Router does not broadcast a 5 Ghz Wifi network at the moment. If you configure to router to do so, please also remove the BSSID entry from the network configuration as they differ from 2.4 and 5 ghz in your case.

What do you think I should do here?
It also says this on the side: Automatic Wi-Fi channel selection

AUTO 1: Selects the optimal channel in any of the bands: U‑NII‑1, U-NII-2, U-NII-2ext
AUTO 2: Selects the optimal channel only in band U-NII-1. Use this mode in case some of your devices sometimes cannot detect the 5GHz WiFi signal